Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Missing artifact org.eclipse.virgo.mirrored:org.eclipse.osgi:jar:3.8.0.v20120508-2119
Missing artifact org.eclipse.virgo.mirrored:org.eclipse.osgi:jar:3.8.0.v20120508-2119 [message #899595] Wed, 01 August 2012 14:27 Go to next message
Will Yao is currently offline Will Yao
Messages: 11
Registered: July 2010
Junior Member
Hi all:

When I add following dependencies in my pom.xml:
...
		<dependency>
			<groupId>org.eclipse.virgo.teststubs</groupId>
			<artifactId>org.eclipse.virgo.teststubs.osgi</artifactId>
			<version>3.5.0.RELEASE</version>
			<scope>test</scope>
		</dependency>
		<dependency>
			<groupId>org.eclipse.virgo.test</groupId>
			<artifactId>org.eclipse.virgo.test.framework</artifactId>
			<version>3.5.0.RELEASE</version>
			<scope>test</scope>
		</dependency>
...

I got following errors:
Multiple annotations found at this line:
	- Missing artifact org.eclipse.virgo.mirrored:ch.qos.logback.classic:jar:1.0.0.v20111214-2030
	- Missing artifact org.eclipse.virgo.mirrored:org.eclipse.equinox.event:jar:1.2.100.v20111010-1614
	- Missing artifact org.eclipse.virgo.mirrored:org.eclipse.equinox.cm:jar:1.0.400.v20120319-2029
	- Missing artifact org.eclipse.virgo.mirrored:org.eclipse.equinox.log:jar:1.2.200.v20111010-1614
	- Missing artifact org.eclipse.virgo.mirrored:org.slf4j.jul:jar:1.6.4.v20120130-2120
	- Missing artifact org.eclipse.virgo.mirrored:org.slf4j.api:jar:1.6.4.v20120130-2120
	- Missing artifact org.eclipse.virgo.mirrored:org.eclipse.equinox.region:jar:1.1.0.v20120319-1602
	- Missing artifact org.eclipse.virgo.mirrored:org.eclipse.osgi:jar:3.8.0.v20120508-2119
	- Missing artifact org.eclipse.virgo.mirrored:org.eclipse.osgi.services:jar:3.3.0.v20120307-2102
	- Missing artifact org.eclipse.virgo.mirrored:ch.qos.logback.slf4j:jar:1.0.0.v20120123-1500
	- Missing artifact org.eclipse.virgo.mirrored:com.springsource.org.aspectj.weaver:jar:1.6.12.RELEASE



Where can I download these artificts?

My pom.xml :
	<repositories>
		...
		<repository>
			<id>virgo-release</id>
			<url>[url]http://build.eclipse.org[/url] /rt/virgo/maven/bundles/release</url>
			<releases>
				<enabled>true</enabled>
			</releases>
			<snapshots>
				<enabled>false</enabled>
			</snapshots>
		</repository>
		<repository>
			<id>virgo-milestone</id>
			<url>[url]http://build.eclipse.org[/url] /rt/virgo/maven/bundles/milestone</url>
			<releases>
				<enabled>true</enabled>
			</releases>
			<snapshots>
				<enabled>false</enabled>
			</snapshots>
		</repository>
                ...
	</repositories>



thx!!!

[Updated on: Wed, 01 August 2012 14:28]

Report message to a moderator

Re: Missing artifact org.eclipse.virgo.mirrored:org.eclipse.osgi:jar:3.8.0.v20120508-2119 [message #899614 is a reply to message #899595] Wed, 01 August 2012 15:03 Go to previous messageGo to next message
Borislav Kapukaranov is currently offline Borislav Kapukaranov
Messages: 80
Registered: September 2010
Member
Unfortunatelly these artifacts are only available in Virgo's Ivy build.eclipse.org repository at the moment. If you can consume Ivy repositories from Maven then that should solve the issue.
If you can't it would be best to open a bug so that we take care of publishing them also in our Maven repos.
Re: Missing artifact org.eclipse.virgo.mirrored:org.eclipse.osgi:jar:3.8.0.v20120508-2119 [message #899702 is a reply to message #899614] Thu, 02 August 2012 00:35 Go to previous message
Will Yao is currently offline Will Yao
Messages: 11
Registered: July 2010
Junior Member
I have report a bug: https://bugs.eclipse.org/bugs/show_bug.cgi?id=386456
Previous Topic:How to configure Embeded tomcat settings programatically in Virgo
Next Topic:Virgo Server for Apache Tomcat - Production Usage
Goto Forum:
  


Current Time: Mon Sep 22 04:16:00 GMT 2014

Powered by FUDForum. Page generated in 0.05562 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software