Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » My report is PAGE BROKEN on SOME pages although I didn't use PAGE BREAK
My report is PAGE BROKEN on SOME pages although I didn't use PAGE BREAK [message #899353] Tue, 31 July 2012 14:23 Go to next message
Dejan Vujanic is currently offline Dejan VujanicFriend
Messages: 66
Registered: October 2011
Member
Hi,

I have a list of records and after some pages on example on fifth or fourth my BIRT report is PAGE BROKEN. I didn't use anywhere in report PAGE BREAK so why does it happen and how to solve this?

thanks - i attached example (one table with list of records but on the fifth page it is broken- why? ) If there is need I can attach and BIRT report.

Thanks
Re: My report is PAGE BROKEN on SOME pages although I didn't use PAGE BREAK [message #899397 is a reply to message #899353] Tue, 31 July 2012 16:39 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

What version of BIRT are you using? Select the table and click on the
page break tab in the Property Editor. Try setting your page break
interval to 0.

Jason

On 7/31/2012 10:23 AM, Missing name Mising name wrote:
> Hi,
>
> I have a list of records and after some pages on example on fifth or fourth my BIRT report is PAGE BROKEN. I didn't use anywhere in report PAGE BREAK so why does it happen and how to solve this?
>
> thanks - i attached example (one table with list of records but on the fifth page it is broken- why? ) If there is need I can attach and BIRT report.
>
> Thanks
>
Re: My report is PAGE BROKEN on SOME pages although I didn't use PAGE BREAK [message #899560 is a reply to message #899397] Wed, 01 August 2012 12:37 Go to previous messageGo to next message
Dejan Vujanic is currently offline Dejan VujanicFriend
Messages: 66
Registered: October 2011
Member
Again of course you solved it.- thank you

When I set it to 0 it was solved.
It was by default set to 50 - so do you have maybe explanation why does it broke it on 5 fifths page - and it is only broken on my twelve page report.

Thanks!!!!
Re: My report is PAGE BROKEN on SOME pages although I didn't use PAGE BREAK [message #899643 is a reply to message #899560] Wed, 01 August 2012 16:07 Go to previous message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

This has to do with how pagination real estate is calculated. In the
latest releases of BIRT we try to size html and pdf identically. The
page break interval does a hard page break and is reset after each html
page break. When this setting is higher than what would fit on a pdf
page this introduces inconsistent rendering. We probably need to
default this to 0. If you look at your layout and change it from fixed
to auto it may be a bit more obvious. Auto layout does not produce
identical outputs.

Jason

On 8/1/2012 8:37 AM, Missing name Mising name wrote:
> Again of course you solved it.- thank you
>
> When I set it to 0 it was solved.
> It was by default set to 50 - so do you have maybe explanation why does
> it broke it on 5 fifths page - and it is only broken on my twelve page
> report.
>
> Thanks!!!!
Previous Topic:BIRT Engine and server doesn't respond
Next Topic:BIRT 4.2.0
Goto Forum:
  


Current Time: Sun Nov 23 22:41:25 GMT 2014

Powered by FUDForum. Page generated in 0.02108 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software