Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » Updating Jenkins workspace
Updating Jenkins workspace [message #899197] Mon, 30 July 2012 22:49
Alex Kravets is currently offline Alex Kravets
Messages: 372
Registered: November 2009
Senior Member
Hi,

I used to run Buckminster builds in Hudson on Windows. Recently I moved to CentOS and I am experiencing issues with updating workspace during cquery resolution that worked on Windows machine.

On Windows machine svn strategy was to always checkout fresh copy and that worked fine, although I never figured out why update didn't work. On CentOS we are running Jenkins instead of Hudson, which I don't think should make a difference. If I set svn strategy to svn update then nothing happens - no update occurs and the build continues without update. Setting to always checkout fresh copy also does not do anything, although I expect it to delete workspace and checkout everything anew as it does no Windows. Finally, svn revert option also does not do any update - Perhaps it's permission issue on what particular user or user of a group can do.

When I set check out fresh or perform update on my build feature, which is checked out using Jenkin's Subversion module it does what I expect - either delete everything or update. Only those components that were checkout using cquery are not being updated.

Has anybody else dealt with this kind of issue? I am thinking that is some kind of permission issue on Linux.

Thanks,
Alex

Previous Topic:How to obfuscate
Next Topic:Building a p2 site for patched features/plugins
Goto Forum:
  


Current Time: Sat Jul 26 01:13:09 EDT 2014

Powered by FUDForum. Page generated in 0.02842 seconds