Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Lua Development Tools » Contributing bugfix for debugger.lua
Contributing bugfix for debugger.lua [message #899060] Mon, 30 July 2012 11:47 Go to next message
Richard Geary is currently offline Richard GearyFriend
Messages: 14
Registered: July 2012
Junior Member
Hi,

I've got a bugfix for the debugger.lua file, how do I contribute it?

The init() function doesn't wait for the debugger to connect if you'd connected once before in a previous session. On the first read, it would error with "Closed" message. I've modified it to attempt to read 0 bytes from the socket after it's sent the init message, and loop if it returns "closed".

Thanks,
Richard
Re: Contributing bugfix for debugger.lua [message #899080 is a reply to message #899060] Mon, 30 July 2012 13:46 Go to previous message
Simon Bernard is currently offline Simon BernardFriend
Messages: 290
Registered: July 2009
Senior Member
Hi,
You could check if the bug does not already exist and if not, you could open one and add your patch as attachement.
We will have a look on it as soon as we can and we will see if we can integrate it.
Thx you for your involvement Wink.
Previous Topic:Debug Variable Window, Tables wrong order
Next Topic:Setting up for the first time
Goto Forum:
  


Current Time: Sat Dec 20 14:40:27 GMT 2014

Powered by FUDForum. Page generated in 0.13108 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software