Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » eglplatform.h issue(eclipse can use egl functions but doesnt recognize the eglplatform variables declared in them)
eglplatform.h issue [message #897953] Wed, 25 July 2012 13:49
jan schuerman is currently offline jan schuermanFriend
Messages: 2
Registered: July 2012
Junior Member
Im my testing application i am trying to native use open GLES but when calling egl functions that require eglplatform.h variables or using those variables themselves eclipse puts erros these are the problems:

m_Display = eglGetDisplay(EGL_DEFAULT_DISPLAY);
m_Surface = eglCreateWindowSurface(m_Display, lConfig,
m_Application->window, NULL);

nvalid arguments ' Candidates are: void * eglGetDisplay(?)

Type 'EGL_DEFAULT_DISPLAY' could not be resolved

Invalid arguments ' Candidates are: void * eglCreateWindowSurface(void *, void *, ?, const int *)

EGL_DEFAULT_DISPLAY is declared in egl.h but it is based on a variable from eglplatform.h so also isnt accepted,

I`m at a los of how to fix this, ive tried including eglplatform.h itself but it doesnt change anything

greets
Previous Topic:Save run-time warnings in Console window
Next Topic:[SOLVED] Debugger very slow (~ 10 sec between two steps) !
Goto Forum:
  


Current Time: Fri Dec 19 15:52:32 GMT 2014

Powered by FUDForum. Page generated in 0.02049 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software