Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Snippet 277
Snippet 277 [message #897565] Tue, 24 July 2012 14:04 Go to next message
Gerald Radix is currently offline Gerald Radix
Messages: 9
Registered: April 2012
Junior Member
Hi,

I would like to use snippet277 for downloading.

But with xulrunner-1.9.2.19 in debian squeeze, but nothing happens...

any idea ?
Re: Snippet 277 [message #899133 is a reply to message #897565] Mon, 30 July 2012 15:49 Go to previous message
Grant Gayed is currently offline Grant Gayed
Messages: 2151
Registered: July 2009
Senior Member
Your description of what happens for you is a bit vague, so the
following are guesses:

- Snippet277 uses JavaXPCOM, so the javaxpcom.jar in your XULRunner's
root directory needs to be on your .classpath
- I believe that Snippet277 was written prior to the days of XULRunner
1.9.2.x, so it's quite possible (likely) that some of the JavaXPCOM
interfaces it uses do not match what you have in 1.9.2.19. The
snippet's javadoc should have some words added to indicate this. You
may need to make some changes to the snippet to adapt it to the
interfaces in your XULRunner.

Grant


On 7/24/2012 10:04 AM, Gerald Radix wrote:
> Hi,
>
> I would like to use snippet277 for downloading.
>
> But with xulrunner-1.9.2.19 in debian squeeze, but nothing happens...
>
> any idea ?
Previous Topic:SWT an xulrunner
Next Topic:Drag n drop on tree not showing more than one item unless its not expanded after adding first item
Goto Forum:
  


Current Time: Sat Oct 25 13:34:44 GMT 2014

Powered by FUDForum. Page generated in 0.04620 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software