Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » [Acceleo] Error on BPEL to Java transformation([SOLVED] Acceleo fails to generate files from a BPEL to Java basic transformation)
icon4.gif  [Acceleo] Error on BPEL to Java transformation [message #896870] Fri, 20 July 2012 08:12 Go to next message
AxA AxA is currently offline AxA AxAFriend
Messages: 5
Registered: July 2012
Junior Member
Hi guys,

is there anyone who has tried a transformation from BPEL or WSDL and could maybe share some hints?

I'm using Eclipse Modeling Juno 4.2 and Acceleo 3.3.0 and I'm stuck at the real beginning.
I created a project, loaded the bpel.ecore, and made a very simple .mtl file that should just create a java file (I tried to create this file both with a fixed name or with the name of the BPEL process) but I keep getting the error:

Quote:
The generation failed to generate any file because there are no model elements that matches at least the type of the first parameter of one of your main templates. The problem may be caused by a problem with the registration of your metamodel, please see the method named "registerPackages" in the Java launcher of your generator. It could also come from a missing [comment @main/] in the template used as the entry point of the generation.



Here is my Acceleo generate.mtl file:

[comment encoding = UTF-8 /]
[module generate('http:///org/eclipse/bpel/model/bpel.ecore')]

[template public generateElement(aProcess : Process)]
[comment @main /]
[file (aProcess.name, false, 'UTF-8')]
[/file]
[/template]


and here the input .bpel file (just a part of it) :

<!-- BPEL_sayHelloProcess BPEL Process [Generated by the Eclipse BPEL Designer] -->
<!-- Date: Wed Jul 18 11:00:50 CEST 2012 -->
<bpel:process name="BPEL_sayHelloProcess"
         targetNamespace="httX://bpeltojava.uni" (can't insert links)
         suppressJoinFailure="yes"
....
....
</bpel:process>


I guess the problem might come from the registration of the metamodel, but I checked another transformation from UML-->Java (that works fine) and I couldn't find useful differences to help me out

Thank you Smile

[Updated on: Thu, 26 July 2012 12:48]

Report message to a moderator

Re: [Acceleo] Error on BPEL to Java transformation [message #898471 is a reply to message #896870] Thu, 26 July 2012 12:46 Go to previous messageGo to next message
AxA AxA is currently offline AxA AxAFriend
Messages: 5
Registered: July 2012
Junior Member
It seems I found out the problem.

I downloaded and installed Eclipse Indigo Modeling 3.7.2, added the Acceleo 3.3 plugin from the update site, and the BPEL plugin version 1.0 and the Acceleo transformation works right away, no particular things to do, I simply don't get the error anymore.

I think the problem relies, as I already experienced here http://www.eclipse.org/forums/index.php/m/895663/#msg_895663 while doing some tutorials on BPEL, within Eclipse Juno and the BPEL plugin.

Hope this will help somebody else encountering same troubles
Re: [Acceleo] Error on BPEL to Java transformation [message #1014789 is a reply to message #898471] Tue, 26 February 2013 13:21 Go to previous message
GAALOUL Haithem is currently offline GAALOUL HaithemFriend
Messages: 4
Registered: February 2013
Junior Member
hello can you tell me where you found the plugin bpel 1.0?? i don't found it any where!
i must get a transformation BPEL to JAVA can you help me i can't do it with acceleo plugin! have you some tutorial ?
Previous Topic:Use of project name in Xpand template
Next Topic:EMF topological sort
Goto Forum:
  


Current Time: Fri Dec 19 10:14:27 GMT 2014

Powered by FUDForum. Page generated in 0.03835 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software