Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » After drag&drop, the node was deleted when i reopen the editor(drag&drop)
After drag&drop, the node was deleted when i reopen the editor [message #895727] Sun, 15 July 2012 08:16
Michael Qian is currently offline Michael Qian
Messages: 1
Registered: July 2012
Junior Member
Hi All,

I'm trying to do drag & drop between treeviewer and editor. And now I can create a shortcut in the editor. But when I reopen the editor, the shortcut disappeared.

And I check the diagram file. The element I draged was deleted.

I compare the diagram file between mine and the Papyrus'. The element href has the format like "href="modelfilename#//@children.0"". But I look at the Papyrus notation file and find that the element href is like "href="modelfilename#id"".

Is that why I can't create a shortcut of a model in another modelfile? Or there is another reason?

--------------------------------------------------------------
In the refreshSemantic() method of **CanonicalEditPolicy class, it call the "deleteViews". That will delete the views if it can't find the model of the view(I think so).

Thanks in adavance!

Michael

[Updated on: Sun, 15 July 2012 09:22]

Report message to a moderator

Previous Topic:Save/Load model from RCP application
Next Topic:Adding Content Assist to a WrappingLabel?
Goto Forum:
  


Current Time: Thu Jul 24 23:41:08 EDT 2014

Powered by FUDForum. Page generated in 0.09317 seconds