Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BPMN 2.0 Modeler » Is latest BPMN2 Modeler compatible with Eclipse 3.8??
Is latest BPMN2 Modeler compatible with Eclipse 3.8?? [message #895653] Sat, 14 July 2012 02:17 Go to next message
Mohammed Razak is currently offline Mohammed Razak
Messages: 3
Registered: July 2012
Junior Member
I am trying to use latest BPMN2 modeler in Eclipse 3.8 but was unable to create or open any Bpmn2 diagram file.


Steps to reproduce:

1.Download Eclipse 3.8

2.Update the eclipse with latest BPMN2 modeler - http://download.eclipse.org/bpmn2-modeler/site/
Note:This will get Graphiti plugins of 0.9 version

3.Create bpmn2 diagram file and press Finish button in the 'BPMN2 Diagram File' wizard

Error dialog with message 'org/eclipse/bpmn2/modeler/ui/wizards/FileService$MyDiagramEditorFactory' gets displayed.


4.Copy any existing bpmn2 diagram file and open it with 'BPMN2 Diagram Editor'

NoClassDefFoundError is thrown

Stack trace:

java.lang.NoClassDefFoundError: org/eclipse/bpmn2/modeler/ui/wizards/FileService$MyDiagramEditorFactory
at org.eclipse.bpmn2.modeler.ui.wizards.FileService.createEmfFileForDiagram(FileService.java:66)
at org.eclipse.bpmn2.modeler.ui.wizards.BPMN2DiagramCreator.createDiagram(BPMN2DiagramCreator.java:60)
at org.eclipse.bpmn2.modeler.ui.editor.BPMN2Editor.createNewDiagramEditorInput(BPMN2Editor.java:253)
at org.eclipse.bpmn2.modeler.ui.editor.BPMN2Editor.init(BPMN2Editor.java:169)
at org.eclipse.ui.part.MultiPageEditorPart.addPage(MultiPageEditorPart.java:237)
at org.eclipse.bpmn2.modeler.ui.editor.BPMN2MultiPageEditor.createDesignEditor(BPMN2MultiPageEditor.java:244)
at org.eclipse.bpmn2.modeler.ui.editor.BPMN2MultiPageEditor.createPages(BPMN2MultiPageEditor.java:232)
at org.eclipse.ui.part.MultiPageEditorPart.createPartControl(MultiPageEditorPart.java:348)
at org.eclipse.ui.internal.EditorReference.createPartHelper(EditorReference.java:670)
at org.eclipse.ui.internal.EditorReference.createPart(EditorReference.java:465)
at org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:595)
at org.eclipse.ui.internal.PartPane.setVisible(PartPane.java:315)
at org.eclipse.ui.internal.presentations.PresentablePart.setVisible(PresentablePart.java:180)
at org.eclipse.ui.internal.presentations.util.PresentablePartFolder.select(PresentablePartFolder.java:270)
at org.eclipse.ui.internal.presentations.util.LeftToRightTabOrder.select(LeftToRightTabOrder.java:65)
at org.eclipse.ui.internal.presentations.util.TabbedStackPresentation.selectPart(TabbedStackPresentation.java:473)
at org.eclipse.ui.internal.PartStack.refreshPresentationSelection(PartStack.java:1245)
at org.eclipse.ui.internal.PartStack.setSelection(PartStack.java:1198)
at org.eclipse.ui.internal.PartStack.showPart(PartStack.java:1597)
at org.eclipse.ui.internal.PartStack.add(PartStack.java:493)
at org.eclipse.ui.internal.EditorStack.add(EditorStack.java:103)
at org.eclipse.ui.internal.PartStack.add(PartStack.java:479)
at org.eclipse.ui.internal.EditorStack.add(EditorStack.java:112)
at org.eclipse.ui.internal.EditorSashContainer.addEditor(EditorSashContainer.java:63)
at org.eclipse.ui.internal.EditorAreaHelper.addToLayout(EditorAreaHelper.java:225)
at org.eclipse.ui.internal.EditorAreaHelper.addEditor(EditorAreaHelper.java:213)
at org.eclipse.ui.internal.EditorManager.createEditorTab(EditorManager.java:808)
at org.eclipse.ui.internal.EditorManager.openEditorFromDescriptor(EditorManager.java:707)
at org.eclipse.ui.internal.EditorManager.openEditor(EditorManager.java:666)
at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditorBatched(WorkbenchPage.java:2946)
at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor(WorkbenchPage.java:2854)
at org.eclipse.ui.internal.WorkbenchPage.access$11(WorkbenchPage.java:2846)
at org.eclipse.ui.internal.WorkbenchPage$10.run(WorkbenchPage.java:2797)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2793)
at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2777)
at org.eclipse.ui.actions.OpenWithMenu.openEditor(OpenWithMenu.java:338)
at org.eclipse.ui.actions.OpenWithMenu$2.handleEvent(OpenWithMenu.java:180)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4169)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3758)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:124)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
at org.eclipse.equinox.launcher.Main.run(Main.java:1438)


Did any one face similar kind of issue ?
Is latest BPMN2 modeler compatible with Eclipse 3.8 and Graphiti 0.9??

Best Regards,
Razak

[Updated on: Mon, 16 July 2012 06:45]

Report message to a moderator

Re: Is latest BPMN2 Modeler compatible with Eclipse 3.8?? [message #895906 is a reply to message #895653] Mon, 16 July 2012 09:19 Go to previous messageGo to next message
Robert Brodt is currently offline Robert Brodt
Messages: 593
Registered: August 2010
Location: Colorado Springs, CO
Senior Member

Hi Mohammed,

We're still working on migrating the editor from Graphiti 0.8.2 to 0.9.0 because there were some breaking API changes. I'm not sure if there are backward-incompatibilities with other plugins, but you may want to try an install Graphiti 0.8.2 first and then install the editor. Please let me know if that works.

Bob
Re: Is latest BPMN2 Modeler compatible with Eclipse 3.8?? [message #896048 is a reply to message #895906] Tue, 17 July 2012 00:12 Go to previous messageGo to next message
Mohammed Razak is currently offline Mohammed Razak
Messages: 3
Registered: July 2012
Junior Member
Hi Bob,

Thanks for reply!
My requirement is to use Eclipse 3.8 and Graphiti 0.9,so can't down-port it.

Could you please let me know when the migration of BPMN2 editor from Graphiti 0.8.2 to 0.9.0 is planned?

Best Regards,
Razak

[Updated on: Tue, 17 July 2012 02:51]

Report message to a moderator

Re: Is latest BPMN2 Modeler compatible with Eclipse 3.8?? [message #896155 is a reply to message #896048] Tue, 17 July 2012 08:33 Go to previous messageGo to next message
Robert Brodt is currently offline Robert Brodt
Messages: 593
Registered: August 2010
Location: Colorado Springs, CO
Senior Member

Actually, the code changes are complete (as far as I can tell Wink) I just need to do some more testing to make sure nothing is broken. This should be available for this week's build (scheduled for this Friday, July 20) or earlier.

I'll post a status update to this forum once I'm satisfied there are no issues with the migration.

Bob
Re: Is latest BPMN2 Modeler compatible with Eclipse 3.8?? [message #896156 is a reply to message #896048] Tue, 17 July 2012 08:33 Go to previous messageGo to next message
Tosten Mengel is currently offline Tosten Mengel
Messages: 5
Registered: July 2012
Junior Member
Hi all,

I do have the same problem and I'm using Graphiti 8.2.
But I'm also using the the latest Eclipse Version for Modelling

Eclipse Modeling Tools
Version: Juno Release
Build id: 20120620-1657

So please keep me also up to date for a fix.

Cheers

Tosten
Re: Is latest BPMN2 Modeler compatible with Eclipse 3.8?? [message #896526 is a reply to message #896156] Wed, 18 July 2012 12:50 Go to previous messageGo to next message
Robert Brodt is currently offline Robert Brodt
Messages: 593
Registered: August 2010
Location: Colorado Springs, CO
Senior Member

Migration to graphiti 0.9.0 is done. See https://bugs.eclipse.org/bugs/show_bug.cgi?id=384055
Re: Is latest BPMN2 Modeler compatible with Eclipse 3.8?? [message #896596 is a reply to message #896526] Thu, 19 July 2012 00:51 Go to previous messageGo to next message
Mohammed Razak is currently offline Mohammed Razak
Messages: 3
Registered: July 2012
Junior Member
Thanks a lot Bob!
Re: Is latest BPMN2 Modeler compatible with Eclipse 3.8?? [message #896655 is a reply to message #896596] Thu, 19 July 2012 05:57 Go to previous messageGo to next message
Tosten Mengel is currently offline Tosten Mengel
Messages: 5
Registered: July 2012
Junior Member
Hi all,

I'm using the Eclipse 4.2 (Juno) the modelling Version.
Thanks to your updates for Graphiti 0.9 and BPMN2.0 i can nur start it and partially model.

One problem does occur: I can not edit the the task names, ...
Also the GUI is completely puzzled and you not read at all anymore the models.

Please help to fix this.

Cheers

Torsten
Re: Is latest BPMN2 Modeler compatible with Eclipse 3.8?? [message #896718 is a reply to message #896655] Thu, 19 July 2012 09:38 Go to previous messageGo to next message
Robert Brodt is currently offline Robert Brodt
Messages: 593
Registered: August 2010
Location: Colorado Springs, CO
Senior Member

Hi Tosten,

I think this has probably already been fixed (yes, we move fast & furious around here Wink) The latest build version on the update site should be 0.0.1.201207182331 - can you please compare this with the version# that you have installed?

Also, I'm not sure what you meant by "the GUI is completely puzzled and you not read at all anymore the models" - can you explain please (auf Deutsch wenn's sein muss Wink) ?

Can you provide an example of a process file that you are having trouble with?

Thanks!
Bob

[Updated on: Thu, 19 July 2012 09:40]

Report message to a moderator

Re: Is latest BPMN2 Modeler compatible with Eclipse 3.8?? [message #897397 is a reply to message #896718] Mon, 23 July 2012 21:33 Go to previous messageGo to next message
Robert Brodt is currently offline Robert Brodt
Messages: 593
Registered: August 2010
Location: Colorado Springs, CO
Senior Member

Hi all,

I've just published the latest BPMN2 Modeler build to the helios update site here:
http://download.eclipse.org/bpmn2-modeler/site-helios/
Please let me know if/what is broken.

Bob

[Updated on: Mon, 23 July 2012 21:34]

Report message to a moderator

Re: Is latest BPMN2 Modeler compatible with Eclipse 3.8?? [message #897585 is a reply to message #897397] Tue, 24 July 2012 11:34 Go to previous messageGo to next message
Tosten Mengel is currently offline Tosten Mengel
Messages: 5
Registered: July 2012
Junior Member
Hi all,

I got the latest Update and I can model now BPMN 2.0 Diagrams. Great!
One question: How can I change the name from e.g. a "User Task 1" in my process to a specific user task like "check data record". I can not find a item for changing it. If I do a double click I can only change the item to a "Service Task" or someting else.

I'm using INDIGO (Eclipese 3.7) with Graphiti 0.9 and BPMN2.0 (0.0.1.201207201902)

Cheers

Torsten
Re: Is latest BPMN2 Modeler compatible with Eclipse 3.8?? [message #897934 is a reply to message #897585] Wed, 25 July 2012 09:14 Go to previous messageGo to next message
Robert Brodt is currently offline Robert Brodt
Messages: 593
Registered: August 2010
Location: Colorado Springs, CO
Senior Member

You should be able to change the Task name in the Descriptions tab. See attached image:

http://screencast.com/t/Vle1cUXLb
Re: Is latest BPMN2 Modeler compatible with Eclipse 3.8?? [message #898607 is a reply to message #897934] Thu, 26 July 2012 17:02 Go to previous messageGo to next message
Tosten Mengel is currently offline Tosten Mengel
Messages: 5
Registered: July 2012
Junior Member
Hi Robert,

thanks a lot for the image! It explains of who to change it.
I dso net get this property tab activted.
If I do alt+Enter on the Task onject I do get an Error Message
No Property pages for PE....
Is there an other way to activate the property tab?

Sorry It is my first project with eclipse for modelling Smile

Cheers

Torsten
Re: Is latest BPMN2 Modeler compatible with Eclipse 3.8?? [message #898745 is a reply to message #898607] Fri, 27 July 2012 08:36 Go to previous messageGo to next message
Robert Brodt is currently offline Robert Brodt
Messages: 593
Registered: August 2010
Location: Colorado Springs, CO
Senior Member

If all of the property tabs are blank it's probably due to a bug. Try changing the Tool Enablement properties for your project: select the project, then from the main menu Project->Properties. Click the BPMN2->Tool Enablement category and select "Override" to enable displaying all of the model elements as shown in the screenshot here:

http://content.screencast.com/users/rbrodt/folders/Jing/media/93fc8ee8-51f8-4d0e-919f-35c4e32c8476/2012-07-27_0633.png

[Updated on: Fri, 27 July 2012 08:38]

Report message to a moderator

Re: Is latest BPMN2 Modeler compatible with Eclipse 3.8?? [message #898754 is a reply to message #898745] Fri, 27 July 2012 08:58 Go to previous messageGo to next message
Tosten Mengel is currently offline Tosten Mengel
Messages: 5
Registered: July 2012
Junior Member
Hi Robert,

that was helpful Smile
now I can add the from the Menue (Show View as a fast View) the properties and I can also change them. Great!

By the way an other question: Are there plans to implement a complete roundtrip - so to say generate a GUI, DB, and Java Code to create a complete application based on the process design?

Cheers

Torsten
Re: Is latest BPMN2 Modeler compatible with Eclipse 3.8?? [message #898830 is a reply to message #898754] Fri, 27 July 2012 16:20 Go to previous messageGo to next message
Robert Brodt is currently offline Robert Brodt
Messages: 593
Registered: August 2010
Location: Colorado Springs, CO
Senior Member

Glad it worked Very Happy

We don't have any plans at the moment for the editor, other than simply creating and editing BPMN 2.0 files (I think that's a handful already Wink) but feel free to make suggestions in bugzilla: https://bugs.eclipse.org/bugs/enter_bug.cgi?product=BPMN2Modeler

Thanks for testing and for your feedback!

Bob
Re: Is latest BPMN2 Modeler compatible with Eclipse 3.8?? [message #912511 is a reply to message #898830] Thu, 13 September 2012 13:30 Go to previous messageGo to next message
Piazza Antonio is currently offline Piazza Antonio
Messages: 1
Registered: September 2012
Junior Member
Hi,

I'm in trouble too Shocked . I've just install Eclipse June (and nothing else, it's a clean version) and then the last release of Ecplise BPMN Modeler 2.0 from this directory http://download.eclipse.org/bpmn2-modeler/site. If I try to make a bpmn diagram it's all ok but when I try to make a model:

Failed to create the part's controls

org.eclipse.core.runtime.AssertionFailedException: assertion failed:
at org.eclipse.core.runtime.Assert.isTrue(Assert.java:110)
at org.eclipse.core.runtime.Assert.isTrue(Assert.java:96)
at org.eclipse.ui.part.MultiPageEditorPart.setActivePage(MultiPageEditorPart.java:1079)
at org.eclipse.ui.part.MultiPageEditorPart.createPartControl(MultiPageEditorPart.java:362)
at org.eclipse.ui.internal.e4.compatibility.CompatibilityPart.createPartControl(CompatibilityPart.java:129)
at org.eclipse.ui.internal.e4.compatibility.CompatibilityEditor.createPartControl(CompatibilityEditor.java:95)
at org.eclipse.ui.internal.e4.compatibility.CompatibilityPart.create(CompatibilityPart.java:300)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:56)
at org.eclipse.e4.core.internal.di.InjectorImpl.processAnnotated(InjectorImpl.java:857)
at org.eclipse.e4.core.internal.di.InjectorImpl.processAnnotated(InjectorImpl.java:837)
at org.eclipse.e4.core.internal.di.InjectorImpl.inject(InjectorImpl.java:111)
at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:318)
at org.eclipse.e4.core.internal.di.InjectorImpl.make(InjectorImpl.java:240)
at org.eclipse.e4.core.contexts.ContextInjectionFactory.make(ContextInjectionFactory.java:161)
at org.eclipse.e4.ui.internal.workbench.ReflectionContributionFactory.createFromBundle(ReflectionContributionFactory.java:102)
at org.eclipse.e4.ui.internal.workbench.ReflectionContributionFactory.doCreate(ReflectionContributionFactory.java:71)
at org.eclipse.e4.ui.internal.workbench.ReflectionContributionFactory.create(ReflectionContributionFactory.java:53)
at org.eclipse.e4.ui.workbench.renderers.swt.ContributedPartRenderer.createWidget(ContributedPartRenderer.java:141)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.createWidget(PartRenderingEngine.java:889)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.safeCreateGui(PartRenderingEngine.java:623)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.safeCreateGui(PartRenderingEngine.java:725)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.access$2(PartRenderingEngine.java:696)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$7.run(PartRenderingEngine.java:690)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.createGui(PartRenderingEngine.java:675)
at org.eclipse.e4.ui.internal.workbench.PartServiceImpl$1.handleEvent(PartServiceImpl.java:90)
at org.eclipse.e4.ui.services.internal.events.UIEventHandler$1.run(UIEventHandler.java:41)
at org.eclipse.swt.widgets.Synchronizer.syncExec(Synchronizer.java:180)
at org.eclipse.ui.internal.UISynchronizer.syncExec(UISynchronizer.java:150)
at org.eclipse.swt.widgets.Display.syncExec(Display.java:4687)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application$1.syncExec(E4Application.java:187)
at org.eclipse.e4.ui.services.internal.events.UIEventHandler.handleEvent(UIEventHandler.java:38)
at org.eclipse.equinox.internal.event.EventHandlerWrapper.handleEvent(EventHandlerWrapper.java:197)
at org.eclipse.equinox.internal.event.EventHandlerTracker.dispatchEvent(EventHandlerTracker.java:197)
at org.eclipse.equinox.internal.event.EventHandlerTracker.dispatchEvent(EventHandlerTracker.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.ListenerQueue.dispatchEventSynchronous(ListenerQueue.java:148)
at org.eclipse.equinox.internal.event.EventAdminImpl.dispatchEvent(EventAdminImpl.java:135)
at org.eclipse.equinox.internal.event.EventAdminImpl.sendEvent(EventAdminImpl.java:78)
at org.eclipse.equinox.internal.event.EventComponent.sendEvent(EventComponent.java:39)
at org.eclipse.e4.ui.services.internal.events.EventBroker.send(EventBroker.java:81)
at org.eclipse.e4.ui.internal.workbench.UIEventPublisher.notifyChanged(UIEventPublisher.java:57)
at org.eclipse.emf.common.notify.impl.BasicNotifierImpl.eNotify(BasicNotifierImpl.java:374)
at org.eclipse.e4.ui.model.application.ui.impl.ElementContainerImpl.setSelectedElement(ElementContainerImpl.java:171)
at org.eclipse.e4.ui.internal.workbench.ModelServiceImpl.showElementInWindow(ModelServiceImpl.java:418)
at org.eclipse.e4.ui.internal.workbench.ModelServiceImpl.bringToTop(ModelServiceImpl.java:385)
at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.delegateBringToTop(PartServiceImpl.java:578)
at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.bringToTop(PartServiceImpl.java:314)
at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.showPart(PartServiceImpl.java:962)
at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor(WorkbenchPage.java:3071)
at org.eclipse.ui.internal.WorkbenchPage.access$21(WorkbenchPage.java:2996)
at org.eclipse.ui.internal.WorkbenchPage$8.run(WorkbenchPage.java:2978)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2974)
at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2933)
at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2916)
at org.eclipse.bpmn2.presentation.Bpmn2ModelWizard.performFinish(Bpmn2ModelWizard.java:272)
at org.eclipse.jface.wizard.WizardDialog.finishPressed(WizardDialog.java:827)
at org.eclipse.jface.wizard.WizardDialog.buttonPressed(WizardDialog.java:432)
at org.eclipse.jface.dialogs.Dialog$2.widgetSelected(Dialog.java:624)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:248)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4169)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3758)
at org.eclipse.jface.window.Window.runEventLoop(Window.java:825)
at org.eclipse.jface.window.Window.open(Window.java:801)
at org.eclipse.ui.internal.handlers.WizardHandler$New.executeHandler(WizardHandler.java:259)
at org.eclipse.ui.internal.handlers.WizardHandler.execute(WizardHandler.java:279)
at org.eclipse.ui.internal.handlers.HandlerProxy.execute(HandlerProxy.java:293)
at org.eclipse.ui.internal.handlers.E4HandlerProxy.execute(E4HandlerProxy.java:76)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:56)
at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:229)
at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:210)
at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:131)
at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:171)
at org.eclipse.ui.internal.handlers.LegacyHandlerService.executeCommand(LegacyHandlerService.java:492)
at org.eclipse.ui.internal.actions.CommandAction.runWithEvent(CommandAction.java:157)
at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:584)
at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501)
at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:411)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4169)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3758)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1022)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:916)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:86)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:585)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:540)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:124)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
at org.eclipse.equinox.launcher.Main.main(Main.java:1414)

any suggestions? Sad

thanks

[Updated on: Thu, 13 September 2012 13:31]

Report message to a moderator

Re: Is latest BPMN2 Modeler compatible with Eclipse 3.8?? [message #913015 is a reply to message #912511] Fri, 14 September 2012 11:44 Go to previous messageGo to next message
Robert Brodt is currently offline Robert Brodt
Messages: 593
Registered: August 2010
Location: Colorado Springs, CO
Senior Member

Hi Antonio,

Have you tried the M2 milestone build from here:

http://download.eclipse.org/bpmn2-modeler/site/M2

The current update site will become our RC1 build for 0.1.0 and hasn't been tested with Juno yet. We are planing another build for this weekend which should work with Juno.

Bob
Re: Is latest BPMN2 Modeler compatible with Eclipse 3.8?? [message #915147 is a reply to message #913015] Sun, 16 September 2012 12:19 Go to previous message
Robert Brodt is currently offline Robert Brodt
Messages: 593
Registered: August 2010
Location: Colorado Springs, CO
Senior Member

Antonio,

Sorry, I misunderstood what you were trying to do. The BPMN2 wizard category has two entries: BPMN2 Diagram and BPMN2 Model - I now realize that you had selected the second one (Model). This entry actually invokes the model creation wizard from the MDT/BPMN2 metamodel project (here: http://www.eclipse.org/modeling/mdt/?project=bpmn2). This wizard just creates an empty XML document with a <definitions> element and nothing else. Once the wizard is completed, it invokes the default editor associated with bpmn2 content type. Normally, this would be the tree-oriented editor that is generated by EMF for a model but, since the the BPMN2 Modeler is registered as the editor for this content, it is invoked instead. Apparently the BPMN2 Modeler can't handle empty bpmn2 documents Sad

I have created a bugzilla for this, here: https://bugs.eclipse.org/bugs/show_bug.cgi?id=389677
We should have a fix for this by the time the RC1 build becomes available.

Thanks for finding this! Smile

Bob
Previous Topic:Problems with targetNamespace
Next Topic:Modeler / jBPM Problem
Goto Forum:
  


Current Time: Tue Sep 02 14:53:49 EDT 2014

Powered by FUDForum. Page generated in 0.06171 seconds