Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Birt rcp report designer 4.2.0 does not lauch
icon8.gif  Birt rcp report designer 4.2.0 does not lauch [message #895039] Wed, 11 July 2012 13:39 Go to next message
Jarod Delaware is currently offline Jarod Delaware
Messages: 2
Registered: July 2012
Junior Member
Hey there,

I would like to know if someone could help me to resolve my installation problem with the new version of Birt RCP report Designer 4.2.0. I unzipped the archive and when I click on Birt.exe I have this error message :

An error has occurred, see log file. Do you know how to solve this problem ?
Regards,
Jarod.

!SESSION 2012-07-11 15:36:55.232 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_33
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=fr_FR
Command-line arguments: -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.osgi 4 0 2012-07-11 15:36:56.279
!MESSAGE Application error
!STACK 1
java.lang.NullPointerException
at org.eclipse.e4.ui.internal.workbench.ModelServiceImpl.<init>(ModelServiceImpl.java:92)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createDefaultContext(E4Application.java:442)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createE4Workbench(E4Application.java:182)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:554)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:540)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.birt.report.designer.ui.rcp.DesignerApplication.run(DesignerApplication.java:38)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.internal.app.EclipseAppContainer.callMethodWithException(EclipseAppContainer.java:587)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:198)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
Re: Birt rcp report designer 4.2.0 does not lauch [message #895158 is a reply to message #895039] Wed, 11 July 2012 20:27 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Do you get the same error when using the allinone build?

Jason

On 7/11/12 9:39 AM, Jarod Delaware wrote:
> Hey there,
>
> I would like to know if someone could help me to resolve my installation
> problem with the new version of Birt RCP report Designer 4.2.0. I
> unzipped the archive and when I click on Birt.exe I have this error
> message :
>
> An error has occurred, see log file. Do you know how to solve this
> problem ?
> Regards,
> Jarod.
>
> !SESSION 2012-07-11 15:36:55.232
> -----------------------------------------------
> eclipse.buildId=unknown
> java.version=1.6.0_33
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=fr_FR
> Command-line arguments: -os win32 -ws win32 -arch x86
>
> !ENTRY org.eclipse.osgi 4 0 2012-07-11 15:36:56.279
> !MESSAGE Application error
> !STACK 1
> java.lang.NullPointerException
> at
> org.eclipse.e4.ui.internal.workbench.ModelServiceImpl.<init>(ModelServiceImpl.java:92)
>
> at
> org.eclipse.e4.ui.internal.workbench.swt.E4Application.createDefaultContext(E4Application.java:442)
>
> at
> org.eclipse.e4.ui.internal.workbench.swt.E4Application.createE4Workbench(E4Application.java:182)
>
> at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:554)
> at
> org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
>
> at
> org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:540)
> at
> org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
> at
> org.eclipse.birt.report.designer.ui.rcp.DesignerApplication.run(DesignerApplication.java:38)
>
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
> at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
> at java.lang.reflect.Method.invoke(Unknown Source)
> at
> org.eclipse.equinox.internal.app.EclipseAppContainer.callMethodWithException(EclipseAppContainer.java:587)
>
> at
> org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:198)
>
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
>
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
>
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
>
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
>
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
> at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
> at java.lang.reflect.Method.invoke(Unknown Source)
> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
> at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
Re: Birt rcp report designer 4.2.0 does not lauch [message #895247 is a reply to message #895158] Thu, 12 July 2012 09:14 Go to previous messageGo to next message
Jarod Delaware is currently offline Jarod Delaware
Messages: 2
Registered: July 2012
Junior Member
Hi Jason,

Thanks for your reply. I didn't download the allinone build. I used to download the RCP designer and it works without any additional download previously. Got this error only with this new version 4.2.0.

I will try to install the allinone build to see.

Regards,
Jarod.
Re: Birt rcp report designer 4.2.0 does not lauch [message #895341 is a reply to message #895247] Thu, 12 July 2012 14:01 Go to previous messageGo to next message
Brian McMahon is currently offline Brian McMahon
Messages: 8
Registered: July 2012
Location: University of Delaware
Junior Member
I am having the same problem launching the RCP designer 4.2.0. RCP designer 3.7.2 works fine. Will give the all in one a try.
icon8.gif  Re: Birt rcp report designer 4.2.0 does not lauch [message #895447 is a reply to message #895039] Fri, 13 July 2012 01:17 Go to previous messageGo to next message
Ines Feijao is currently offline Ines Feijao
Messages: 1
Registered: July 2012
Junior Member
I have the exact same problem.. Doesn't launch. Please help!
Re: Birt rcp report designer 4.2.0 does not lauch [message #896039 is a reply to message #895447] Tue, 17 July 2012 02:54 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

We are looking into this now.

Jason

On 7/12/2012 9:17 PM, Ines Feijao wrote:
> I have the exact same problem.. Doesn't launch. Please help!
Re: Birt rcp report designer 4.2.0 does not lauch [message #896043 is a reply to message #896039] Tue, 17 July 2012 03:12 Go to previous message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Patch is available in this bugzilla entry:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=383756

Jason

On 7/16/2012 10:54 PM, Jason Weathersby wrote:
> We are looking into this now.
>
> Jason
>
> On 7/12/2012 9:17 PM, Ines Feijao wrote:
>> I have the exact same problem.. Doesn't launch. Please help!
>
>
Previous Topic:Support for Multiple Excel worksheets
Next Topic:Birt report export to excel error
Goto Forum:
  


Current Time: Sat Oct 25 18:23:22 GMT 2014

Powered by FUDForum. Page generated in 0.21062 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software