Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Eclipse RCP Product export issue(Eclipse RCP Product export issue)
Eclipse RCP Product export issue [message #893658] Thu, 05 July 2012 07:03
Girish Chandran is currently offline Girish Chandran
Messages: 24
Registered: June 2012
Junior Member
Hi all,

Iam having a tree viewer in the project explorer view of my RCP application. My product completely deals with loading, value retrieval and updating values in resource ("org.eclipse.emf.ecore.resource.Resource"). Iam having a create project menu item, which is used for creation of new project. After the project creation operation, a new file is created in the project folder. Iam having a standard xml file, which i need to be loaded while creating the project itself. So, in the entire application, i deal with 2 files(standard xml file and the xml file created during project creation operation). When iam running the rcp product in eclipse, its working fine and after the completion of project creation process, the project node appears in the tree and when i try to expand the project node, it shows the child nodes.

I tried to export it as an rcp product by using "export as a product" option in eclipse product file. And when I tried to create project, the project node is shown in the tree viewer, but when i try to expand the project node, nothing is shown under it. I tried to find out the reason by using a console view in my product. Actually, i have to take value from a xml resource and add it as a child to the project node. When, i tried to print the root node of resource in console view, it was showing the value of root node. But i needed to put the immediate children of the root node under the project node. So , i took the children of the node and tried to print the number of children, the value was showing as 0. The file is created perfectly in the project folder. I think, this happens due to some issues related with resources. Is there something which we should care about resources, while exporting the product.

A help will be greatly appreciated.

Thanks in advance.

Regards,
Girish
Previous Topic:[SOLVED] Mozilla extenal browser does not work in Eclipse on Ubuntu
Next Topic:Can't hide import wizards.
Goto Forum:
  


Current Time: Tue Sep 23 06:28:37 GMT 2014

Powered by FUDForum. Page generated in 0.02430 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software