Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » TPTP Auto GUI recorder article
TPTP Auto GUI recorder article [message #118834] Fri, 30 November 2007 20:03 Go to next message
Neil Goldsmith is currently offline Neil GoldsmithFriend
Messages: 68
Registered: July 2009
Member
Just breaking into TPTP and going through the user guide "An Introduction
to Using TPTP's Automated GUI Recorder"
http://www.eclipse.org/tptp/test/documents/userguides/Intro- Auto-GUI-4-4-0.html

I ran into an issue that seems pretty basic. In the run dialog, I've
defined a launch configuration under "Test" to run it. My test suite is
setup with "use current workbench as context", however when I run the test
case it loads for a while (up to about 40%) then returns back "Failed to
retrieve the context that should be used to run the test cases in"

The test is super simple, it just creates a new Java project. I've run it
successfully using the "play test case" button on the test suite toolbar,
but can't seem to launch a runtime config and have it work.

Has anyone attempted this article or just launced a super simple test app
and what might I have done wrong?

thank you
Re: TPTP Auto GUI recorder article [message #118846 is a reply to message #118834] Fri, 30 November 2007 20:17 Go to previous messageGo to next message
Neil Goldsmith is currently offline Neil GoldsmithFriend
Messages: 68
Registered: July 2009
Member
If this helps, here is what shows up in the log:

!ENTRY org.eclipse.hyades.test.core 1 0 2007-11-30 14:59:55.197
!MESSAGE java.lang.ClassCastException: Failed to retrieve the context that
should be used to run the test cases in
!STACK 0
java.lang.ClassCastException: Failed to retrieve the context that should
be used to run the test cases in
at
org.eclipse.tptp.test.auto.gui.internal.runner.AutoGUIExecEn vAdapter.setupExecutionEnvironment(AutoGUIExecEnvAdapter.jav a:129)
at
org.eclipse.hyades.execution.harness.util.ExecutionAdapterUt ilities.adaptExecutionEnvironment(ExecutionAdapterUtilities. java:139)
at
org.eclipse.hyades.execution.harness.TestExecutionHarness.la unchTestExecution(TestExecutionHarness.java:1996)
at
org.eclipse.hyades.execution.harness.TestExecutionHarness.ac cess$2(TestExecutionHarness.java:1830)
at
org.eclipse.hyades.execution.harness.TestExecutionHarness$2. run(TestExecutionHarness.java:750)
Re: TPTP Auto GUI recorder article [message #118884 is a reply to message #118834] Mon, 03 December 2007 11:38 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul SlauenwhiteFriend
Messages: 970
Registered: July 2009
Senior Member
Hi Neil,
What version of TPTP are you using? Also, what OS/JRE (version and
vendor)?

Paul
"Neil Goldsmith" <neilg@avaya.com> wrote in message
news:8c4097b3487296ddc5c0f5342229a4bf$1@www.eclipse.org...
> Just breaking into TPTP and going through the user guide "An Introduction
> to Using TPTP's Automated GUI Recorder"
> http://www.eclipse.org/tptp/test/documents/userguides/Intro- Auto-GUI-4-4-0.html
>
> I ran into an issue that seems pretty basic. In the run dialog, I've
> defined a launch configuration under "Test" to run it. My test suite is
> setup with "use current workbench as context", however when I run the test
> case it loads for a while (up to about 40%) then returns back "Failed to
> retrieve the context that should be used to run the test cases in"
>
> The test is super simple, it just creates a new Java project. I've run it
> successfully using the "play test case" button on the test suite toolbar,
> but can't seem to launch a runtime config and have it work.
>
> Has anyone attempted this article or just launced a super simple test app
> and what might I have done wrong?
>
> thank you
>
Re: TPTP Auto GUI recorder article [message #118924 is a reply to message #118884] Mon, 03 December 2007 15:18 Go to previous messageGo to next message
Neil Goldsmith is currently offline Neil GoldsmithFriend
Messages: 68
Registered: July 2009
Member
Windows XP/Java 1.5
TPTP 4.4.0.3

thanks
Re: TPTP Auto GUI recorder article [message #119026 is a reply to message #118924] Tue, 04 December 2007 11:44 Go to previous message
Paul Slauenwhite is currently offline Paul SlauenwhiteFriend
Messages: 970
Registered: July 2009
Senior Member
Are you using the AGR from
http://www.eclipse.org/tptp/home/downloads/?ver=4.4.0.3? This is a tested
(and simple) scenario that should work when TPTP is installed correctly.
Can you try reinstalling TPTP and the AGR?

PS

"Neil Goldsmith" <neilg@avaya.com> wrote in message
news:17ce522f15ce804dc208fdb1040d3fe3$1@www.eclipse.org...
> Windows XP/Java 1.5 TPTP 4.4.0.3
>
> thanks
>
Previous Topic:storing enabled/disabled state of widgets
Next Topic:Reuse Profiling & Logging Plugin
Goto Forum:
  


Current Time: Sat Nov 22 03:04:21 GMT 2014

Powered by FUDForum. Page generated in 0.02040 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software