Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Red exclamation in PDE project icon
Red exclamation in PDE project icon [message #890559] Fri, 22 June 2012 14:09 Go to next message
Libor Jelinek is currently offline Libor Jelinek
Messages: 143
Registered: January 2012
Location: Prague, Czech Rep.
Senior Member

Hi all,
from time to time I encounter red exclamation on icon of PDE project
like in attachment but can find out what's (and where) wrong because all
source files, manifests, everything are without any problem.

However, for example when running tests, I'm notified that there are
errors in my projects but didn't tell me what errors....

Thanks for any help!
Libor
Re: Red exclamation in PDE project icon [message #890567 is a reply to message #890559] Fri, 22 June 2012 15:24 Go to previous messageGo to next message
Sopot Cela is currently offline Sopot Cela
Messages: 597
Registered: December 2010
Senior Member

It usually indicates a build path problem. Go to properties-java build path and check if there is something wrong there, like unbound libraries etc.
Re: Red exclamation in PDE project icon [message #890877 is a reply to message #890567] Sat, 23 June 2012 09:51 Go to previous messageGo to next message
Libor Jelinek is currently offline Libor Jelinek
Messages: 143
Registered: January 2012
Location: Prague, Czech Rep.
Senior Member

Unfortunately I'm still not able to find out what's wrong. In build path
in Properties doesn't report any problem. Are they some other ways, please?

Libor

On 06/22/2012 05:24 PM, Sopot Cela wrote:
> It usually indicates a build path problem. Go to properties-java build
> path and check if there is something wrong there, like unbound libraries
> etc.
Re: Red exclamation in PDE project icon [message #890882 is a reply to message #890559] Sat, 23 June 2012 10:13 Go to previous messageGo to next message
Simon Scholz is currently offline Simon Scholz
Messages: 73
Registered: April 2012
Location: Germany
Member
Hello Libor Jelínek,

Sopot Cela is right, usually the red exclamationmark indicates that there is something wrong with your dependencies.

Maybe you should look into your run configuration and validate plugins, and look for problems.
Sometimes the TargetPlatform contains the some jar/bundles in a differend version so that it ends in a conflict.

So check your dependencies in your Manifest, check the buildpath and your TargetPlatform.

Best regards,

Simon
Re: Red exclamation in PDE project icon [message #890917 is a reply to message #890877] Sat, 23 June 2012 12:30 Go to previous message
Sopot Cela is currently offline Sopot Cela
Messages: 597
Registered: December 2010
Senior Member

See the Problems view or Markers view. It should be there somewhere.

Libor Jelínek wrote on Sat, 23 June 2012 12:51
Unfortunately I'm still not able to find out what's wrong. In build path
in Properties doesn't report any problem. Are they some other ways, please?

Libor

On 06/22/2012 05:24 PM, Sopot Cela wrote:
> It usually indicates a build path problem. Go to properties-java build
> path and check if there is something wrong there, like unbound libraries
> etc.
Previous Topic:Missing Tab when PDE is launched via Webstart
Next Topic:Red exclamation in PDE project icon
Goto Forum:
  


Current Time: Fri Oct 31 05:51:35 GMT 2014

Powered by FUDForum. Page generated in 0.02745 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software