Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » options for selenium when starting html aut(window settings for html aut)
icon5.gif  options for selenium when starting html aut [message #889666] Tue, 19 June 2012 13:07
Flo Ryan is currently offline Flo Ryan
Messages: 1
Registered: June 2012
Junior Member
Hi Folks,

I'm able to start html AUTs with ie. A browser window called "Remote Control" appears after starting the AUT - that browser window is started through selenium-driver with the size of approx 960x680.

My AUT needs at least a window of 1024x768 to be shown properly.
You can find two links "edit profile" and "logout" in top right region of my AUT. When AUT is started I can't see the "logout"-Button without using the horizontal scrolling bar to get to the most-right-window region...

i think thats where my problem comes from:

did the object mapping: started om-editor --> started aut --> started object mapping mode (target-icon) --> hold ctrl+shift+q and clicked on my logout-link-element --> mapped unassigned component name with technical name --> saved and stopped the object mapping mode. NOTE: I had to scroll to max right before i was able to collect the logout-link. I didn't collected the edit profile-link - cause i don't wanna use it atm!

I've added the Testcase "PerformLogout" to my testsuite. When i'm running it the test fails. Application screenshots shows that "edit profile" was called instead of "logout" (which i was planning to test).

i'm now assuming jubula tries to check the most top-right element in visible window-region - and that was in this case the "edit profile" link instead of expected "logout"....

now i was looking for some information how selenium is called from jubula standalone but i couldn't find something useful. the idea was to open my AUT in full-screen mode or in a fixed size window to avoid this behaviour.

any idea how to achieve this?

thanks in advance

Flo
Previous Topic:Is there solution for the composites unknown?
Next Topic:How to set up external Oracle database
Goto Forum:
  


Current Time: Mon Oct 20 13:21:33 GMT 2014

Powered by FUDForum. Page generated in 0.01800 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software