Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » error using UML as input
error using UML as input [message #887559] Sat, 16 June 2012 20:54 Go to next message
Fernanda R.F. is currently offline Fernanda R.F.
Messages: 64
Registered: May 2012
Member
Hi,


I'm trying to use ATL plugin, but I'm getting the following error:

org.eclipse.m2m.atl.engine.emfvm.VMException: Could not find model element Model from UML
Java Stack:
org.eclipse.m2m.atl.engine.emfvm.VMException: Could not find model element Model from UML
	at org.eclipse.m2m.atl.engine.emfvm.ASM.registerOperations(ASM.java:243)
	at org.eclipse.m2m.atl.engine.emfvm.ASM.run(ASM.java:195)
	at org.eclipse.m2m.atl.engine.emfvm.launch.EMFVMLauncher.internalLaunch(EMFVMLauncher.java:170)
	at org.eclipse.m2m.atl.engine.emfvm.launch.EMFVMLauncher.launch(EMFVMLauncher.java:139)
	at uml2metamodelRC.Uml2metamodel.doUml2metamodel(Uml2metamodel.java:165)
	at uml2metamodelRC.Uml2metamodel.main(Uml2metamodel.java:80)
Caused by: org.eclipse.m2m.atl.engine.emfvm.ASM$SignatureParsingException: Could not find model element Model from UML
	at org.eclipse.m2m.atl.engine.emfvm.ASM.parseTypeInternal(ASM.java:414)
	at org.eclipse.m2m.atl.engine.emfvm.ASM.parseType(ASM.java:378)
	at org.eclipse.m2m.atl.engine.emfvm.ASM.registerOperations(ASM.java:240)
	... 5 more


I'm using an UML file as metamodel in and an Ecore file as metamodel out.

I tried change sending a URL instead of UML metamodel, however the error still occurring.

So, what could I do to resolve it?

Thanks



Re: error using UML as input [message #890087 is a reply to message #887559] Thu, 21 June 2012 03:19 Go to previous messageGo to next message
Christian W. Damus is currently offline Christian W. Damus
Messages: 802
Registered: July 2009
Senior Member
Hi, Fernanda,

You will probably get better help about ATL on the ATL forum than on
the UML2 forum. This doesn't seem likely to be specific to the UML
metamodel, as such.

Cheers,

Christian


On 2012-06-16 20:54:12 +0000, Fernanda R.F. said:

> Hi,
>
>
> I'm trying to use ATL plugin, but I'm getting the following error:
>
>
> org.eclipse.m2m.atl.engine.emfvm.VMException: Could not find model
> element Model from UML
> Java Stack:
> org.eclipse.m2m.atl.engine.emfvm.VMException: Could not find model
> element Model from UML
> at org.eclipse.m2m.atl.engine.emfvm.ASM.registerOperations(ASM.java:243)
> at org.eclipse.m2m.atl.engine.emfvm.ASM.run(ASM.java:195)
> at
> org.eclipse.m2m.atl.engine.emfvm.launch.EMFVMLauncher.internalLaunch(EMFVMLauncher.java:170)
>
> at
> org.eclipse.m2m.atl.engine.emfvm.launch.EMFVMLauncher.launch(EMFVMLauncher.java:139)
>
> at uml2metamodelRC.Uml2metamodel.doUml2metamodel(Uml2metamodel.java:165)
> at uml2metamodelRC.Uml2metamodel.main(Uml2metamodel.java:80)
> Caused by:
> org.eclipse.m2m.atl.engine.emfvm.ASM$SignatureParsingException: Could
> not find model element Model from UML
> at org.eclipse.m2m.atl.engine.emfvm.ASM.parseTypeInternal(ASM.java:414)
> at org.eclipse.m2m.atl.engine.emfvm.ASM.parseType(ASM.java:378)
> at org.eclipse.m2m.atl.engine.emfvm.ASM.registerOperations(ASM.java:240)
> ... 5 more
>
> I'm using an UML file as metamodel in and an Ecore file as metamodel out.
> I tried change sending a URL instead of UML metamodel, however the
> error still occurring.
> So, what could I do to resolve it?
> Thanks
Re: error using UML as input [message #890327 is a reply to message #890087] Fri, 22 June 2012 00:55 Go to previous message
Fernanda R.F. is currently offline Fernanda R.F.
Messages: 64
Registered: May 2012
Member
Hi Christian,

Thanks, a put a new topic into ATL forum, but nobody answer yet.

Sad
Previous Topic:Compatibility of applied profiles
Next Topic:How to get the type of the element
Goto Forum:
  


Current Time: Sat Oct 25 08:01:01 GMT 2014

Powered by FUDForum. Page generated in 0.03120 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software