Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Java 1.7 Indigo Problems(Technical Problems with Compiler )
Java 1.7 Indigo Problems [message #884075] Sun, 10 June 2012 03:05 Go to next message
Bryant Lopez is currently offline Bryant LopezFriend
Messages: 2
Registered: June 2012
Junior Member
Im not sure if I posted this topic in the right place, but here goes.

I just downloaded Eclipse Indigo so I would have Java 7 compliance, but when I try to create a new project it says the 1.7 compiler cant be used, and the 1.6 compiler will be used instead. I am currently updating Eclipse to see if that fixes it, but figured I would post here just in case.
Re: Java 1.7 Indigo Problems [message #884165 is a reply to message #884075] Sun, 10 June 2012 09:30 Go to previous messageGo to next message
Stephan Herrmann is currently offline Stephan HerrmannFriend
Messages: 1051
Registered: July 2009
Senior Member
What's the exact error message?
Does it say "When selecting 1.7 compliance, make sure to have a compatible JRE installed ..."?

Stephan
Re: Java 1.7 Indigo Problems [message #884279 is a reply to message #884165] Sun, 10 June 2012 17:49 Go to previous messageGo to next message
Bryant Lopez is currently offline Bryant LopezFriend
Messages: 2
Registered: June 2012
Junior Member
I managed to fix the problem without really knowing what caused it in the first place. I kept trying to update Eclipse and it would give me errors. When I reinstalled it everything worked fine. I must have messed up the install somehow. Thanks for your help anyway.
Re: Java 1.7 Indigo Problems [message #884568 is a reply to message #884279] Mon, 11 June 2012 11:19 Go to previous message
Dani Megert is currently offline Dani MegertFriend
Messages: 3801
Registered: July 2009
Senior Member
On 10.06.2012 19:49, Bryant Lopez wrote:
> I managed to fix the problem without really knowing what caused it in
> the first place. I kept trying to update Eclipse and it would give me
> errors. When I reinstalled it everything worked fine. I must have
> messed up the install somehow. Thanks for your help anyway.
Not that you need Indigo SR1 or SR2 as the initial Indigo release (3.7)
did not yet contain support for Java 7.

Dani
Previous Topic:Core Expression for "ITextEditor.isEditable"?
Next Topic:Eclipse skipping breakpoints
Goto Forum:
  


Current Time: Sun Dec 21 22:27:31 GMT 2014

Powered by FUDForum. Page generated in 0.01913 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software