Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Subversive SVN Connectors required after MDT Papyrus Install?
Subversive SVN Connectors required after MDT Papyrus Install? [message #882325] Wed, 06 June 2012 08:59 Go to next message
Paul Walker is currently offline Paul WalkerFriend
Messages: 1
Registered: June 2012
Junior Member
I successfully installed MDT Papyrus 0.8.2 onto the Eclipse Indigo CDT (3.7.2) and It appears to work.
The only problem is that each start up, I get an "Install Connectors"prompt window looking for Subversive SVN connectors. (See below)
Does this mean that Papyrus will only work with SVN repositories?
We use Rational Clearcase for configuration management - changing to another system isn't an option for us.
Can anyone recommend a way to fix this?

OS: PC Win XP SP3
Eclipse Indigo 3.7.2 (Win32)
Eclipse IDE for C/C++ Developers 1.4.2.20120213-0813
MDT Papyrus 0.8.2.v201202150957
Eclipse Clearcase Integration 2.2.15.201203220754

The offending "Install Connectors" Prompt window
Subversive SVN Connectors.
Options are:-
SVN Kit 1.2.3
SVN Kit 1.3.2
SVN Kit 1.3.5
Native JavaHL 1.5.4
Native JavaHL 1.6.15
Re: Subversive SVN Connectors required after MDT Papyrus Install? [message #882340 is a reply to message #882325] Wed, 06 June 2012 09:19 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4154
Registered: July 2009
Senior Member
Hi Paul

Eclipse you to use a distinct CM for each project; so for the time being
just install SVN from the Collaboration section of Install New Software.

Then raise a Bugzilla because I suspect this dependency is an accident.

Regards

Ed Willink

On 06/06/2012 09:59, Paul Walker wrote:
> I successfully installed MDT Papyrus 0.8.2 onto the Eclipse Indigo CDT
> (3.7.2) and It appears to work. The only problem is that each start
> up, I get an "Install Connectors"prompt window looking for Subversive
> SVN connectors. (See below)
> Does this mean that Papyrus will only work with SVN repositories?
> We use Rational Clearcase for configuration management - changing to
> another system isn't an option for us.
> Can anyone recommend a way to fix this?
> OS: PC Win XP SP3
> Eclipse Indigo 3.7.2 (Win32)
> Eclipse IDE for C/C++ Developers 1.4.2.20120213-0813
> MDT Papyrus 0.8.2.v201202150957
> Eclipse Clearcase Integration 2.2.15.201203220754
>
> The offending "Install Connectors" Prompt window
> Subversive SVN Connectors. Options are:-
> SVN Kit 1.2.3
> SVN Kit 1.3.2
> SVN Kit 1.3.5
> Native JavaHL 1.5.4
> Native JavaHL 1.6.15
>
Re: Subversive SVN Connectors required after MDT Papyrus Install? [message #882422 is a reply to message #882340] Wed, 06 June 2012 12:48 Go to previous message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 504
Registered: February 2011
Senior Member
Hello,

This is not exactly an accident, although it might probably be less greedy.

There is one (small) plug-in in Papyrus which does an SVN integration, and depends on org.eclipse.team.svn.core (Which requires SVN connectors, although Papyrus does not, AFAIK). So, we have a dependency to SVN, but this should probably be some kind of optional, non-greedy dependency.

We'll try to fix that for 0.9.0


Camille


Camille Letavernier
Papyrus developer
Previous Topic:How to rename in one step CallOpaqueAction argument and its corresponding Operation Parameter
Next Topic:Assign value to a property
Goto Forum:
  


Current Time: Wed Nov 26 20:54:45 GMT 2014

Powered by FUDForum. Page generated in 0.01759 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software