Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Launch Failed. Binary Not Found. But found after refresh(The project explorer is not refreshing the filesystem after build. )
Launch Failed. Binary Not Found. But found after refresh [message #881180] Mon, 04 June 2012 00:11
Karthikeyan Missing name is currently offline Karthikeyan Missing name
Messages: 2
Registered: September 2011
Junior Member
Hi,
I am running Eclipse Juno in Fedora 17 with CDT plugin. I was trying to run a sample application. I tried to build the application. The console said:

**** Build of configuration Debug for project HelloWorld ****

make all
Building file: ../main.c
Invoking: GCC C Compiler
gcc -O0 -g3 -Wall -c -fmessage-length=0 -MMD -MP -MF"main.d" -MT"main.d" -o "main.o" "../main.c"
../main.c: In function 'main':
../main.c:10:2: warning: implicit declaration of function 'printf' [-Wimplicit-function-declaration]
../main.c:10:2: warning: incompatible implicit declaration of built-in function 'printf' [enabled by default]
Finished building: ../main.c

Building target: HelloWorld
Invoking: GCC C Linker
gcc -o "HelloWorld" ./main.o
Finished building target: HelloWorld


**** Build Finished ****

The project explorer showed the Debug folder, but the executable was not shown.(see screenshot Step:1-After Build). But in the actual filesystem location (in nautilus) the executable is present. While I try to run using (right click -> Run As -> Local C/C++ application, the launcher give the error, Launch Failed. Binary Not Found (Screenshot: Step:2-Launch Failed_Binary NotFound). Then I did a refresh on the project explorer (right click -> Refresh F5), the executalbes were visible (Screenshot: Step:3-Refreshed). Now I ran the project as mentioned earlier and it ran successfully (Screenshot: Step:4-RanSuccessfull). I have to do a refresh every time I do a compile. I am not sure why this is happening.
This did not used to happen in the earlier versions of eclipse (Indigo and Helios). Could you help me, so that I dont have to do this refresh every time.

Thanks
Karthikeyan
Previous Topic:Build Configuration
Next Topic:Cannot seem to be able to compile with -O2
Goto Forum:
  


Current Time: Wed Apr 16 06:54:05 EDT 2014

Powered by FUDForum. Page generated in 0.01538 seconds