Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Problem with BIRT Report Viewer - missing JS files
Problem with BIRT Report Viewer - missing JS files [message #873165] Thu, 17 May 2012 16:09 Go to next message
Ravi Gogna is currently offline Ravi GognaFriend
Messages: 3
Registered: May 2012
Junior Member
Hi all,

First time poster, and a real BIRT newbie so apologies in advance for any missing details. I am trying to write a report in Eclipse and view it via an iframe in my webapp.

I created the report in Eclipse (3.7, using BIRT 2.6.0) and then:

- downloaded and installed the report viewer into the webapps folder
- copied my report into the birt-report webapp folder

I then tried running the report and the iframe did appear, but it ran with the following errors:

Line 468
Char: 2
Error: 'Constants' is undefined
Code: 0
URL: XXX

Line 486
Char: 5
Error: 'Constants' is undefined
Code: 0
URL: XXX

Line 530
Char: 3
Error: Object expected
Code: 0
URL: XXX

Line 542
Char: 4
Error: 'birtUtility' is undefined
Code: 0
URL: XXX

By looking at the source of the iframe, I saw that Constants and birtUtility both seem to be .js files that should be at birt/ajax/utility/ but when I look there there are no files (and actually there are no .js files anywhere in /birt/). By going to the relevant lines in the source, I am guessing that there are missing classes. Do I have to run some additionally installation to get the JARs to build? And where do those Javascript files come from?

Any help very gratefully received!
Re: Problem with BIRT Report Viewer - missing JS files [message #873672 is a reply to message #873165] Fri, 18 May 2012 20:08 Go to previous message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

Why not try the tag library with the viewer installed?
http://www.eclipse.org/birt/phoenix/deploy/viewerUsageMain.php#tags

Jason


On 5/17/2012 12:09 PM, Ravi Gogna wrote:
> Hi all,
>
> First time poster, and a real BIRT newbie so apologies in advance for
> any missing details. I am trying to write a report in Eclipse and view
> it via an iframe in my webapp.
>
> I created the report in Eclipse (3.7, using BIRT 2.6.0) and then:
>
> - downloaded and installed the report viewer into the webapps folder
> - copied my report into the birt-report webapp folder
>
> I then tried running the report and the iframe did appear, but it ran
> with the following errors:
>
> Line 468 Char: 2 Error: 'Constants' is undefined Code: 0 URL: XXX
> Line 486 Char: 5 Error: 'Constants' is undefined Code: 0 URL: XXX
> Line 530 Char: 3 Error: Object expected Code: 0 URL: XXX
> Line 542 Char: 4 Error: 'birtUtility' is undefined Code: 0 URL: XXX
> By looking at the source of the iframe, I saw that Constants and
> birtUtility both seem to be .js files that should be at
> birt/ajax/utility/ but when I look there there are no files (and
> actually there are no .js files anywhere in /birt/). By going to the
> relevant lines in the source, I am guessing that there are missing
> classes. Do I have to run some additionally installation to get the JARs
> to build? And where do those Javascript files come from?
>
> Any help very gratefully received!
>
Previous Topic:Deploying BIRT Report to Tomcat with MongoDB ODA
Next Topic:Date Picker for Eclipse 3.7
Goto Forum:
  


Current Time: Sat Dec 20 01:42:22 GMT 2014

Powered by FUDForum. Page generated in 0.02708 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software