Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » CDT editor performance problems(CDT editor performance problems)
CDT editor performance problems [message #868935] Wed, 02 May 2012 14:55 Go to next message
Andreas Deinlein is currently offline Andreas Deinlein
Messages: 6
Registered: July 2009
Junior Member
Hi,
we use CDT (indigo) in an embedded environment with GCC as compiler. Development is done on an windows XP machine.

We have performance problems with the CDT editor. The editor sporadically gets blocked for some seconds or the characters appear after some seconds while typing.

My idea would be to disable the indexer while typing and only update the index on saving the file. But i do not know, how to change the preferences for that !

Are there any ideas how to improve the performance ?

Thanks in advance,

Andreas
Re: CDT editor performance problems [message #869761 is a reply to message #868935] Fri, 04 May 2012 04:51 Go to previous messageGo to next message
Harry Houdini is currently offline Harry Houdini
Messages: 131
Registered: February 2010
Senior Member
Preferences -> C/C++ -> Indexer
Re: CDT editor performance problems [message #869898 is a reply to message #869761] Fri, 04 May 2012 12:55 Go to previous messageGo to next message
Yevgeny Shifrin is currently offline Yevgeny Shifrin
Messages: 201
Registered: July 2009
Senior Member
Hi,

I would like to mention several points that could improve editor performance:
1) Does it happens when you type "." or "->" or "::"? It is advised to uncheck "Auto-Activation" (Window -> Preferences -> C/C++ -> Editor -> Content Assist -> Auto-Activation). When you want "completion" use CTRL+SPACE.
2) In many cases when CTRL+SOME_ACTIONS are used (CTRL+C for copy, etc.) and mouse left button is pressed it could cause editor to stuck because it confuses it with hyperlink and tries to navigate. It is advised to disable this feature (Window -> Preferences -> General -> Editors -> Text Editors -> Hyperlinking -> uncheck "C/C++ elements") and use F3 or "context menu" instead.

Thanks,
Yevgeny
Re: CDT editor performance problems [message #869963 is a reply to message #869898] Sat, 05 May 2012 05:12 Go to previous messageGo to next message
Andreas Deinlein is currently offline Andreas Deinlein
Messages: 6
Registered: July 2009
Junior Member
Thanks for the hints. They are useful.

But I have the problems in the editor also while typing normal C/C++ elements or comments, not only on auto completion.

In my opinion, it has to do with live parsing/indexing ! When you type new syntax elements in the editor, you get immediately informed whether your syntax is right even before saving the file ! So the question is, how could i disable this functionality, so that the parser/indexer only works, when i save a file.

I already know the indexer preference page. There are two checkboxes:

- "Automatically update the index": "Activate this checkbox to have the index automatically update as it requires."
The question is what does this option really do ? What means "requires" ?
When i deactivate this, then also the second optiion is greyed out !

- "Update index immediately after every file-save": "Activate this checkbox to force an index update whenever a file is saved." This sounds like that, what I want to do, but even if it is checked, live check of syntax is still done. How could i deacivate this live parsing ?

Thanks,
Andreas

Re: CDT editor performance problems [message #870012 is a reply to message #869963] Sat, 05 May 2012 12:58 Go to previous message
Yevgeny Shifrin is currently offline Yevgeny Shifrin
Messages: 201
Registered: July 2009
Senior Member
Hi,

I am not really sure of the meaning of each indexing options. Live syntax checking is called "CODAN", you can disable all tests (Window -> Preferences -> C/C++ -> Code Analysis).

Thanks,
Yevgeny
Previous Topic:Problem reading text file using argc and argv
Next Topic:Install CDT for puppy linux
Goto Forum:
  


Current Time: Sat Aug 02 00:36:23 EDT 2014

Powered by FUDForum. Page generated in 0.02690 seconds