Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » java.lang.NoClassDefFoundError: org/eclipse/core/runtime/FileLocator
java.lang.NoClassDefFoundError: org/eclipse/core/runtime/FileLocator [message #112450] Tue, 24 June 2008 18:45 Go to next message
Eclipse UserFriend
Originally posted by: mburbidg.adobe.com

I'm getting the following exception:

java.lang.NoClassDefFoundError: org/eclipse/core/runtime/FileLocator
at
com.adobe.clover.deployer.DeployBundleJob.initialize(DeployB undleJob.java:37)
at
com.adobe.clover.deployer.DeployBundleJob.execute(DeployBund leJob.java:23)
at org.quartz.core.JobRunShell.run(JobRunShell.java:202)
at
org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThr eadPool.java:529)

So I added org.eclipse.core.runtime to my manifest imports, which look
like:

Import-Package: javax.xml.parsers,
org.apache.commons.lang,org.apache.commons.lang.exception,or g.apache.commons.lang.text,
org.apache.commons.logging,org.apache.commons.logging.impl,
org.apache.commons.beanutils,
org.apache.commons.configuration,
org.quartz,
org.springframework.beans.factory,
org.springframework.scheduling.quartz,
org.w3c.dom, org.apache.xml.serialize,
org.osgi.framework,
org.eclipse.core.runtime

Now I don't get a runtime exception, but the equinox log contains the
following entry:

!ENTRY com.adobe.clover.deployer 4 0 2008-06-24 11:37:46.775
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved.
Reason: Missing Constraint: Import-Package: org.eclipse.core.runtime;
version="0.0.0"
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:305)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:350)
at
org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1118)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:634)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:508)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:282)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:468)
at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:195)
at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:297)

!ENTRY org.eclipse.osgi 4 0 2008-06-24 11:37:47.441
!MESSAGE Bundle
initial@reference:file:foundation/com.adobe.clover.deployer.jar/ was not
resolved.

The package org.eclipse.core.runtime is in the equnix bundle named
org.eclipse.equinox.common_3.3.0.v20070426.jar, which I start up as the
first bundle. This is what is in my config.ini:

osgi.bundles=\
foundation/org.eclipse.equinox.common_3.3.0.v20070426.jar@:s tart,\
foundation/com.springsource.org.apache.commons.logging-1.1.1 .jar,\
...
foundation/com.adobe.clover.deployer.jar@:start

If I do a status from the equinox command prompt I can see that the bundle
org.eclipse.equinox.common_3.3.0.v20070426.jar is started. I don't
understand why my bundle can't resolve it's reference to this bundle.

Any suggestions?

Michael-
Re: java.lang.NoClassDefFoundError: org/eclipse/core/runtime/FileLocator [message #112463 is a reply to message #112450] Tue, 24 June 2008 21:30 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mburbidg.adobe.com

I believe this is because the package org.eclipse.core.runtime is
partially implemented in two different bundles. I believe this confuses
equinox. I have had this problem before with partially implemented
packages in different bundles. Both
org.eclipse.osgi_3.3.2.R33x_v20080105.jar and
org.eclipse.equinox.common_3.3.0.v20070426.jar have partial
implementations of org.eclipse.core.runtime.

Please if anyone can enlighten me as to what is going on here I would
really appreciate it. I must have some fundamental misunderstanding of
OSGi. I'm about ready to give up on it because of constant wrestling and
frustration with dependencies.

Thanks,
Michael-
Re: java.lang.NoClassDefFoundError: org/eclipse/core/runtime/FileLocator [message #112503 is a reply to message #112450] Wed, 25 June 2008 14:39 Go to previous message
Oleg Besedin is currently offline Oleg BesedinFriend
Messages: 41
Registered: July 2009
Member
This is a multi-part message in MIME format.

------=_NextPart_000_0017_01C8D6AF.B8914C50
Content-Type: text/plain;
charset="iso-8859-15"
Content-Transfer-Encoding: quoted-printable

Hi Michael,
If you'd like to depend on the org.eclipse.equinox.common bundle only, =
put the following line in the Import statements:

Import-Package: org.eclipse.core.runtime;common=3Dsplit,

or use:

Require-Bundle: org.eclipse.equinox.common

I do agree that split packages are rather confusing. Hope this helps.

Thanks,
Oleg

"Michael Burbidge" <mburbidg@adobe.com> wrote in message =
news:9d28f0e393e4b26cd81f0bf42ca97fee$1@www.eclipse.org...
> I'm getting the following exception:
>=20
> java.lang.NoClassDefFoundError: org/eclipse/core/runtime/FileLocator
> at=20
> =
com.adobe.clover.deployer.DeployBundleJob.initialize(DeployB undleJob.java=
:37)
> at=20
> =
com.adobe.clover.deployer.DeployBundleJob.execute(DeployBund leJob.java:23=
)
> at org.quartz.core.JobRunShell.run(JobRunShell.java:202)
> at=20
> =
org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThr eadPool.java:=
529)
>=20
> So I added org.eclipse.core.runtime to my manifest imports, which look =

> like:
>=20
> Import-Package: javax.xml.parsers,
> =
org.apache.commons.lang,org.apache.commons.lang.exception,or g.apache.comm=
ons.lang.text,
> org.apache.commons.logging,org.apache.commons.logging.impl,
> org.apache.commons.beanutils,
> org.apache.commons.configuration,
> org.quartz,
> org.springframework.beans.factory,
> org.springframework.scheduling.quartz,
> org.w3c.dom, org.apache.xml.serialize,
> org.osgi.framework,
> org.eclipse.core.runtime
>=20
> Now I don't get a runtime exception, but the equinox log contains the=20
> following entry:
>=20
> !ENTRY com.adobe.clover.deployer 4 0 2008-06-24 11:37:46.775
> !MESSAGE=20
> !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.=20
> Reason: Missing Constraint: Import-Package: org.eclipse.core.runtime;=20
> version=3D"0.0.0"
> at=20
> =
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHos=
t.java:305)
> at=20
> =
org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBu=
ndle.java:350)
> at=20
> =
org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework=
..java:1118)
> at=20
> =
org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(=
StartLevelManager.java:634)
> at=20
> =
org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartL=
evelManager.java:508)
> at=20
> =
org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLeve=
l(StartLevelManager.java:282)
> at=20
> =
org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(=
StartLevelManager.java:468)
> at=20
> =
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManag=
er.java:195)
> at=20
> =
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventMan=
ager.java:297)
>=20
> !ENTRY org.eclipse.osgi 4 0 2008-06-24 11:37:47.441
> !MESSAGE Bundle=20
> initial@reference:file:foundation/com.adobe.clover.deployer.jar/ was =
not=20
> resolved.
>=20
> The package org.eclipse.core.runtime is in the equnix bundle named=20
> org.eclipse.equinox.common_3.3.0.v20070426.jar, which I start up as =
the=20
> first bundle. This is what is in my config.ini:
>=20
> osgi.bundles=3D\
> foundation/org.eclipse.equinox.common_3.3.0.v20070426.jar@:s tart,\
> foundation/com.springsource.org.apache.commons.logging-1.1.1 .jar,\
> ..
> foundation/com.adobe.clover.deployer.jar@:start
>=20
> If I do a status from the equinox command prompt I can see that the =
bundle=20
> org.eclipse.equinox.common_3.3.0.v20070426.jar is started. I don't=20
> understand why my bundle can't resolve it's reference to this bundle.
>=20
> Any suggestions?
>=20
> Michael-
>=20
>=20
>
------=_NextPart_000_0017_01C8D6AF.B8914C50
Content-Type: text/html;
charset="iso-8859-15"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=3DContent-Type content=3D"text/html; =
charset=3Diso-8859-15">
<META content=3D"MSHTML 6.00.2900.3354" name=3DGENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY>
<DIV><FONT face=3DArial size=3D2>Hi Michael,</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>If you'd like to depend on the=20
org.eclipse.equinox.common bundle only, put the following line in the =
Import=20
statements:</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>&nbsp;&nbsp;&nbsp; Import-Package:=20
org.eclipse.core.runtime<STRONG>;common=3Dsplit</STRONG>, </FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>or use:</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>&nbsp;&nbsp;&nbsp; Require-Bundle:=20
org.eclipse.equinox.common</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>I do agree that split packages are =
rather=20
confusing. </FONT><FONT face=3DArial size=3D2>Hope this =
helps.</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>Thanks,</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>Oleg</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>"Michael Burbidge" &lt;</FONT><A=20
href=3D"mailto:mburbidg@adobe.com"><FONT face=3DArial=20
size=3D2>mburbidg@adobe.com</FONT></A><FONT face=3DArial size=3D2>&gt; =
wrote in=20
message </FONT><A=20
href=3D"news:9d28f0e393e4b26cd81f0bf42ca97fee$1@www.eclipse.org"><FONT =
face=3DArial=20
size=3D2>news:9d28f0e393e4b26cd81f0bf42ca97fee$1@www.eclipse.org</FONT></=
A><FONT=20
face=3DArial size=3D2>...</FONT></DIV><FONT face=3DArial size=3D2>&gt; =
I'm getting the=20
following exception:<BR>&gt; <BR>&gt; java.lang.NoClassDefFoundError:=20
org/eclipse/core/runtime/FileLocator<BR>&gt; at <BR>&gt;=20
com.adobe.clover.deployer.DeployBundleJob.initialize(DeployB undleJob.java=
:37)<BR>&gt;=20
at <BR>&gt;=20
com.adobe.clover.deployer.DeployBundleJob.execute(DeployBund leJob.java:23=
)<BR>&gt;=20
at org.quartz.core.JobRunShell.run(JobRunShell.java:202)<BR>&gt; at =
<BR>&gt;=20
org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThr eadPool.java:=
529)<BR>&gt;=20
<BR>&gt; So I added org.eclipse.core.runtime to my manifest imports, =
which look=20
<BR>&gt; like:<BR>&gt; <BR>&gt; Import-Package:&nbsp;=20
javax.xml.parsers,<BR> &gt;&nbsp;org.apache.commons.lang,org.apache.common=
s.lang.exception,org.apache.commons.lang.text,<BR>&gt;&nbsp;org.apache.co=
mmons.logging,org.apache.commons.logging.impl,<BR>&gt;&nbsp;org.apache.co=
mmons.beanutils,<BR>&gt;&nbsp;org.apache.commons.configuration, <BR>&gt;&n=
bsp;org.quartz,<BR>&gt;&nbsp;org.springframework.beans.factory, <BR>&gt;&n=
bsp;org.springframework.scheduling.quartz,<BR>&gt;&nbsp;org.w3c.dom,=20
org.apache.xml.serialize,<BR>&gt;&nbsp;org.osgi.framework, <BR>&gt;&nbsp;o=
rg.eclipse.core.runtime<BR>&gt;=20
<BR>&gt; Now I don't get a runtime exception, but the equinox log =
contains the=20
<BR>&gt; following entry:<BR>&gt; <BR>&gt; !ENTRY =
com.adobe.clover.deployer 4 0=20
2008-06-24 11:37:46.775<BR>&gt; !MESSAGE <BR>&gt; !STACK 0<BR>&gt;=20
org.osgi.framework.BundleException: The bundle could not be resolved. =
<BR>&gt;=20
Reason: Missing Constraint: Import-Package: org.eclipse.core.runtime; =
<BR>&gt;=20
version=3D"0.0.0"<BR>&gt; at <BR>&gt;=20
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHos=
t.java:305)<BR>&gt;=20
at <BR>&gt;=20
org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBu=
ndle.java:350)<BR>&gt;=20
at <BR>&gt;=20
org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework=
..java:1118)<BR>&gt;=20
at <BR>&gt;=20
org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(=
StartLevelManager.java:634)<BR>&gt;=20
at <BR>&gt;=20
org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartL=
evelManager.java:508)<BR>&gt;=20
at <BR>&gt;=20
org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLeve=
l(StartLevelManager.java:282)<BR>&gt;=20
at <BR>&gt;=20
org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(=
StartLevelManager.java:468)<BR>&gt;=20
at <BR>&gt;=20
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManag=
er.java:195)<BR>&gt;=20
at <BR>&gt;=20
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventMan=
ager.java:297)<BR>&gt;=20
<BR>&gt; !ENTRY org.eclipse.osgi 4 0 2008-06-24 11:37:47.441<BR>&gt; =
!MESSAGE=20
Bundle <BR>&gt; </FONT><A=20
href=3D"mailto:initial@reference:file:foundation/com.adobe.clover.deploye=
r.jar/"><FONT=20
face=3DArial=20
size=3D2>initial@reference:file:foundation/com.adobe.clover.deployer.jar/=
</FONT></A><FONT=20
face=3DArial size=3D2> was not <BR>&gt; resolved.<BR>&gt; <BR>&gt; The =
package=20
org.eclipse.core.runtime is in the equnix bundle named <BR>&gt;=20
org.eclipse.equinox.common_3.3.0.v20070426.jar, which I start up as the =
<BR>&gt;=20
first bundle. This is what is in my config.ini:<BR>&gt; <BR>&gt;=20
osgi.bundles=3D\<BR>&gt; </FONT><A=20
href=3D" mailto:foundation/org.eclipse.equinox.common_3.3.0.v20070426 .jar@=
:start,\"><FONT=20
face=3DArial=20
size=3D2> foundation/org.eclipse.equinox.common_3.3.0.v20070426.jar@:s tart=
,\</FONT></A><BR><FONT=20
face=3DArial size=3D2>&gt;=20
foundation/com.springsource.org.apache.commons.logging-1.1.1 .jar,\ <BR>&gt=
;=20
...<BR>&gt; </FONT><A=20
href=3D"mailto:foundation/com.adobe.clover.deployer.jar@:start "><FONT =
face=3DArial=20
size=3D2>foundation/com.adobe.clover.deployer.jar@:start</FONT ></A><BR><F=
ONT=20
face=3DArial size=3D2>&gt; <BR>&gt; If I do a status from the equinox =
command prompt=20
I can see that the bundle <BR>&gt;=20
org.eclipse.equinox.common_3.3.0.v20070426.jar is started. I don't =
<BR>&gt;=20
understand why my bundle can't resolve it's reference to this =
bundle.<BR>&gt;=20
<BR>&gt; Any suggestions?<BR>&gt; <BR>&gt; Michael-<BR>&gt; <BR>&gt;=20
<BR>&gt;</FONT></BODY></HTML>

------=_NextPart_000_0017_01C8D6AF.B8914C50--
Previous Topic:P2 server-side usage...
Next Topic:config.ini Cannot Set "user.name" in Equinox
Goto Forum:
  


Current Time: Thu Nov 27 13:26:56 GMT 2014

Powered by FUDForum. Page generated in 0.04729 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software