Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Papyrus 0.9.0M6 Installation Problem - pushingpixels
icon9.gif  Papyrus 0.9.0M6 Installation Problem - pushingpixels [message #860807] Sat, 28 April 2012 07:59 Go to next message
MyungWoon Oh is currently offline MyungWoon OhFriend
Messages: 30
Registered: March 2012
Member
While installing Papyrus 0.9.0M6 to Eclipse Juno through the downloaded .Zip file,

Juno says,

-------
Cannot complete the install because one or more required items could not be found.
Software being installed: Papyrus SDK Binaries (Incubation) 0.9.0.v201203211542 (org.eclipse.papyrus.sdk.feature.feature.group 0.9.0.v201203211542)
Missing requirement: XWT (Incubation) 0.9.1.v20110603 (org.eclipse.e4.xwt 0.9.1.v20110603) requires 'bundle org.pushingpixels.trident 1.2.0' but it could not be found
Cannot satisfy dependency:
From: XWT UI Plug-in (Incubation) 0.9.0.v20101021 (org.eclipse.e4.xwt.tools.ui 0.9.0.v20101021)
To: bundle org.eclipse.e4.xwt 0.0.0
Cannot satisfy dependency:
From: Papyrus SDK Binaries (Incubation) 0.9.0.v201203211542 (org.eclipse.papyrus.sdk.feature.feature.group 0.9.0.v201203211542)
To: org.eclipse.e4.xwt.tools.ui [0.9.0.v20101021]
-----------

I couldn't get 'org.pushingpixels.trident 1.2.0' from anywhere.

When I install Papyrus through 'Help > Install Modelling Components > Papyrus',
Juno produces an error without exception stack trace.

Where can I get that pusingpixels bundle to successfully install Papyrus 0.9.0M6 to Juno.

If that bundle is needed to install Papyrus 0.9.0M6 to Juno,
I suggest Papyrus should include that bundle in their release.

Re: Papyrus 0.9.0M6 Installation Problem - pushingpixels [message #861011 is a reply to message #860807] Sat, 28 April 2012 10:13 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4154
Registered: July 2009
Senior Member
Hi

The trace indicates that it is org.eclipse.e4.xwt 0.9.1.v20110603 that
requires org.pushingpixels.trident 1.2.0, so the problem is that XWT
does not provide it or you have not provided the repos that XWT expects.
You are mixing Juno and Indigo installs probably on an Indigo base. I
suggest using only Juno or only Indigo, or perhaps try to be selective
in which papyrus features you install so that you don't need XWT.

Regards

Ed Willink

On 28/04/2012 08:59, MyungWoon Oh wrote:
> While installing Papyrus 0.9.0M6 to Eclipse Juno through the
> downloaded .Zip file,
>
> Juno says,
>
> -------
> Cannot complete the install because one or more required items could
> not be found.
> Software being installed: Papyrus SDK Binaries (Incubation)
> 0.9.0.v201203211542 (org.eclipse.papyrus.sdk.feature.feature.group
> 0.9.0.v201203211542)
> Missing requirement: XWT (Incubation) 0.9.1.v20110603
> (org.eclipse.e4.xwt 0.9.1.v20110603) requires 'bundle
> org.pushingpixels.trident 1.2.0' but it could not be found
> Cannot satisfy dependency:
> From: XWT UI Plug-in (Incubation) 0.9.0.v20101021
> (org.eclipse.e4.xwt.tools.ui 0.9.0.v20101021)
> To: bundle org.eclipse.e4.xwt 0.0.0
> Cannot satisfy dependency:
> From: Papyrus SDK Binaries (Incubation) 0.9.0.v201203211542
> (org.eclipse.papyrus.sdk.feature.feature.group 0.9.0.v201203211542)
> To: org.eclipse.e4.xwt.tools.ui [0.9.0.v20101021]
> -----------
>
> I couldn't get 'org.pushingpixels.trident 1.2.0' from anywhere.
>
> When I install Papyrus through 'Help > Install Modelling Components >
> Papyrus',
> Juno produces an error without exception stack trace.
>
> Where can I get that pusingpixels bundle to successfully install
> Papyrus 0.9.0M6 to Juno.
>
> If that bundle is needed to install Papyrus 0.9.0M6 to Juno,
> I suggest Papyrus should include that bundle in their release.
>
>
Re: Papyrus 0.9.0M6 Installation Problem - pushingpixels [message #861169 is a reply to message #861011] Sat, 28 April 2012 12:05 Go to previous messageGo to next message
MyungWoon Oh is currently offline MyungWoon OhFriend
Messages: 30
Registered: March 2012
Member
Thank you for the reply, Ed. Wink

But I don't understand what you mean by 'You are mixing Juno and Indigo installs probably on an Indigo base'

Actually I used Indigo, and I installed Juno in different folder than Indigo.
I executed Juno by double-clicking eclipse.exe in Juno folder.
Does it produce any problem? If it does, please let me know how to fix it. Wink


I know that it is org.eclipse.e4.xwt 0.9.1.v20110603 that requires org.pushingpixels.trident 1.2.0.
But Papyrus included org.eclipse.e4.xwt 0.9.1.v20110603 as its plugin,
so I need org.pushingpixels.trident 1.2.0 regardless of which plugin requires org.pushingpixels.trident 1.2.0.

Re: Papyrus 0.9.0M6 Installation Problem - pushingpixels [message #861194 is a reply to message #861169] Sat, 28 April 2012 12:20 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4154
Registered: July 2009
Senior Member
Hi

Exactly. Your base installation is Indigo, and you're trying to install
a Juno development. Sometimes it works. Sometimes it can be made to
work, but only if you're familiar with mixing and matching and the
consequent dangers.

I recommend starting with a Juno M6 base if you want the latest Papyrus.

Regards

Ed Willink

On 28/04/2012 13:05, MyungWoon Oh wrote:
> Thank you for the reply, Ed. ;)
>
> But I don't understand what you mean by 'You are mixing Juno and
> Indigo installs probably on an Indigo base'
>
> Actually I used Indigo, and I installed Juno in different folder than
> Indigo.
> I executed Juno by double-clicking eclipse.exe in Juno folder.
> Does it produce any problem? If it does, please let me know how to fix
> it. ;)
>
>
> I know that it is org.eclipse.e4.xwt 0.9.1.v20110603 that requires
> org.pushingpixels.trident 1.2.0.
> But Papyrus included org.eclipse.e4.xwt 0.9.1.v20110603 as its plugin,
> so I need org.pushingpixels.trident 1.2.0 regardless of which plugin
> requires org.pushingpixels.trident 1.2.0.
>
>
Re: Papyrus 0.9.0M6 Installation Problem - pushingpixels [message #870863 is a reply to message #861194] Thu, 10 May 2012 04:50 Go to previous messageGo to next message
MyungWoon Oh is currently offline MyungWoon OhFriend
Messages: 30
Registered: March 2012
Member
I found the solution. Very Happy

To install Papyrus0.9.0M6 on Eclipse 4, we need the following to be installed.

- E4 XWT(I removed 'http:' thanks to 25 messages limit)
update site : //download.eclipse.org/e4/downloads/drops/S-0.12M6-201203151300/repository/

- xText SDK, Runtim
update site : Juno Update Site

- EMF Model Transaction SDK, Workbench Integration(I removed 'http:' thanks to 25 messages limit)
update site : EMF - //download.eclipse.org/modeling/emf/updates/releases/

- EMF Facet SDK
update site : Juno Update Site, filter with EMF

- QVT
update site : Juno Update Site, filter with QVT

- modisco
update site : Juno Update Site, filter with modisco

- OCL
update site : Juno Update Site, filter with OCL

And to remove com.google.collect problem
In Dependency tab of Manifest.MF,
remove com.google.collect and add com.google.guava
- com.google.collect
Re: Papyrus 0.9.0M6 Installation Problem - pushingpixels [message #870867 is a reply to message #870863] Thu, 10 May 2012 05:54 Go to previous message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4154
Registered: July 2009
Senior Member
Hi

These should all be in the Juno Releases repository that is used
automatically provide you have "consult all repositories" selected.

Regards

Ed Willink

On 10/05/2012 05:50, MyungWoon Oh wrote:
> I found the solution. :d
> To install Papyrus0.9.0M6 on Eclipse 4, we need the following to be
> installed.
>
> - E4 XWT(I removed 'http:' thanks to 25 messages limit)
> update site :
> //download.eclipse.org/e4/downloads/drops/S-0.12M6-201203151300/repository/
>
> - xText SDK, Runtim
> update site : Juno Update Site
>
> - EMF Model Transaction SDK, Workbench Integration(I removed 'http:'
> thanks to 25 messages limit)
> update site : EMF - //download.eclipse.org/modeling/emf/updates/releases/
>
> - EMF Facet SDK
> update site : Juno Update Site, filter with EMF
>
> - QVT
> update site : Juno Update Site, filter with QVT
>
> - modisco
> update site : Juno Update Site, filter with modisco
>
> - OCL
> update site : Juno Update Site, filter with OCL
>
> And to remove com.google.collect problem
> In Dependency tab of Manifest.MF,
> remove com.google.collect and add com.google.guava
> - com.google.collect
Previous Topic:How to set valid nature of a Papyrus project
Next Topic:Create Object Action in Interaction Diagrams
Goto Forum:
  


Current Time: Thu Nov 27 09:48:53 GMT 2014

Powered by FUDForum. Page generated in 0.03048 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software