Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Which version of BIRT should be used for RAD6 + LWI ?
Which version of BIRT should be used for RAD6 + LWI ? [message #109523] Mon, 20 August 2007 08:40 Go to next message
Eclipse UserFriend
Originally posted by: huxiaoy.cn.ibm.com

I develope in RAD6.0.0 and target ISC on LWI (on Linux) as the deployment
framework. So, the Light Weight Infrastructure is the application server
rather than WebSphere. I tried to use BIRT in my project but failed. Is it
possible to use BIRT with RAD6 + ISC + LWI?

In the RAD directory, ..\Rational\SDP\6.0\eclipse\plugins, I found
org.eclipse.core.runtime_3.0.1 and org.eclipse.emf_2.0.1 but no GEF.

I downloaded birt-report-framework-2_2_0 and birt-runtime-2_2_0. I cannot
create a birt project after I create a new link file
org.eclipse.birt.link. I think this is because of the version issue.
Anyway, I can do the following:
- Add birt jars (from birt-runtime-2_2_0\ReportEngine\lib) to
...\WebContent\WEB-INF\lib
- Now, I can import birt report engine api (such as
org.eclipse.birt.report.engine.api.EngineConfig) in my java file.
- Then, I write code to new EngineConfig, create report engine, create a
task to run the report.
================================
deploy to lwi in linux:
With birt-runtime-2_2_0, I got the following error:
An exception occurred while writing to the platform log:
java.lang.NullPointerException
at
org.eclipse.core.runtime.internal.adaptor.EclipseEnvironment Info.guessOS
-----------------
Then I turn to birt 2.1.1, I got another error:
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:64)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.j
================================

(My project is a JSR 168 project, target server is WebSphere Portal v5.1
stub.)

Anyone could give some help? Any clue is appreciated.
Thanks a lot in advance!
Re: Which version of BIRT should be used for RAD6 + LWI ? [message #109536 is a reply to message #109523] Mon, 20 August 2007 08:41 Go to previous message
Eclipse UserFriend
Originally posted by: huxiaoy.cn.ibm.com

Sorry, I meant to post it in eclipse.birt.
Previous Topic:TPTP Agent Controller troubles
Next Topic:AGR - Problem getting started with AGR
Goto Forum:
  


Current Time: Sun Dec 21 12:07:54 GMT 2014

Powered by FUDForum. Page generated in 0.03737 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software