Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » Running JPA 1 & 2 in same Process(Will EclipseLink do this or will it emmulate 1.0?)
Running JPA 1 & 2 in same Process [message #842843] Thu, 12 April 2012 17:02 Go to next message
Jason Hodge is currently offline Jason HodgeFriend
Messages: 7
Registered: April 2012
Junior Member
I have a project running EclipseLink 2.x. The ejb jar has a JPA 2.0 persistence.xml, but it also has another jar that has a persistence.xml file declared to require JPA 1.0. The question is, can EclipseLink run 2 different persistence units, one in JPA 2, the other in JPA 1 mode? Or will it cause one to run in the other one's mode?

WebLogic 10.3.5
JDK 1.6
JDeveloper 11g
Oracle 9, Thin Driver, non XA DataSource
Re: Running JPA 1 & 2 in same Process [message #843890 is a reply to message #842843] Fri, 13 April 2012 13:19 Go to previous message
Chris Delahunt is currently offline Chris DelahuntFriend
Messages: 1039
Registered: July 2009
Senior Member
Hello,

EclipseLink, and JPA 2.0 are both backward compatible, so you should be able to run your JPA 1.0 application using the 2.0 persistence.jar. There is no 1.0 jpa mode or change in EclipseLink behavior, the only difference is that the 2.0 persistence jar exposes more api than the 1.0 jpa persitence jar.

Best Regards,
Chris
Previous Topic:Persistence
Next Topic:Metamodel not being created until after first use
Goto Forum:
  


Current Time: Fri Nov 21 19:29:25 GMT 2014

Powered by FUDForum. Page generated in 0.03019 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software