Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » xdebug on apache 2.2 with PHP 5.3(xdebug cannot be loaded)
icon5.gif  xdebug on apache 2.2 with PHP 5.3 [message #828749] Sun, 25 March 2012 08:11 Go to next message
Ethereal1m Mising name is currently offline Ethereal1m Mising nameFriend
Messages: 35
Registered: January 2010
Member
Dear all,
has anybody had luck on loading xdebug with Apache 2.2 and PHP 5.3? For some reason, it didn't get loaded. I had it working with Apache 2.2 and PHP 5.2 though....

I'm using php5.3 thread save, compiled with vc9, nondebug. Part of phpinfo:
PHP Extension Build 	API20090626,TS,VC9
Debug Build 	no
Thread Safety 	enabled 


part of php.ini for xdebug configuration:
zend_extension_ts = "C:\Program Files (x86)\PHP\php_xdebug-2.1.4-5.3-vc9.dll"
xdebug.remote_enable=On
xdebug.remote_host="localhost"
xdebug.remote_port=9000
xdebug.remote_handler="dbgp"
xdebug.remote_log="C:\Program Files (x86)\PHP\log"


what went wrong?

best regards,
ethereal1m
Re: xdebug on apache 2.2 with PHP 5.3 [message #828854 is a reply to message #828749] Sun, 25 March 2012 12:07 Go to previous messageGo to next message
sNop is currently offline sNopFriend
Messages: 281
Registered: July 2009
Senior Member
change:
zend_extension_ts = "C:\Program Files (x86)\PHP\php_xdebug-2.1.4-5.3-vc9.dll"

to:
zend_extension = "C:\Program Files (x86)\PHP\php_xdebug-2.1.4-5.3-vc9.dll"

On 25. 3. 2012 10:11, Ethereal1m Mising name wrote:
> Dear all,
> has anybody had luck on loading xdebug with Apache 2.2 and PHP 5.3? For some reason, it didn't get loaded. I had it working with Apache 2.2 and PHP 5.2 though....
>
> I'm using php5.3 thread save, compiled with vc9, nondebug. Part of phpinfo:
>
> PHP Extension Build API20090626,TS,VC9
> Debug Build no
> Thread Safety enabled
>
> part of php.ini for xdebug configuration:
>
> zend_extension_ts = "C:\Program Files (x86)\PHP\php_xdebug-2.1.4-5.3-vc9.dll"
> xdebug.remote_enable=On
> xdebug.remote_host="localhost"
> xdebug.remote_port=9000
> xdebug.remote_handler="dbgp"
> xdebug.remote_log="C:\Program Files (x86)\PHP\log"
>
>
> what went wrong?
>
> best regards,
> ethereal1m
>
Re: xdebug on apache 2.2 with PHP 5.3 [message #828924 is a reply to message #828854] Sun, 25 March 2012 14:57 Go to previous message
Ethereal1m Mising name is currently offline Ethereal1m Mising nameFriend
Messages: 35
Registered: January 2010
Member
holy crap, this works....!
I don't get it...

I thought when php is thread save, you need to put ts suffix....

Did something change?
Previous Topic:Fresh PDT install won't allow editing PHP files
Next Topic:Obtain source code from ASTNode
Goto Forum:
  


Current Time: Sat Dec 20 10:32:27 GMT 2014

Powered by FUDForum. Page generated in 0.05584 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software