Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Can ESelectionService propagate selection to 3.x legacy views?
Can ESelectionService propagate selection to 3.x legacy views? [message #820825] Wed, 14 March 2012 16:06
Fredrik Attebrant is currently offline Fredrik Attebrant
Messages: 7
Registered: October 2010
Junior Member
We have an RCP application running on the compatibility layer.
Now we are migrating parts of it to be "pure 4.x" and thus we need to be able to react to changes of selection across the "3.x/4.x" boundary.

Some trials shows that a "pure 4.x" part can detect selection changes in a 3.x part.
However, when applying a change of selection from a "pure 4.x" view, I fail to detect it in a 3.x view.

Thus, does the ESelectionService trigger changes in the "legacy selection" framework?

Setting the selection as described here:
google "vogella Eclipse4Services selectionservice" (#"!€%# forum says I've posted too few posts to be allowed to post a link... Shocked ), but you'll find it Wink

Thanks,
--Fredrik
Previous Topic:Localization in fragment not working...bug?
Next Topic:Dependency injection in Views/Editors running with the compatibility layer
Goto Forum:
  


Current Time: Wed Sep 24 04:50:11 GMT 2014

Powered by FUDForum. Page generated in 0.03504 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software