Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Orbit » How to configure jetty bundle correct with log4j?
How to configure jetty bundle correct with log4j? [message #9014] Fri, 02 February 2007 07:47 Go to next message
Martin Dames is currently offline Martin Dames
Messages: 28
Registered: July 2009
Junior Member
Hey guys,

I just being confused about the jetty bundle.. I can not configure the
log4j, jetty uses, correct. I always getting the warning message:

log4j:WARN No appenders could be found for logger
(org.mortbay.util.Container).
log4j:WARN Please initialize the log4j system properly.

I put the log4.properties file everywhere in the jetty bundle and in the
equinox.http.jetty bundle, which starts the jetty bundle in equinox... but
nothing.. it doesnt change anything. I tried a lot of stuff.

I really need some advise, how to configure the jetty bundle correct.

Please help me... I am a bit desperate! :-)

Thank you.
Re: How to configure jetty bundle correct with log4j? [message #9036 is a reply to message #9014] Fri, 02 February 2007 15:29 Go to previous message
Martin Dames is currently offline Martin Dames
Messages: 28
Registered: July 2009
Junior Member
What did I do?

I just importet the jetty working set into an empty eclipse workspace,
like described in:
http://www.eclipse.org/equinox/server/http_in_equinox.php

Then I created a new bundle, as described in
http://www.eclipse.org/equinox/server/http_writing_applicati on.php.

I ran it with a Equinox Launch Conf, and voila, everything is fine....
except for the log4j stuff by starting OSGi in the console:

osgi> log4j:WARN No appenders could be found for logger
(org.mortbay.util.Container).
log4j:WARN Please initialize the log4j system properly.

Please tell me, how to configure this properly!

Thank you.
Re: How to configure jetty bundle correct with log4j? [message #562329 is a reply to message #9014] Fri, 02 February 2007 15:29 Go to previous message
Martin Dames is currently offline Martin Dames
Messages: 28
Registered: July 2009
Junior Member
What did I do?

I just importet the jetty working set into an empty eclipse workspace,
like described in:
http://www.eclipse.org/equinox/server/http_in_equinox.php

Then I created a new bundle, as described in
http://www.eclipse.org/equinox/server/http_writing_applicati on.php

I ran it with a Equinox Launch Conf, and voila, everything is fine....
except for the log4j stuff by starting OSGi in the console:

osgi> log4j:WARN No appenders could be found for logger
(org.mortbay.util.Container).
log4j:WARN Please initialize the log4j system properly.

Please tell me, how to configure this properly!

Thank you.
Previous Topic:How to configure jetty bundle correct with log4j?
Next Topic:parser generators and their licensing
Goto Forum:
  


Current Time: Wed Apr 16 09:38:44 EDT 2014

Powered by FUDForum. Page generated in 0.08932 seconds