Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » can not run test with remote aut agent
can not run test with remote aut agent [message #807647] Sun, 26 February 2012 20:48 Go to next message
Michael Nesterenko is currently offline Michael NesterenkoFriend
Messages: 12
Registered: August 2011
Junior Member
I have installed aut agent on the remote machine. Configured aut to point on that agent and started application remotely. No problem up to this point.

When I try to run any test jubula says me that it could not connect to aut.

Quote:
2012-02-26 22:47:00.261 [Worker-13] ERROR o.e.j.c.c.c.AUTConnection - Connection to AUT could not be established.
Re: can not run test with remote aut agent [message #807938 is a reply to message #807647] Mon, 27 February 2012 07:49 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1455
Registered: July 2009
Senior Member
Hi,

If you have successfully started your AUT on the remote agent, but the test execution fails, then two things come to mind:

1. Are you perhaps connected to the Agent via the ITE and are trying to connect to the same agent via the Test Executor? Only one connection to the Agent at a time is allowed.

2. Are there perhaps firewalls in place that could be blocking communication?

HTH,
Alex
Re: can not run test with remote aut agent [message #807963 is a reply to message #807938] Mon, 27 February 2012 08:29 Go to previous messageGo to next message
Michael Nesterenko is currently offline Michael NesterenkoFriend
Messages: 12
Registered: August 2011
Junior Member
Alexandra Schladebeck wrote on Mon, 27 February 2012 09:49
Hi,

1. Are you perhaps connected to the Agent via the ITE and are trying to connect to the same agent via the Test Executor? Only one connection to the Agent at a time is allowed.


not sure exactly about what you saying, however I do the same actions when I connect to local aut agent (embedded aut agent) and tests run perfectly.

Alexandra Schladebeck wrote on Mon, 27 February 2012 09:49
Hi,
2. Are there perhaps firewalls in place that could be blocking communication?
HTH,
Alex


could you say what ports should be available, so I will check if connection can be established to that ports. However I am not aware of any firewall software blocking connections. I have several other applications connecting to the same host and I never had connectivity problems. Nevertheless I will check.
Re: can not run test with remote aut agent [message #807975 is a reply to message #807963] Mon, 27 February 2012 08:52 Go to previous messageGo to next message
Michael Nesterenko is currently offline Michael NesterenkoFriend
Messages: 12
Registered: August 2011
Junior Member
I have attached conversation log to to the remote host.
Re: can not run test with remote aut agent [message #1066449 is a reply to message #807647] Tue, 02 July 2013 17:03 Go to previous messageGo to next message
Ricardo Gonzalez is currently offline Ricardo GonzalezFriend
Messages: 1
Registered: July 2013
Junior Member
Hi everyone,

I'm starting with Jubula and what I need is to test an swing application that runs on a cash register, but I want to test it directly on the cash register and control it from my PC.

To run the test directly on the cash register, the AUT Agent has to be install on the cash register, right?

The cash register uses linux, Is there anyway to get just the AUT Agent installer for linux? Because the .sh available is quite large.

Thanks for your answers and help.
Re: can not run test with remote aut agent [message #1066562 is a reply to message #1066449] Wed, 03 July 2013 08:02 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1455
Registered: July 2009
Senior Member
Hi Ricardo,

My first guess is to say yes - the Agent must be installed there. I know that you can install the agent separately, but I understand that the .sh file itself is large. It should be possible to separately install the agent elsewhere and then copy everything over. Maybe that will help.

HTH,
Alex
Re: can not run test with remote aut agent [message #1444812 is a reply to message #807975] Tue, 14 October 2014 15:33 Go to previous messageGo to next message
Victor Martin is currently offline Victor MartinFriend
Messages: 29
Registered: July 2009
Junior Member
Were you able to find what the problem was? I'm running into the same problem. I can get my test to run on the remote machine only when I'm on a fast network. As soon as I try the same machine from home I get the same as you: I can connect to the remote agent and start the AUT, but I get the "Connection to AUT could not be established" as soon as I try to run any test suite.
Re: can not run test with remote aut agent [message #1703285 is a reply to message #1444812] Thu, 30 July 2015 10:05 Go to previous messageGo to next message
sara mel is currently offline sara melFriend
Messages: 22
Registered: April 2015
Junior Member
Hi ,
I'm using jubula to run my tests on a remote machine , everything is working when I do this from a windows machine , but i cannot connect to autagent from a linux machine is there any specific configuration for linux ?
This is the error:
[ |--->] Could not connect to AUT: W4_Composer
[ |--->] 30/07/15 11:57:32 - AUT Agent: connection closed.
[ |--->] 30/07/15 11:57:32 - Exit: Code 1
[ |--->] Result: 1
Re: can not run test with remote aut agent [message #1703366 is a reply to message #1703285] Fri, 31 July 2015 06:53 Go to previous messageGo to next message
Oliver Goetz is currently offline Oliver GoetzFriend
Messages: 190
Registered: May 2011
Senior Member
Hi,

could you provide the according log files?
Regards
Oliver
Re: can not run test with remote aut agent [message #1703372 is a reply to message #1703366] Fri, 31 July 2015 07:40 Go to previous messageGo to next message
sara mel is currently offline sara melFriend
Messages: 22
Registered: April 2015
Junior Member
this is logs content :

2015-07-30 11:28:30.685 [main] ERROR o.e.j.c.cmd.AbstractCmdlineClient - An error ocurred: Connection to AUT Agent could not be established.
2015-07-30 11:28:30.686 [main] ERROR o.e.j.c.cmd.AbstractCmdlineClient - An error ocurred: Connection to AUT Agent has been unexpectedly lost during test execution
2015-07-30 11:29:40.078 [Worker-0] ERROR o.e.j.c.c.c.AUTConnection - Connection to AUT could not be established.
2015-07-30 11:29:40.094 [Worker-0] ERROR o.e.j.c.cmd.AbstractCmdlineClient - An error ocurred: Could not connect to AUT: W4_Composer
2015-07-30 11:45:10.414 [main] WARN o.e.j.client.core.ClientTestImpl - connecting the AUT Agent failed
2015-07-30 11:45:10.455 [main] ERROR o.e.j.app.testexec.TestexecClient - Connection to AUT Agent could not be established.
org.eclipse.jubula.tools.internal.exception.CommunicationException: Connection to AUT Agent could not be established.
at org.eclipse.jubula.app.testexec.batch.ExecutionController.prepareAUTA
gentConnection(ExecutionController.java:650) ~[na:na] at org.eclipse.jubula.app.testexec.batch.ExecutionController.executeJob(
ExecutionController.java:411) ~[na:na]
at org.eclipse.jubula.app.testexec.TestexecClient.doRun(TestexecClient.java:79) ~[na:na]
at org.eclipse.jubula.client.cmd.AbstractCmdlineClient.run(AbstractCmdlineClient.java:416) [org.eclipse.jubula.client.cmd_3.0.0.201501191443.jar:na]
at org.eclipse.jubula.client.cmd.AbstractLauncher.start(AbstractLauncher
.java:24) [org.eclipse.jubula.client.cmd_3.0.0.201501191443.jar:na]
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandl
e.java:196) [org.eclipse.equinox.app_1.3.200.v20130910-1609.jar:na]
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134) [org.eclipse.osgi_3.10.1.v20140909-1633.jar: na]
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104) [org.eclipse.osgi_3.10.1.v20140909-1633.jar:na]
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380) [org.eclipse.osgi_3.10.1.v20140909-1633.jar:na]
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235) [org.eclipse.osgi_3.10.1.v20140909-1633.jar:na]
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:1.7.0_72]
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) ~[na:1.7.0_72]
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[na:1.7.0_72]
at java.lang.reflect.Method.invoke(Method.java:606) ~[na:1.7.0_72]
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648) [org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar:na]
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603) [org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar:na]
at org.eclipse.equinox.launcher.Main.run(Main.java:1465) [org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar:na]
at org.eclipse.equinox.launcher.Main.main(Main.java:1438) [org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar:na]
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:1.7.0_72]
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) ~[na:1.7.0_72]
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[na:1.7.0_72]
at java.lang.reflect.Method.invoke(Method.java:606) ~[na:1.7.0_72]
at com.exe4j.runtime.LauncherEngine.launch(Unknown Source) [i4jruntime.jar:na]
at com.install4j.runtime.launcher.Launcher.main(Unknown Source) [i4jruntime.jar:na]
2015-07-30 11:45:10.456 [main] ERROR o.e.j.c.cmd.AbstractCmdlineClient - An error ocurred: Connection to AUT Agent could not be established.
2015-07-30 11:45:10.456 [main] ERROR o.e.j.c.cmd.AbstractCmdlineClient - An error ocurred: Connection to AUT Agent has been unexpectedly lost during test execution
2015-07-30 11:54:36.178 [Worker-0] ERROR o.e.j.c.c.c.AUTConnection - Connection to AUT could not be established.
2015-07-30 11:54:36.194 [Worker-0] ERROR o.e.j.c.cmd.AbstractCmdlineClient - An error ocurred: Could not connect to AUT: W4_Composer
2015-07-30 11:57:32.384 [Worker-0] ERROR o.e.j.c.c.c.AUTConnection - Connection to AUT could not be established.
2015-07-30 11:57:32.401 [Worker-0] ERROR o.e.j.c.cmd.AbstractCmdlineClient - An error ocurred: Could not connect to AUT: W4_Composer
Re: can not run test with remote aut agent [message #1703564 is a reply to message #1703372] Mon, 03 August 2015 06:44 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1455
Registered: July 2009
Senior Member
Could it be a firewall problem?
http://testing.bredex.de/faqs/what-ports-does-jubula-require-for-testing.html
http://testing.bredex.de/faqs/what-connections-are-required-between-the-ite-and-the-aut-agent.html

Best regards,
Alex

Re: can not run test with remote aut agent [message #1703612 is a reply to message #1703564] Mon, 03 August 2015 15:56 Go to previous messageGo to next message
sara mel is currently offline sara melFriend
Messages: 22
Registered: April 2015
Junior Member
I think It is complaining about the display , in fact I'm using a linux server which does not allow -X (graphical interfaces) , so it seems to be normal because swt is a graphical library , I tried on an other linux machine with graphical interface and it works
Re: can not run test with remote aut agent [message #1716715 is a reply to message #1703612] Mon, 07 December 2015 16:56 Go to previous messageGo to next message
Luca Da Rin Fioretto is currently offline Luca Da Rin FiorettoFriend
Messages: 6
Registered: November 2015
Junior Member
Hello,

I have the exact same problem here. When I try to remotely launch the tests, the autagent launches the AUT but then then it seems that the AUT cannot establish a connection with the testexec. I'm working with Linux virtual machines on the same private network and I have disabled both firewalls.

Is there a way I can troubleshoot this?

Thank you.

Luca
Re: can not run test with remote aut agent [message #1716806 is a reply to message #1716715] Tue, 08 December 2015 10:56 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1455
Registered: July 2009
Senior Member
Hi Luca,

If it is the same configuration as Sara's then it will probably be because there is no graphical user interface on the system. Jubula does require a UI to run tests.

Best regards,
Alex
Re: can not run test with remote aut agent [message #1716822 is a reply to message #1716806] Tue, 08 December 2015 12:15 Go to previous messageGo to next message
Joost Andrae is currently offline Joost AndraeFriend
Messages: 12
Registered: January 2014
Junior Member
Hi there,

not with Jubula but using other automation tools on Linux and Solaris I often used xvfb to pass graphical output to a vitrual display. If you use it then configure it with useful display size and color depth.

see: https://en.wikipedia.org/wiki/Xvfb

Kind regards, Joost
Re: can not run test with remote aut agent [message #1716844 is a reply to message #1716806] Tue, 08 December 2015 14:10 Go to previous messageGo to next message
Luca Da Rin Fioretto is currently offline Luca Da Rin FiorettoFriend
Messages: 6
Registered: November 2015
Junior Member
The problem is not the graphical interface, in fact I got the same error when I tried to launch the tests from the GUI.

I'm trying to run tests remotely using the command line testexec. Of course there is a GUI installed and running on the target machine (where autagent and AUT are installed).

The problem it's perhaps that the AUT (spawned by testexec through the autagent) cannot reach back the calling testexc (even though I have disabled all firewalls). So, my question is: is there a way to get a more detailed error in order to troubleshoot this problem?

Thank you.
Re: can not run test with remote aut agent [message #1716954 is a reply to message #1716844] Wed, 09 December 2015 09:43 Go to previous messageGo to next message
Oliver Goetz is currently offline Oliver GoetzFriend
Messages: 190
Registered: May 2011
Senior Member
Hi,

do the log-files contain any useful Information? You can find them in <YourHomeDirectory>/<.jubula>/<logs>.
Regards
Oliver
Re: can not run test with remote aut agent [message #1717151 is a reply to message #1716954] Thu, 10 December 2015 10:15 Go to previous message
Luca Da Rin Fioretto is currently offline Luca Da Rin FiorettoFriend
Messages: 6
Registered: November 2015
Junior Member
Oliver Goetz wrote on Wed, 09 December 2015 09:43
Hi,

do the log-files contain any useful Information? You can find them in <YourHomeDirectory>/<.jubula>/<logs>.
Regards
Oliver


Thank you Oliver,

I was able to solve the problem, but the following might be useful for others in my situation.

My system has three virtual machines running different Linux distros guests on VirtualBox on a Windows 8 host OS. Each machine is configured with two network adapters, a NAT as primary and a Host-Only as secondary. They can talk betbeen each other on the Host-Only private network as they're all in the same subnet.

The way Jubula handle remote AUT connections is described at (add http) testing.bredex.de/faqs/what-connections-are-required-between-the-ite-and-the-aut-agent.html. (I can't as the forum is preventing me from posting URLs as I don't have more than 5 posts. But let's continue.) So what happened on my system is that the machine running the testexec process was able to successfully call the remote autagent but then the AUT wasn't able to reach back the testexec process as shown in the log produced by the AUT (<HomeDirectory>/<.jubula>/<logs>) below:

2015-12-08 16:53:48.001 [Connection.ReaderThread:Socket[addr=localhost/127.0.0.1,port=58415,localport=53721]] ERROR o.e.j.r.c.c.ConnectToClientCommand - Error while attempting to connect to client.
java.net.UnknownHostException: controller: unknown error
        at java.net.Inet6AddressImpl.lookupAllHostAddr(Native Method) ~[na:1.8.0_66]
        at java.net.InetAddress$2.lookupAllHostAddr(InetAddress.java:928) ~[na:1.8.0_66]
        at java.net.InetAddress.getAddressesFromNameService(InetAddress.java:1323) ~[na:1.8.0_66]
        at java.net.InetAddress.getAllByName0(InetAddress.java:1276) ~[na:1.8.0_66]
        at java.net.InetAddress.getAllByName(InetAddress.java:1192) ~[na:1.8.0_66]
        at java.net.InetAddress.getAllByName(InetAddress.java:1126) ~[na:1.8.0_66]
        at java.net.InetAddress.getByName(InetAddress.java:1076) ~[na:1.8.0_66]
        at org.eclipse.jubula.rc.common.AUTServer.initClientCommunication(AUTServer.java:511) ~[org.eclipse.jubula.rc.common.jar:na]
        at org.eclipse.jubula.rc.common.commands.ConnectToClientCommand.execute(ConnectToClientCommand.java:41) ~[org.eclipse.jubula.rc.common.jar:na]
        at org.eclipse.jubula.communication.internal.Communicator$ConnectionListener.received(Communicator.java:918) [org.eclipse.jubula.communication.jar:na]
        at org.eclipse.jubula.communication.internal.connection.Connection.fireMessageReceived(Connection.java:402) [org.eclipse.jubula.communication.jar:na]
        at org.eclipse.jubula.communication.internal.connection.Connection.access$2(Connection.java:391) [org.eclipse.jubula.communication.jar:na]
        at org.eclipse.jubula.communication.internal.connection.Connection$ReaderThread.run(Connection.java:454) [org.eclipse.jubula.communication.jar:na]


Where "controller" is the hostname of the machine running the testexec. Looks to me that the AUT machine is trying to contact "controller" instead of the private IP of the testexec machine. Hence if you don't have a DNS on your system this won't work. So the way I solved the problem is by modifying the primary network interface of the testexec machine from NAT to bridged.

[Updated on: Fri, 11 December 2015 18:05]

Report message to a moderator

Previous Topic:Jubula doesn't recognize JavaFX Tree after initial mapping.
Next Topic:Problems with the lock manager
Goto Forum:
  


Current Time: Sat Feb 06 03:14:25 GMT 2016

Powered by FUDForum. Page generated in 0.07457 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software