Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » C++ analysis does nothing (E3.3, TPTP4.4)
C++ analysis does nothing (E3.3, TPTP4.4) [message #96194] Wed, 18 April 2007 05:21 Go to next message
Tarjei Knapstad is currently offline Tarjei Knapstad
Messages: 6
Registered: July 2009
Junior Member
Hi all,

I made an attempt on performing static analysis on a C++ application
today, but it doesn't look like any analysis is actually performed. I've
created a new analysis configuration and ticked off all the "Code Review
for C/C++" rules. When I click "Analyze" I get an empty report, and an
event log that says [0 results in 0 ms]. I've tried both analyzing a
specific project and the entire workspace.

Are there any logs written that I can check to figure out what's (not)
going on? Any ideas as to what I might be doing wrong?

Platform details (basically the "latest and greatest"):
OS: Linux (CentOS 4.4)
JRE: SUN 1.5.0.11
Eclipse: 3.3M6 (Europa)
TPTP: 4.4.0
Cpp rules:
org.eclipse.tptp.platform.analysis.codereview.cpp-TPTP-4.4.0 -200703270100C.zip

Regards,
--
Tarjei
Re: C++ analysis does nothing (E3.3, TPTP4.4) [message #96600 is a reply to message #96194] Sun, 22 April 2007 20:51 Go to previous messageGo to next message
Eclipse User
Originally posted by: s_gutz.ca.ibm.com

Do you have CDT installed? You want CDT 3.x not 4.0 (there are some
problems with the latter)


Tarjei Knapstad wrote:
> Hi all,
>
> I made an attempt on performing static analysis on a C++ application
> today, but it doesn't look like any analysis is actually performed. I've
> created a new analysis configuration and ticked off all the "Code Review
> for C/C++" rules. When I click "Analyze" I get an empty report, and an
> event log that says [0 results in 0 ms]. I've tried both analyzing a
> specific project and the entire workspace.
>
> Are there any logs written that I can check to figure out what's (not)
> going on? Any ideas as to what I might be doing wrong?
>
> Platform details (basically the "latest and greatest"):
> OS: Linux (CentOS 4.4)
> JRE: SUN 1.5.0.11
> Eclipse: 3.3M6 (Europa)
> TPTP: 4.4.0
> Cpp rules:
> org.eclipse.tptp.platform.analysis.codereview.cpp-TPTP-4.4.0 -200703270100C.zip
>
>
> Regards,
> --
> Tarjei
Re: C++ analysis does nothing (E3.3, TPTP4.4) [message #96853 is a reply to message #96600] Wed, 25 April 2007 04:18 Go to previous message
Tarjei Knapstad is currently offline Tarjei Knapstad
Messages: 6
Registered: July 2009
Junior Member
Steve Gutz wrote:
> Do you have CDT installed? You want CDT 3.x not 4.0 (there are some
> problems with the latter)
>

Aha, I've got 4.0 installed of course... :) Will just wait for this to
be fixed then. Is there a bugreport in Bugzilla I can watch? (I couldn't
find one when searching the "TPTP Static Analysis" bugs).

--
Tarjei
Previous Topic:TPTP & XML report improvement
Next Topic:TPTP auto gui testing ..
Goto Forum:
  


Current Time: Mon Apr 21 05:44:49 EDT 2014

Powered by FUDForum. Page generated in 0.02335 seconds