Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Problem running app with multiple versions of the same bundle selected(Possibly an incorrect config.ini generated)
Problem running app with multiple versions of the same bundle selected [message #792861] Tue, 07 February 2012 14:01 Go to next message
Mark .Friend
Messages: 12
Registered: July 2010
Junior Member
Hi all,

I have two versions of camel-core selected in my launch configuration, 2.75 and 2.9.0.
When I run my app, only one of them is loaded (2.7.5) which is the one my plugins depend upon. Now, my plugins also depend upon a bundle which in turn depends upon camel 2.9.0.

I have both version in my target platform and both are selected in the PDE launch config. However, the plugin which depends upon the 2.9.0 version is not resolved because it cannot find 2.9.0 (see below)

Framework is launched.

id	State       Bundle
56	INSTALLED   org.hb.core.commons_0.0.1.SNAPSHOT

osgi> diag 56
initial@reference:file:../hb-bundles/commons-0.0.1-SNAPSHOT.jar/ [56]
  Direct constraints which are unresolved:
    Missing imported package org.apache.camel_[2.9.0,3.0.0).


I have looked at the config.ini file generated by eclipse and noticed that the camel 2.9.0 jar is not references at all, only the 2.7.5 version. Remember, both versions were selected in plug-ins tab of the Eclipse application run configuration.

Any ideas?
Re: Problem running app with multiple versions of the same bundle selected [message #793017 is a reply to message #792861] Tue, 07 February 2012 17:10 Go to previous messageGo to next message
John B is currently offline John BFriend
Messages: 18
Registered: November 2011
Junior Member
Do you have the dependency on camel core 2.9.0 in your plugin.xml dependencies tab defined?
Re: Problem running app with multiple versions of the same bundle selected [message #793100 is a reply to message #793017] Tue, 07 February 2012 19:30 Go to previous message
Mark .Friend
Messages: 12
Registered: July 2010
Junior Member
Well, it's not a direct dependency. See ascii diagram Smile

MyPlugin ----depends---> camel 2.7.5
        |
        |----------depends---> OSGiBundleX ---depends---> camel 2.9.0


Perhaps the PDE is being clever and calculating that the plugins don't require camel 2.9.0 directly without taking into account raw OSGi bundles i.e. those with no plugin.xml.
Previous Topic:PropertyDescriptor with Combobox and String values
Next Topic:Project Explorer navigator content dropAssistant validate drop not being called
Goto Forum:
  


Current Time: Mon Nov 24 15:31:20 GMT 2014

Powered by FUDForum. Page generated in 0.03293 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software