Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Problem running app with multiple versions of the same bundle selected(Possibly an incorrect config.ini generated)
Problem running app with multiple versions of the same bundle selected [message #791924] Mon, 06 February 2012 12:25
Mark .Friend
Messages: 12
Registered: July 2010
Junior Member
Hi all,

I have two versions of camel-core selected in my launch configuration, 2.75 and 2.9.0.
When I run my app, only one of them is loaded (2.7.5) which is the one my plugins depend upon. Now, my plugins also depend upon a bundle which in turn depends upon camel 2.9.0.

I have both version in my target platform and both are selected in the PDE launch config. However, the plugin which depends upon the 2.9.0 version is not resolved because it cannot find 2.9.0 (see below)

Framework is launched.

id	State       Bundle
56	INSTALLED   org.hb.core.commons_0.0.1.SNAPSHOT

osgi> diag 56
initial@reference:file:../hb-bundles/commons-0.0.1-SNAPSHOT.jar/ [56]
  Direct constraints which are unresolved:
    Missing imported package org.apache.camel_[2.9.0,3.0.0).


I have looked at the config.ini file generated by eclipse and noticed that the camel 2.9.0 jar is not references at all, only the 2.7.5 version. Remember, both versions were selected in plug-ins tab of the Eclipse application run configuration.

Any ideas?

[Updated on: Mon, 06 February 2012 16:20]

Report message to a moderator

Previous Topic:Non p2 compliant plugin not loading in Solaris
Next Topic:Adding combo box on toolbar of eclipse
Goto Forum:
  


Current Time: Sat Nov 25 06:01:51 GMT 2017

Powered by FUDForum. Page generated in 0.02452 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software