Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » profiler stops receiving data after a few mins
profiler stops receiving data after a few mins [message #89833] Fri, 08 December 2006 22:48
Eclipse User
Originally posted by: rmeador.wpi.edu

Hi,
I'm attempting to use the TPTP profiler to profile tomcat running on a
remote system. Both the system I'm running eclipse/tptp on and the tomcat
server are SUSE 9.3 linux. I'm using the "attach - java process"
configuration type rather than "apache tomcat" because the tomcat one
seems to want to launch the server itself on the local machine and I need
it to connect to an existing remote process.

The first time I tried this, it worked quite well, except that the server
was very, very slow. I was able to pull up the main page of the website,
log in, do some other stuff. I was just getting a feel for how it worked,
so I don't recall if it stopped recording data or not.

A few subsequent times I've tried this (and I've restarted eclipse, the
RAC and tomcat to ensure none of those are issues), I've been able to get
the main page and attempt to log in, but it takes about 10 minutes to get
logged in. Another 15 minutes or so to begin using the webapp I logged
into... then I stop getting data.

Most recently, I can't even get fully logged in. Before the login process
completes, the profiler stops receiving data from the server and tomcat's
CPU usage hits 100% and stays there until I kill the RAC. Upon killing
the RAC, the login process completes and tomcat's CPU usage returns to
normal and it seems to behave as if it isn't being profiled (i.e. it isn't
slow). I'm totally mystified as to why this happens and what I can do to
fix it (I don't even know how to go about debugging a problem like this,
but I know that tomcat's logs don't say anything out of the ordinary).

Just as a side note, I found on bugzilla that there used to be a bug that
looks exactly like the "most recent" stage of my problem. It was closed
in 2004 with "works for me". It was apparently only a problem with fedora
core 2, but I thought it interesting that I'm using Fedora Core 5 on the
machine I'm using eclipse from (eclipse is running on the SUSE box as I
said above, but I'm using it over X forwarding from the FC5 machine
because both SUSE boxes are servers and thus a lot more powerful).

Any help would be most appreciated. Thanks,
Ryan
Previous Topic:[AGR] Problem with dialogs derived from org.eclipse.swt.widgets.Dialog
Next Topic:Using GUI Recorder to Test Plug-ins?
Goto Forum:
  


Current Time: Sat Oct 25 03:07:21 GMT 2014

Powered by FUDForum. Page generated in 0.01583 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software