Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Problems implementing XML Schema Editor in my RCP application
Problems implementing XML Schema Editor in my RCP application [message #777399] Tue, 10 January 2012 07:16
David Gonzalez is currently offline David Gonzalez
Messages: 23
Registered: January 2011
Junior Member
Hello everybody,

I tried to implement the XML Schema Editor in my RCP application. At first it worked but the editor throws some exceptions I don't understand and some things don't work as expected.

When I open a .xsd-File with the XML Schema Editor in my application following exceptions occur:

Reference item find.ext not found for action null (4 times)
Reference item additions not found for action null (1 time)


Adding a new element works, changing the type doesn't. I select an element and in the properties view is a combo "Type" with the text "string" in it, but if I open the combo box there is no content to choose.

With a right click on the element I try to open "Set Type > New...". Again an exception:

java.lang.NullPointerException
at org.eclipse.wst.xsd.ui.internal.common.commands.SetTypeCommand.execute(SetTypeCommand.java:57)
at org.eclipse.gef.commands.CommandStack.execute(CommandStack.java:197)
at org.eclipse.wst.xsd.ui.internal.common.actions.SetTypeAction.run(SetTypeAction.java:46)
at org.eclipse.jface.action.Action.runWithEvent(Action.java:498)
(just ask if you need more stacktrace)


Does anyone know what could be wrong? Which plugins are necessary to use the XML Schema Editor in an own RCP application?

Greets

[Updated on: Tue, 10 January 2012 07:17]

Report message to a moderator

Previous Topic:Listening for EAR Changes
Next Topic:problem installing and running glassfish v3
Goto Forum:
  


Current Time: Thu Apr 17 20:49:46 EDT 2014

Powered by FUDForum. Page generated in 0.02419 seconds