Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » BPEL Designer » ActiveBPEL Runtime Plug-in 0.4 Available for Download
ActiveBPEL Runtime Plug-in 0.4 Available for Download [message #7928] Fri, 18 May 2007 14:49 Go to next message
Bruno Wassermann is currently offline Bruno Wassermann
Messages: 21
Registered: July 2009
Junior Member
Dear All,

You can now download a deployable version of the ActiveBPEL runtime plug-in
from http://sse.cs.ucl.ac.uk/projects/omiibpel/downloads/

This plug-in represents the first integration of a BPEL engine into BPEL
Designer via the mechanisms provided by org.eclipse.bpel.runtimes. It
integrates the ActiveBPEL 3.0 engine into BPEL Designer and allows you to
interact (start/stop/deploy BPEL processes) with the server from within the
Servers view in Eclipse.

A nice feature about this plug-in is that it is fully automated and provides
click-of-a-button deployment, that is, it does not require you to configure
endless wizards for each process you want to deploy.

Some documentation on how to use it can be found here:

http://sse.cs.ucl.ac.uk/omii-bpel/docs/userguide.html#i_serv erruntime

Enjoy and let me know how it works and doesn't work for you.

-- Bruno
Re: ActiveBPEL Runtime Plug-in 0.4 Available for Download [message #8803 is a reply to message #7928] Fri, 27 July 2007 14:01 Go to previous messageGo to next message
Eclipse User
Originally posted by: carlos.grahl.senior.com.br

Hello,

I've downloaded your activeBpel runtime plugin, unzip it on the Eclipse
plugins folder, but nothing happens.

When I open the servers runtime dialog, the ActiveBPEL option is not
available. I tried with Eclipse versions 3.2 and 3.3.

Did I miss something? Are there any more steps to be done?

Thanks in advance

Carlos Augusto Grahl
Re: ActiveBPEL Runtime Plug-in 0.4 Available for Download [message #8818 is a reply to message #8803] Fri, 27 July 2007 17:56 Go to previous messageGo to next message
Eclipse User
Originally posted by: carlos.grahl.senior.com.br

Some news...

I run the "Validate Plug-ins" on the "plugins" tab on the Run Dialog. The
plugin appears on the problems list, with the following error message:

"Missing constraint: Require-Bundle: org.wsdl4j; bundle-version="0.0.0""

That could help... I have WTP installed also on my Eclipse (3.3 version).

Any tips?

thank you
Re: ActiveBPEL Runtime Plug-in 0.4 Available for Download [message #9251 is a reply to message #8818] Tue, 31 July 2007 22:08 Go to previous messageGo to next message
Bruno Wassermann is currently offline Bruno Wassermann
Messages: 21
Registered: July 2009
Junior Member
Hi Carlos,

Sorry for the late reply. Can you please tell me the versions of the
pre-requisites you have installed in your Eclipse (WTP, GEF, EMF, DTP)?

I will make avaiable a new version of the ABR plug-in this week, which will
hopefully fix this problem.

Regards,

-- Bruno


"Carlos Grahl" <carlos.grahl@senior.com.br> wrote in message
news:f5f029c6d5c827d82c07f1aca163c05f$1@www.eclipse.org...
> Some news...
>
> I run the "Validate Plug-ins" on the "plugins" tab on the Run Dialog. The
> plugin appears on the problems list, with the following error message:
>
> "Missing constraint: Require-Bundle: org.wsdl4j; bundle-version="0.0.0""
>
> That could help... I have WTP installed also on my Eclipse (3.3 version).
>
> Any tips?
>
> thank you
>
Re: ActiveBPEL Runtime Plug-in 0.4 Available for Download [message #9274 is a reply to message #9251] Wed, 01 August 2007 13:05 Go to previous messageGo to next message
Eclipse User
Originally posted by: carlos.grahl.senior.com.br

Hi!

Thank you for your reply.

I'm using the Europa released version of all plugins:

DTP: 1.5.0.20070621
EMF: 2.3.0.v200706262000
GEM: 1.0.100.v20070601-1400-7d-Et....
WTP: 2.0.0.v200706041905-7C-18...

Are you planning to open-source your plugin?

Thank you again,

Carlos Augusto Grahl
Re: ActiveBPEL Runtime Plug-in 0.4 Available for Download [message #9296 is a reply to message #9274] Wed, 01 August 2007 14:03 Go to previous messageGo to next message
Bruno Wassermann is currently offline Bruno Wassermann
Messages: 21
Registered: July 2009
Junior Member
Hi Carlos,

Please download the Europa version of the ABR plug-in via this site
http://sse.cs.ucl.ac.uk/projects/omiibpel/downloads/

This should fix the problem you have encountered.

The plug-in is open-source. We (University College London Software Systems
Engineering Group) just haven't made our CVS repository public. Does your
question indicate that you would be interested and willing to contribute to
the further development of the ABR plug-in? ;-)

Regards,

-- Bruno


"Carlos Grahl" <carlos.grahl@senior.com.br> wrote in message
news:e71850807f469b8202fc7ab846990ce6$1@www.eclipse.org...
> Hi!
>
> Thank you for your reply.
>
> I'm using the Europa released version of all plugins:
>
> DTP: 1.5.0.20070621
> EMF: 2.3.0.v200706262000
> GEM: 1.0.100.v20070601-1400-7d-Et....
> WTP: 2.0.0.v200706041905-7C-18...
>
> Are you planning to open-source your plugin?
>
> Thank you again,
>
> Carlos Augusto Grahl
>
Re: ActiveBPEL Runtime Plug-in 0.4 Available for Download [message #9319 is a reply to message #9296] Wed, 01 August 2007 14:14 Go to previous message
Eclipse User
Originally posted by: carlos.grahl.senior.com.br

Hi, Bruno!

Thank you for your quick reply.

I'll soon download and test this new version.

And yes, i'm interested in contribute to this plugin development. I'm
planning to use the activeBpel engine, and this plugin will be very, very
usefull :-)

How can I get the source? Should i wait for your CVS be ok?

Thank you

Carlos Augusto Grahl
Previous Topic:Deploying processes to Apache Ode
Next Topic:Eclipse 3.3 installation
Goto Forum:
  


Current Time: Thu Oct 02 06:24:30 GMT 2014

Powered by FUDForum. Page generated in 0.03604 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software