Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Output issue with Flat file(Output is not correct FlatFile datasource)
Output issue with Flat file [message #764676] Mon, 12 December 2011 11:41 Go to next message
JP Redro is currently offline JP Redro
Messages: 167
Registered: July 2009
Location: India
Senior Member

hi All,

I have build a report in BIRT 3.7.1 and datasource as Flatfile. but the alignment is not correct. Attached is the report and relevant output and original output. Please suggest me.

Thanks,
JP
  • Attachment: FlatFile.zip
    (Size: 5.54KB, Downloaded 50 times)


Thanks,
JP
Re: Output issue with Flat file [message #764711 is a reply to message #764676] Mon, 12 December 2011 13:02 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

JP,

You will have to put the content into grids to get the spacing of the
original. For example if you take your current table and put it inside
a grid (second column of 3x3 grid) you can set the left spacing with the
first column. The only issue is that your data may have to be broken
into multiple datasets as all the data is not spaced the same.

Jason

On 12/12/2011 11:41 AM, JP wrote:
> hi All,
>
> I have build a report in BIRT 3.7.1 and datasource as Flatfile. but the alignment is not correct. Attached is the report and relevant output and original output. Please suggest me.
>
> Thanks,
> JP
>
Re: Output issue with Flat file [message #765154 is a reply to message #764711] Tue, 13 December 2011 09:23 Go to previous messageGo to next message
JP Redro is currently offline JP Redro
Messages: 167
Registered: July 2009
Location: India
Senior Member

Hi Jason,

I have followed your instructions, but when i use grid in table it is displaying only one row which is first. If i use only grid it will display only one row. Please suggest me.

Thanks
JP


Thanks,
JP
Re: Output issue with Flat file [message #765242 is a reply to message #765154] Tue, 13 December 2011 12:23 Go to previous message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Sorry. I meant use a table in a grid. Grids do not iterate over result
sets, they will only get the first value.

Jason

On 12/13/2011 9:23 AM, JP wrote:
> Hi Jason,
>
> I have followed your instructions, but when i use grid in table it is
> displaying only one row which is first. If i use only grid it will
> display only one row. Please suggest me.
>
> Thanks
> JP
Previous Topic:Unable to print image on Excel output in BIRT 3.7.1
Next Topic:How to use some variable in Report Parameter input before starting report?
Goto Forum:
  


Current Time: Wed Aug 27 07:20:44 EDT 2014

Powered by FUDForum. Page generated in 0.01982 seconds