Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Executing tests with testexec - no scheme?(No Database Connection is available for name "JubulaPostGreSQL". Available names: Default Embedded (H2))
Executing tests with testexec - no scheme? [message #760431] Fri, 02 December 2011 11:06 Go to next message
Amir Hadi is currently offline Amir Hadi
Messages: 10
Registered: November 2011
Location: Stuttgart, Germany
Junior Member

Hi again,

I need to run tests with the testexec command line utility. Problem is, that I always get the following error:
No Database Connection is available for name "JubulaPostGreSQL". Available names: Default Embedded (H2)


I execute testexec like this:
testexec.exe -project "YUCAS" -version "13.0" -autconfig "Application@localhost" -dbscheme "JubulaPostGreSQL" -dbuser "jubula" -dbpw "test" -server "53.118.51.20" -port "60000" -language "de_DE" -testsuite "Login" -datadir "C:\Users\ahadi\.jubula\configAreas\jubula\5.2.00266" -resultdir "C:\Users\ahadi\Desktop\Test\Results" -n


In the forum I've read that the -datadir parameter should be the workspace path. I tried C:\Users\ahadi\.jubula\configAreas\jubula\5.2.00266 and C:\Users\ahadi\.jubula\.

Anyone an idea, why the dbscheme is not found?

Thanks in advance,
Amir
Re: Executing tests with testexec - no scheme? [message #760432 is a reply to message #760431] Fri, 02 December 2011 11:10 Go to previous messageGo to next message
Zeb Ford-Reitz is currently offline Zeb Ford-Reitz
Messages: 32
Registered: November 2010
Member
In addition to the "-datadir" parameter, you should also set the "-data" parameter to the workspace path. This actually tells testexec to use that workspace, so that it can reference, for example, all database connections defined in that workspace's preferences.
Re: Executing tests with testexec - no scheme? [message #760434 is a reply to message #760432] Fri, 02 December 2011 11:16 Go to previous messageGo to next message
Amir Hadi is currently offline Amir Hadi
Messages: 10
Registered: November 2011
Location: Stuttgart, Germany
Junior Member

OK sorry, I didn't see that parameter.

Now I tried it like this:
"C:\Program Files (x86)\jubula_5.2.00266\jubula\testexec.exe" -project "YUCAS" -version "13.0" -autconfig "YUCAS-EWPWAS2-JUnit@Toshiba" -dbscheme "YUCON Jubula PostGreSQL" -dbuser "jubula" -dbpw "test" -server "53.118.51.20" -port "60000" -language "de_DE" -testsuite "Login" -data "C:\Users\ahadi\.jubula" -datadir "C:\Users\ahadi\Desktop\Test\Data" -resultdir "C:\Users\ahadi\Desktop\Test\Results"


I also tried to set the -data parameter to
C:\Users\ahadi\.jubula\configAreas\jubula\5.2.00266

but still no success for me.

EDIT: OK guys, the problem was BKAC. Wrong path to the workspace.

[Updated on: Fri, 02 December 2011 12:04]

Report message to a moderator

Re: Executing tests with testexec - no scheme? [message #780722 is a reply to message #760434] Thu, 19 January 2012 08:10 Go to previous messageGo to next message
Sascha Mising name is currently offline Sascha Mising name
Messages: 22
Registered: December 2011
Junior Member
I also had this issue.

I am wondering for me it seems i need the workspace only because of the DB Scheme ?

Is this right ? Or does the testexec also rely on other information from the workspace ?
For me this is the reason why i have to check in the workspace to my source code control as we execute tests directly from there.

If this is the only information this data i would prefer to be able to specify the relevat parameters (DB Server, DB Type, DB Port) in the command line.
Without the need of the Workspace for automated test execution.

Cheers Sascha


Re: Executing tests with testexec - no scheme? [message #780725 is a reply to message #780722] Thu, 19 January 2012 08:20 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1157
Registered: July 2009
Senior Member
Hi,

As far as I can remember, it is the db scheme that makes us require the workspace. I don't know whether the plan is to use more information from the workspace later on, or whether removing the necessity for the workspace is viable - feel free to enter an enhancement / a patch.

Thanks,
Alex
Re: Executing tests with testexec - no scheme? [message #780765 is a reply to message #780725] Thu, 19 January 2012 10:22 Go to previous messageGo to next message
Sascha Mising name is currently offline Sascha Mising name
Messages: 22
Registered: December 2011
Junior Member
Enhancment Request : Bug 369051
Re: Executing tests with testexec - no scheme? [message #840698 is a reply to message #760431] Tue, 10 April 2012 12:04 Go to previous message
Stefan Mertins is currently offline Stefan Mertins
Messages: 11
Registered: March 2012
Junior Member
Hi,

I have the exact same problem, but can not solve it. I use a mySql db and can access it over the jubula UI. But I want to use the testexec to execute the tests.
I used the -data parameter like this: -data C:\"Program Files (x86)"\jubula_1.2\workspace
But everytime I run the command it says just:
!!Error occurred !!
No Database Connection is available for name "Jubula_MySQL". Available names: Default Embedded (H2)

I also tried to copy the workspace to c:\workspace because the path has some spaces in it. But the error still occurs.

Any hints how to solve this?

meddins

[EDIT]
Ok solved it now aswell. I always started the command from my user folder with an absolute path to the testexec and workspace folder. The command created everytime a new workspace folder in my user folder.
To solve it, I executed the command from the path the workspace is in and it worked.

[Updated on: Tue, 10 April 2012 12:16]

Report message to a moderator

Previous Topic:Jubula vs GUIdancer
Next Topic:Unable to Export a Test Project
Goto Forum:
  


Current Time: Thu Oct 30 16:09:52 GMT 2014

Powered by FUDForum. Page generated in 0.02466 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software