Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » [solved] Can't install emma.headless
[solved] Can't install emma.headless [message #753987] Mon, 31 October 2011 11:14 Go to next message
Volker Stolz is currently offline Volker Stolz
Messages: 62
Registered: July 2009
Member
Hi all,
I wanted to install emma-support into our (working) headless buckminster, but:

-bash-3.00$ ./buckminster --loglevel DEBUG install http://download.eclipse.org/tools/buckminster/headless-3.7/ org.eclipse.bu>
install 'http://download.eclipse.org/tools/buckminster/headless-3.7/' 'org.eclipse.buckminster.emma.headless.feature'
An error occurred while collecting items to be installed
[0]session context was:(profile=Buckminster, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
[0]No repository found containing: osgi.bundle,org.eclipse.core.databinding,1.4.0.I20110111-0800
[0]No repository found containing: osgi.bundle,org.eclipse.core.databinding.observable,1.4.0.I20110222-0800
[0]No repository found containing: osgi.bundle,org.eclipse.core.databinding.property,1.4.0.I20110222-0800
[0]No repository found containing: osgi.bundle,org.eclipse.equinox.concurrent,1.0.200.v20110502
[0]No repository found containing: osgi.bundle,org.eclipse.equinox.p2.repository.tools,2.0.100.v20110512-1320
[0]No repository found containing: osgi.bundle,org.eclipse.help,3.5.100.v20110426
[0]No repository found containing: osgi.bundle,org.eclipse.jface,3.7.0.I20110522-1430
[0]No repository found containing: osgi.bundle,org.eclipse.jface.databinding,1.5.0.I20100907-0800
[0]No repository found containing: osgi.bundle,org.eclipse.swt,3.7.1.v3738a
[0]No repository found containing: osgi.bundle,org.eclipse.ui,3.7.0.I20110602-0100
[0]No repository found containing: osgi.bundle,org.eclipse.ui.workbench,3.7.0.I20110519-0100

Any hint would be appreciated!

Volker

[Updated on: Wed, 07 December 2011 12:01]

Report message to a moderator

Re: Can't install emma.headless [message #753994 is a reply to message #753987] Mon, 31 October 2011 11:23 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3229
Registered: July 2009
Senior Member
My guess would be temporary network failure. It's not uncommon when you access eclipse.org update sites.

HTH,
- thomas

On 2011-10-31 12:14, Volker Stolz wrote:
> Hi all,
> I wanted to install emma-support into our (working) headless buckminster, but:
>
> -bash-3.00$ ./buckminster --loglevel DEBUG install http://download.eclipse.org/tools/buckminster/headless-3.7/
> org.eclipse.bu>
> install 'http://download.eclipse.org/tools/buckminster/headless-3.7/' 'org.eclipse.buckminster.emma.headless.feature'
> An error occurred while collecting items to be installed
> [0]session context was:(profile=Buckminster, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=,
> action=).
> [0]No repository found containing: osgi.bundle,org.eclipse.core.databinding,1.4.0.I20110111-0800
> [0]No repository found containing: osgi.bundle,org.eclipse.core.databinding.observable,1.4.0.I20110222-0800
> [0]No repository found containing: osgi.bundle,org.eclipse.core.databinding.property,1.4.0.I20110222-0800
> [0]No repository found containing: osgi.bundle,org.eclipse.equinox.concurrent,1.0.200.v20110502
> [0]No repository found containing: osgi.bundle,org.eclipse.equinox.p2.repository.tools,2.0.100.v20110512-1320
> [0]No repository found containing: osgi.bundle,org.eclipse.help,3.5.100.v20110426
> [0]No repository found containing: osgi.bundle,org.eclipse.jface,3.7.0.I20110522-1430
> [0]No repository found containing: osgi.bundle,org.eclipse.jface.databinding,1.5.0.I20100907-0800
> [0]No repository found containing: osgi.bundle,org.eclipse.swt,3.7.1.v3738a
> [0]No repository found containing: osgi.bundle,org.eclipse.ui,3.7.0.I20110602-0100
> [0]No repository found containing: osgi.bundle,org.eclipse.ui.workbench,3.7.0.I20110519-0100
>
> Any hint would be appreciated!
>
> Volker
Re: Can't install emma.headless [message #754050 is a reply to message #753994] Mon, 31 October 2011 15:24 Go to previous messageGo to next message
Volker Stolz is currently offline Volker Stolz
Messages: 62
Registered: July 2009
Member
Hm, it seems there's something wrong with the particular buckminster I'm installing into: as this problem has persisted over the weekend, I used director to get a new buckminster, and emma and e.g. PSF support install fine into THAT one, while they still fail for the other buckminster.

File ownership and permissions in the older buckminster look okay...the --loglevel doesn't seem to do much for the 'install' target, though, so I can't see what the problem is.

Are there any temporary files that can be safely wiped? Othwise I'll probably go with a fresh install.

Volker

Re: Can't install emma.headless [message #963712 is a reply to message #754050] Tue, 30 October 2012 01:49 Go to previous messageGo to next message
Minhyuk Kwon is currently offline Minhyuk Kwon
Messages: 4
Registered: January 2012
Junior Member
Hello,
I got a same problem with you.
please sharing how to solved this problem? you mean fresh buckminster installed?

please let me know

Regards,
Re: Can't install emma.headless [message #963782 is a reply to message #963712] Tue, 30 October 2012 03:05 Go to previous message
Minhyuk Kwon is currently offline Minhyuk Kwon
Messages: 4
Registered: January 2012
Junior Member
Solved by fresh install.
I think some temp files make this problem but i didn't investgated.

I use this step to configure my buckminster and it work fine.

#1. get fresh buckminter
director -r http://download.eclipse.org/tools/buckminster/headless-3.7/
         -d D:\HUDSON_HOME\buckminster
         -p Buckminster
         -i org.eclipse.buckminster.cmdline.product


#2. install required features
org.eclipse.buckminster.emma.headless.feature
org.eclipse.equinox.p2.director.feature
org.eclipse.buckminster.core.headless.feature
org.eclipse.buckminster.pde.headless.feature
org.eclipse.buckminster.subversive.headless.feature
Previous Topic:version range substitution in MANIFEST.MF
Next Topic:Updating with P2 from PDE-built to Buckminster-built product
Goto Forum:
  


Current Time: Fri Oct 31 14:22:23 GMT 2014

Powered by FUDForum. Page generated in 0.03291 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software