Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Uses Violation: Conflicting Packages from Kernel and User Region
Uses Violation: Conflicting Packages from Kernel and User Region [message #739252] Mon, 17 October 2011 09:04 Go to next message
Vladimir Stevanovic is currently offline Vladimir StevanovicFriend
Messages: 29
Registered: March 2010
Junior Member
I'm trying to start PAR file in Virgo 3.0.1, containing several bundles. After failing to start it, I've used OSGi state explorer to diagnose the problem. I've got a lot of uses violations and among them some very strange:
Uses violation: <Import-Package: org.springframework.remoting.rmi; version="[2.5.0,4.0.0]"> in bundle <org.gs4tr.editor.trasnstudio.par-1-gs4tr-tm-lucene_3.0.30.SNAPSHOT[1318841157640]>

Found conflicts:
package 'org.aopalliance.intercept_1.0.0' in bundle 'com.springsource.org.aopalliance_1.0.0[31]' used by 'org.springframework.remoting.rmi_3.0.5.RELEASE' in bundle 'org.springframework.context_3.0.5.RELEASE[25]'
conflicts with 'org.aopalliance.intercept_1.0.0' in bundle 'com.springsource.org.aopalliance_1.0.0[69]' used by 'org.gs4tr.tm3.commonlayer.lucene_0.0.0' in bundle 'org.gs4tr.editor.trasnstudio.par-1-gs4tr-tm-commonlay

package 'org.springframework.core_3.0.5.RELEASE' in bundle 'org.springframework.core_3.0.5.RELEASE[83]' used by 'org.springframework.remoting.rmi_3.0.5.RELEASE' in bundle 'org.springframework.context_3.0.5.RELEASE[82]'
conflicts with 'org.springframework.core_3.0.5.RELEASE' in bundle 'org.springframework.core_3.0.5.RELEASE[24]' used by 'org.springframework.remoting_3.0.5.RELEASE' in bundle 'org.springframework.context_3.0.5.RELEASE[
(...)

So, it points to the springframework bundles from both user and kernel region!!! I thought they were completely isolated. I haven't changed any configuration file in VTS. What could cause this type of error?



Re: Uses Violation: Conflicting Packages from Kernel and User Region [message #739293 is a reply to message #739252] Mon, 17 October 2011 10:03 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn NormingtonFriend
Messages: 1222
Registered: July 2009
Senior Member
Certain packages are shared from the kernel to the user region in VTS. Take a look at the user region properties file in the config directory which contains the following property:

packageImports =\
org.eclipse.virgo.kernel.artifact.*;version="0",\
org.eclipse.virgo.kernel.core;version="0",\
org.eclipse.virgo.kernel.deployer.core;version="0",\
org.eclipse.virgo.kernel.deployer.core.event;version="0",\
org.eclipse.virgo.kernel.deployer.config;version="0",\
org.eclipse.virgo.kernel.install.*;version="0",\
org.eclipse.virgo.kernel.osgi.*;version="0",\
org.eclipse.virgo.kernel.model;version="0",\
org.eclipse.virgo.kernel.model.management;version="0",\
org.eclipse.virgo.kernel.module;version="0",\
org.eclipse.virgo.kernel.serviceability;version="0",\
org.eclipse.virgo.kernel.serviceability.*;version="0",\
org.eclipse.virgo.kernel.services.work;version="0",\
org.eclipse.virgo.kernel.shell;version="0",\
org.eclipse.virgo.kernel.shell.*;version="0",\
org.eclipse.virgo.kernel.shim.*;version="0",\
org.eclipse.virgo.medic.*;version="0",\
org.eclipse.virgo.repository;version="0",\
org.eclipse.virgo.repository.*;version="0",\
org.eclipse.virgo.util.*;version="0",\
org.apache.commons.logging;version="[1.0.0,2.0.0)",\
org.apache.commons.logging.impl;version="[1.0.0,2.0.0)",\
org.aspectj.*;version="[1.6.5.RELEASE,2.0.0)",\
org.osgi.service.event;version="0",\
org.osgi.service.log;version="0",\
org.eclipse.equinox.region;version="1",\
ch.qos.logback.*;version="[0.9.24,1.0.0)",\
org.slf4j;version="[1.6.1,2)",\
org.slf4j.helpers;version="[1.6.1,2)",\
org.slf4j.spi;version="[1.6.1,2)"

Hope that helps to get you started. See the FAQ for general guidance on debugging uses constraint violations.
Re: Uses Violation: Conflicting Packages from Kernel and User Region [message #739342 is a reply to message #739293] Mon, 17 October 2011 11:19 Go to previous messageGo to next message
Vladimir Stevanovic is currently offline Vladimir StevanovicFriend
Messages: 29
Registered: March 2010
Junior Member
I found the uses violations (org.apache.commons.logging).
Thanks
Re: Uses Violation: Conflicting Packages from Kernel and User Region [message #739343 is a reply to message #739342] Mon, 17 October 2011 11:20 Go to previous message
Glyn Normington is currently offline Glyn NormingtonFriend
Messages: 1222
Registered: July 2009
Senior Member
Great!
Previous Topic:how can I run applet application with virgo
Next Topic:Eclipse Server Runtime Environment for Virgo (Jetty) 3.0.1
Goto Forum:
  


Current Time: Sun Dec 21 06:25:54 GMT 2014

Powered by FUDForum. Page generated in 0.02341 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software