Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » Buckminster 3.6 does not resolve targetPlatform sources
icon5.gif  Buckminster 3.6 does not resolve targetPlatform sources [message #736020] Thu, 13 October 2011 11:23 Go to next message
Bjoern Berg is currently offline Bjoern Berg
Messages: 41
Registered: November 2009
Location: Essen
Member
Hello everybody,

I'm trying to build my own RCP application with Buckminster from inside the running Workbench. No headless build currently.

My problem is, that Buckminster does not resolve the sources from the target platform while I'm running it inside Eclipse Workbench.

I have created the following RMAP and CQUERY depending on the information found in BuckyBook and this forum:

RMAP:
<?xml version="1.0" encoding="UTF-8"?>
<rmap
	xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
	xmlns="http://www.eclipse.org/buckminster/RMap-1.0"
	xmlns:bc="http://www.eclipse.org/buckminster/Common-1.0"
	xmlns:mp="http://www.eclipse.org/buckminster/MavenProvider-1.0"
	xmlns:pp="http://www.eclipse.org/buckminster/PDEMapProvider-1.0">
	<!-- Place your RMAP content here -->
	
	<searchPath name="resources">
        <provider readerType="local" componentTypes="osgi.bundle,eclipse.feature,buckminster" source="true" mutable="true">
            <uri format="file:///{0}/{1}/">
                <bc:propertyRef key="workspace.root" />
                <bc:propertyRef key="buckminster.component" />
            </uri>
        </provider>
    </searchPath>
    
    <searchPath name="org.eclipse.platform">
        <provider readerType="p2" componentTypes="osgi.bundle,eclipse.feature" source="true" mutable="true">
            <uri format="file:///P:/target/3.5.2/{0}/">
                <!--  <bc:propertyRef key="P:/target/3.5.2" />-->
                <bc:propertyRef key="buckminster.component" />
            </uri>
        </provider>
    </searchPath>

	<locator searchPathRef="org.eclipse.platform" pattern="^org\.(.*)"/>
    <locator searchPathRef="resources" pattern="^de\.(.*)|^org\.oracle\.(.*)|^com\.(.*)"/>
</rmap>


CQUERY:
<?xml version="1.0" encoding="UTF-8"?>
<cq:componentQuery xmlns:cq="http://www.eclipse.org/buckminster/CQuery-1.0" resourceMap="experience.rmap">
    <cq:rootRequest name="de.genesys_e.experience.feature" componentType="eclipse.feature"/>
    <cq:property key="buckminster.download.source" value="true"/>
    <cq:property key="target.arch" value="*"/>
    <cq:property key="target.os" value="*"/>
    <cq:property key="target.ws" value="*"/>
    <cq:advisorNode namePattern=".*" mutableLevel="REQUIRE" sourceLevel="REQUIRE" useWorkspace="false"/>
</cq:componentQuery>


Running CQUERY with "Resolve to Wizard" shows, that the source packages from the target platform are still unresolved.

What's wrong? Any help is appreciated.

Bjoern
Re: Buckminster 3.6 does not resolve targetPlatform sources [message #736057 is a reply to message #736020] Thu, 13 October 2011 13:21 Go to previous messageGo to next message
Matthew Webber is currently offline Matthew Webber
Messages: 198
Registered: December 2010
Senior Member
You need to set the property "buckminster.download.source" to "true". You can set this in your CQuery on the "properties" tab, or pass it in via -D. If you search this group for the property name, you should see where this has been previously discused.
Matthew
Re: Buckminster 3.6 does not resolve targetPlatform sources [message #736060 is a reply to message #736057] Thu, 13 October 2011 13:26 Go to previous messageGo to next message
Matthew Webber is currently offline Matthew Webber
Messages: 198
Registered: December 2010
Senior Member
Also see thread http://www.eclipse.org/forums/index.php/m/692758/
Matthew
Re: Buckminster 3.6 does not resolve targetPlatform sources [message #736151 is a reply to message #736057] Thu, 13 October 2011 17:09 Go to previous messageGo to next message
Bjoern Berg is currently offline Bjoern Berg
Messages: 41
Registered: November 2009
Location: Essen
Member
Matthew Webber wrote on Thu, 13 October 2011 15:21
You need to set the property "buckminster.download.source" to "true". You can set this in your CQuery on the "properties" tab, or pass it in via -D. If you search this group for the property name, you should see where this has been previously discused.


I think, I have done that as you can see in my posted content of CQUERY, referred to the posting here: http://www.eclipse.org/forums/index.php/m/692758/
Re: Buckminster 3.6 does not resolve targetPlatform sources [message #737084 is a reply to message #736151] Fri, 14 October 2011 16:36 Go to previous messageGo to next message
Matthew Webber is currently offline Matthew Webber
Messages: 198
Registered: December 2010
Senior Member
Sorry, I missed that. Have you verified that source packages are actually in the p2 site for the target (file:///P:/target/3.5.2/)? If they are there, is your Buckminster install up-to-date? It might be worth re-testing with 3.7.
Matthew
icon14.gif  Re: Buckminster 3.6 does not resolve targetPlatform sources [message #753473 is a reply to message #737084] Thu, 27 October 2011 12:19 Go to previous messageGo to next message
Bjoern Berg is currently offline Bjoern Berg
Messages: 41
Registered: November 2009
Location: Essen
Member
Okay found the mistake. Due to a mistake with some environment variables Buckminster 3.5 was used.

Version 3.6 works like charme.
Re: Buckminster 3.6 does not resolve targetPlatform sources [message #755042 is a reply to message #753473] Mon, 07 November 2011 07:27 Go to previous messageGo to next message
Andreas Schilling is currently offline Andreas Schilling
Messages: 22
Registered: April 2010
Junior Member
do you have some more detail on that? what exactly was wrong in your case? we still have the problem that buckminster stopped resolving source bundles for our third party libraries (e.g. hibernate, spring stuff etc.) from some version on...

kind regards,

Andreas
Re: Buckminster 3.6 does not resolve targetPlatform sources [message #756201 is a reply to message #755042] Fri, 11 November 2011 13:13 Go to previous message
Bjoern Berg is currently offline Bjoern Berg
Messages: 41
Registered: November 2009
Location: Essen
Member
My problem was, that an environment variable linked to an older version of buckminster during the build process. My main build scripts reference all third-party tools using environment variables.

Buckminster 3.5 does not resolve source bundles - don't ask me why.

Version 3.6 works without problems.
Previous Topic:Buckminster and Jenkins
Next Topic:Startup order problem in installed RCP application
Goto Forum:
  


Current Time: Tue Sep 16 05:12:19 GMT 2014

Powered by FUDForum. Page generated in 0.02407 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software