Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » cant start profiling -> error
cant start profiling -> error [message #7061] Wed, 23 February 2005 14:53 Go to next message
Eclipse User
Originally posted by: eclipse.knowthem.de

Hyades 3.2
Eclipse 3.0.1

Test connection success.

If I want to start profiling this message comes up:
IWAT0007I Either the agent controller is not started, or the java path is
incorrect. See log for more details

and the log:

Launching process failed, platform specific error is 267.
Path=C:\Programme\Java\jre1.5.0_01\bin\java.exe Process command line =
"C:\Programme\Java\jre1.5.0_01\bin\java.exe"
-XrunpiAgent:server=controlled -Xmx256m editor.Editor" severity="55"
version="1.0.1">

The Java Path is correct.
The Agent controller is running.
Re: cant start profiling -> error [message #8040 is a reply to message #7061] Sat, 26 February 2005 20:26 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Gerrit,
If you can confirm that the Agent Controller is running, the paths are
correct and the editor.Editor is on the classpath, this appears to be a JVM
1.5.x defect. Please open a defect with all the information presented in
this post.

Paul

"Gerrit Brehmer" <eclipse@knowthem.de> wrote in message
news:cvi5ck$i56$1@www.eclipse.org...
> Hyades 3.2
> Eclipse 3.0.1
>
> Test connection success.
>
> If I want to start profiling this message comes up:
> IWAT0007I Either the agent controller is not started, or the java path is
> incorrect. See log for more details
>
> and the log:
>
> Launching process failed, platform specific error is 267.
> Path=C:\Programme\Java\jre1.5.0_01\bin\java.exe Process command line =
> "C:\Programme\Java\jre1.5.0_01\bin\java.exe"
> -XrunpiAgent:server=controlled -Xmx256m editor.Editor" severity="55"
> version="1.0.1">
>
> The Java Path is correct.
> The Agent controller is running.
>
Re: cant start profiling -> error [message #8102 is a reply to message #8040] Mon, 28 February 2005 14:20 Go to previous messageGo to next message
Eclipse User
Originally posted by: eclipse.knowthem.de

Hi Paul,

I tested a little bit (also with the new TPTP 4.0 nightly build): Other
applications working normally with hyades. The app with the problem is a
RMI client. So must I run anything on the server from hyades? but i want
only profiling the client application.
Thanks for your help.

Gerrit

Paul Slauenwhite wrote:

> Hi Gerrit,
> If you can confirm that the Agent Controller is running, the paths are
> correct and the editor.Editor is on the classpath, this appears to be a JVM
> 1.5.x defect. Please open a defect with all the information presented in
> this post.

> Paul

> "Gerrit Brehmer" <eclipse@knowthem.de> wrote in message
> news:cvi5ck$i56$1@www.eclipse.org...
>> Hyades 3.2
>> Eclipse 3.0.1
>>
>> Test connection success.
>>
>> If I want to start profiling this message comes up:
>> IWAT0007I Either the agent controller is not started, or the java path is
>> incorrect. See log for more details
>>
>> and the log:
>>
>> Launching process failed, platform specific error is 267.
>> Path=C:ProgrammeJavajre1.5.0_01binjava.exe Process command line =
>> "C:ProgrammeJavajre1.5.0_01binjava.exe"
>> -XrunpiAgent:server=controlled -Xmx256m editor.Editor" severity="55"
>> version="1.0.1">
>>
>> The Java Path is correct.
>> The Agent controller is running.
>>
Re: cant start profiling -> error [message #10803 is a reply to message #8102] Mon, 21 March 2005 14:41 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Gerrit,
If you are only profiling the client in the RMI application, you will
only need the Agent Controller installed and running on the client's
machine. Profiling data will be truncated when the client makes the remote
invocation.

Paul

"Gerrit Brehmer" <eclipse@knowthem.de> wrote in message
news:cvv9bh$bsa$1@www.eclipse.org...
> Hi Paul,
>
> I tested a little bit (also with the new TPTP 4.0 nightly build): Other
> applications working normally with hyades. The app with the problem is a
> RMI client. So must I run anything on the server from hyades? but i want
> only profiling the client application.
> Thanks for your help.
>
> Gerrit
>
> Paul Slauenwhite wrote:
>
> > Hi Gerrit,
> > If you can confirm that the Agent Controller is running, the paths
are
> > correct and the editor.Editor is on the classpath, this appears to be a
JVM
> > 1.5.x defect. Please open a defect with all the information presented
in
> > this post.
>
> > Paul
>
> > "Gerrit Brehmer" <eclipse@knowthem.de> wrote in message
> > news:cvi5ck$i56$1@www.eclipse.org...
> >> Hyades 3.2
> >> Eclipse 3.0.1
> >>
> >> Test connection success.
> >>
> >> If I want to start profiling this message comes up:
> >> IWAT0007I Either the agent controller is not started, or the java path
is
> >> incorrect. See log for more details
> >>
> >> and the log:
> >>
> >> Launching process failed, platform specific error is 267.
> >> Path=C:ProgrammeJavajre1.5.0_01binjava.exe Process command line =
> >> "C:ProgrammeJavajre1.5.0_01binjava.exe"
> >> -XrunpiAgent:server=controlled -Xmx256m editor.Editor" severity="55"
> >> version="1.0.1">
> >>
> >> The Java Path is correct.
> >> The Agent controller is running.
> >>
>
>
Re: cant start profiling -> error [message #18782 is a reply to message #7061] Fri, 27 May 2005 08:21 Go to previous message
Eclipse User
Originally posted by: roger.hrzsoft.cn

I got the same error of IWAT0007I ..... while following the step
"Tutorial: Analyzing profiling data" that comes with Eclipse Help.
Hyades 4.0.0
Eclipse 3.1M7
OS: Fedora Core 2

I'm sure RAServer is running, but I'm not sure if Java Path is correct.
How could I check the path?

My error log:
org.eclipse.hyades.internal.execution.local.control.NoSuchAp plicationException
at org.eclipse.hyades.internal.execution.local.control.ProcessI mpl.launch(ProcessImpl.java:154)
at org.eclipse.hyades.trace.ui.internal.util.PDCoreUtil.launchT race(PDCoreUtil.java:757)
at org.eclipse.hyades.trace.ui.internal.launcher.ProfileJavaApp licationDelegate.launch(ProfileJavaApplicationDelegate.java: 76)
at org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:590)
at org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:515)
at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(D ebugUIPlugin.java:734)
at org.eclipse.debug.internal.ui.DebugUIPlugin$6.run(DebugUIPlu gin.java:932)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:67)

Any suggestions?

On Wed, 23 Feb 2005 14:53:08 +0000, Gerrit Brehmer wrote:

> Hyades 3.2
> Eclipse 3.0.1
>
> Test connection success.
>
> If I want to start profiling this message comes up:
> IWAT0007I Either the agent controller is not started, or the java path is
> incorrect. See log for more details
>
> and the log:
>
> Launching process failed, platform specific error is 267.
> Path=C:\Programme\Java\jre1.5.0_01\bin\java.exe Process command line =
> "C:\Programme\Java\jre1.5.0_01\bin\java.exe"
> -XrunpiAgent:server=controlled -Xmx256m editor.Editor" severity="55"
> version="1.0.1">
>
> The Java Path is correct.
> The Agent controller is running.
Previous Topic:profiling was application inside wsad - performance
Next Topic:Re: Generic Log Adapter Example
Goto Forum:
  


Current Time: Wed Oct 22 21:54:43 GMT 2014

Powered by FUDForum. Page generated in 0.02034 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software