Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » CreateProcess 206 error when Run As (long classpath problem)(CreateProcess 206 error when Run As (long classpath problem))
CreateProcess 206 error when Run As (long classpath problem) [message #729049] Sat, 24 September 2011 21:21 Go to next message
Thomas Adler is currently offline Thomas AdlerFriend
Messages: 1
Registered: September 2011
Junior Member
Hi,

I am am trying to execute Run As (for executing JUnit tests) for J2EE project in Eclipse running on Windows Vista but I get error:

Cannot run program "C:\Program Files (x86)\Java\jre6\bin\javaw.exe" (in directory "C:\Users\MyName\workspace\MyProject"):
CreateProcess error=206, The filename or extension is too long

My project includes lot of jars and so on, and it can be run on Application Server without errors. I searched Google and the found similar error in a bit different context - it is filed as Netbeans Bugzill bug id=200790.

They are saying that run configuration processes the list of libraries and add the result to the classpath and this classpath can become too long for Windows. So - I guess - this is the problem of Eclipse "Run As..." or at least - the problem of configuration of this plugin.

But what options I have? How I can alternatively inform javaw about all the necessary libraries if not with classpath command option?

I guess that this problem should be fairly common because J2EE projects usually contains lot of jars - hot to Run such projects from Eclipse?

Thanks in advance!
Re: CreateProcess 206 error when Run As (long classpath problem) [message #760556 is a reply to message #729049] Fri, 02 December 2011 20:39 Go to previous messageGo to next message
brayan is currently offline brayanFriend
Messages: 2
Registered: December 2011
Junior Member
Hi Thomas,

Were you able to narrow down respectively confirm that the cause of this error is truly due to a too long filename/extension?

I'm using Eclipse Indigo SR1 and running into the same issue when I want to run an simple Enterprise Client Application refering to another simple EJB project. I cannot remember having similar issues with earlier versions of Eclipse and Java EE projects importing the JBoss 6.1 runtime libraries.

Any workaround available?

thanks for a short response,

bests,
Re: CreateProcess 206 error when Run As (long classpath problem) [message #760557 is a reply to message #760556] Fri, 02 December 2011 20:53 Go to previous messageGo to next message
brayan is currently offline brayanFriend
Messages: 2
Registered: December 2011
Junior Member
Okay, lucky shot. I referenced the wrong jboss server runtime on the EJB project. Try to switch to another available library. It will work. Unclear though what's the difference between them - give it a shot.
icon14.gif  Re: CreateProcess 206 error when Run As (long classpath problem) [message #998683 is a reply to message #729049] Thu, 10 January 2013 13:55 Go to previous messageGo to next message
Sébastien Drouard is currently offline Sébastien DrouardFriend
Messages: 1
Registered: January 2013
Junior Member
Hi,

We faced the same problem with our environment lately : we couldn't launch any Junit Test from the IDE (Error 206 : "name or extension too long" message).
We work on Win 7 (x64) OS.
We tried anything from reinstalling JDK to updating to new IDE version (STS, Juno, Indigo...) without success.

We finally succeeded by enabling assertions for JUnit :
Window -> Preferences -> Java -> JUnit -> Enable "Add '-ea' to VM arguments when creating a new JUnit launch configuration"

This solution is a bit funky as it doesn't answer the "name or extension too long" error message.
Re: CreateProcess 206 error when Run As (long classpath problem) [message #1413841 is a reply to message #998683] Fri, 29 August 2014 15:02 Go to previous message
anna op is currently offline anna opFriend
Messages: 1
Registered: August 2014
Junior Member
I would suggest you usin Long Path Tool to eliminate this issue in other ocassions.
Previous Topic:External Tool Issue
Next Topic:Eclipse/Class code for calculating. Please help me.
Goto Forum:
  


Current Time: Mon Dec 22 03:31:29 GMT 2014

Powered by FUDForum. Page generated in 0.01582 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software