Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » (no subject)
(no subject) [message #707204] Mon, 01 August 2011 10:13
bogdan toma is currently offline bogdan tomaFriend
Messages: 38
Registered: February 2010
Member
Hello all,

I am trying to run xwt on rap.
But i am getting this exception:


java.lang.VerifyError: (class: org/eclipse/e4/xwt/internal/utils/UserData, method: getParent signature: (Ljava/lang/Object;)Lorg/eclipse/swt/widgets/Control;) Wrong return type in function
at org.eclipse.e4.xwt.javabean.ResourceLoader.loadCLR(ResourceLoader.java:1362)
at org.eclipse.e4.xwt.javabean.ResourceLoader.doCreate(ResourceLoader.java:546)
at org.eclipse.e4.xwt.javabean.ResourceLoader.createCLRElement(ResourceLoader.java:371)
at org.eclipse.e4.xwt.internal.core.Core.createCLRElement(Core.java:617)
at org.eclipse.e4.xwt.internal.core.Core.load(Core.java:674)
at org.eclipse.e4.xwt.internal.core.Core.load(Core.java:644)
at org.eclipse.e4.xwt.XWTLoader.loadWithOptions(XWTLoader.java:836)
at org.eclipse.e4.xwt.XWT.loadWithOptions(XWT.java:460)
at testing4.XWTComposite.<init>(XWTComposite.java:29)

I am using xwt from e4.11, rap 1.4, jdk1.6.0_14.

Does anybody can confirm that xwt still can be run on rap, according to what is written here "Bug 298589 - make xwt runnable on rap " (bugs.eclipse.org/bugs/show_bug.cgi?id=298589 - the url without https)

I would like to add that in e3.7 xwt is running.

Thank you.
Previous Topic:(no subject)
Next Topic:(no subject)
Goto Forum:
  


Current Time: Thu Dec 18 10:41:05 GMT 2014

Powered by FUDForum. Page generated in 0.09838 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software