Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » Installing Buckminster in Helios requires an old version of EGit/JGit
Installing Buckminster in Helios requires an old version of EGit/JGit [message #703178] Wed, 27 July 2011 09:04 Go to next message
Matthew Webber is currently offline Matthew WebberFriend
Messages: 198
Registered: December 2010
Senior Member
My IDE is Eclipse for RCP developers, Helios SR2. I have already installed Buckminster core and Subclipse support (and it's all working ok).

Now I want to install Buckminster Git support, plus EGit and JGit. However, I get the following reported:

Cannot complete the install because of a conflicting dependency.
Software being installed: Buckminster - Git Support 1.0.360.r11751 (org.eclipse.buckminster.git.feature.feature.group 1.0.360.r11751)
Software being installed: Eclipse EGit 1.0.0.201106090707-r (org.eclipse.egit.feature.group 1.0.0.201106090707-r)
Only one of the following can be installed at once:
Git Team Provider Core (Incubation) 0.11.1 (org.eclipse.egit.core 0.11.1)
Git Team Provider Core 1.0.0.201106090707-r (org.eclipse.egit.core 1.0.0.201106090707-r)
Cannot satisfy dependency:
From: Reader type extension for GIT 1.0.0.r11751 (org.eclipse.buckminster.git 1.0.0.r11751)
To: bundle org.eclipse.egit.core [0.11.0,1.0.0)
Cannot satisfy dependency:
From: Buckminster - Git Support 1.0.360.r11751 (org.eclipse.buckminster.git.feature.feature.group 1.0.360.r11751)
To: org.eclipse.buckminster.git [1.0.0.r11751]
Cannot satisfy dependency:
From: Eclipse EGit 1.0.0.201106090707-r (org.eclipse.egit.feature.group 1.0.0.201106090707-r)
To: org.eclipse.egit.core [1.0.0.201106090707-r]


I looks like Buckminster has an exact version requirement for EGit of 0.11.1. If I untick the "show only latest versions of available software", and then select the older EGit/JGit Incubation 0.11.1 rather than the latest EGit/JGit 1.0.0.201106090707-r, then the install proceeds ok.

Is it possible for Buckminster Git support in Helios to use EGit 1.0.0? I know that it's ok in Indigo, but some of us are still on Helios.

Thanks

Re: Installing Buckminster in Helios requires an old version of EGit/JGit [message #703223 is a reply to message #703178] Wed, 27 July 2011 09:34 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas HallgrenFriend
Messages: 3229
Registered: July 2009
Senior Member
On 2011-07-27 11:04, Matthew Webber wrote:
> Is it possible for Buckminster Git support in Helios to use EGit 1.0.0? I know that it's ok in Indigo, but some of us
> are still on Helios.
>
It's doable of course but I'm afraid that would be a lot more work than just changing the version ranges. EGit/JGit
changed a lot of API's between 0.11.1 and 1.0.0 and we've also changed some of the common classes that the reader types
are based on.

I would of course consider a well tested patch ;-)

Regards,
Thomas Hallgren
Re: Installing Buckminster in Helios requires an old version of EGit/JGit [message #703344 is a reply to message #703223] Wed, 27 July 2011 13:26 Go to previous messageGo to next message
Matthew Webber is currently offline Matthew WebberFriend
Messages: 198
Registered: December 2010
Senior Member
Thanks for letting us know the situation, Thomas - clearly updating the EGit support in Helios is not worth the time required. I'll use this in my push to get our guys over to Indigo.
Matthew
Re: Installing Buckminster in Helios requires an old version of EGit/JGit [message #704091 is a reply to message #703223] Thu, 28 July 2011 09:08 Go to previous messageGo to next message
Carsten Reckord is currently offline Carsten ReckordFriend
Messages: 139
Registered: July 2009
Senior Member
Hi Thomas and Matthew,

Actually, since we're still on Helios too, but wanted the latest Git, I've
built org.eclipse.buckminster.git (version r11751 aka 9ff9606689437) against
the latest EGit/JGit stable-1.0 branch locally a while ago.

It builds without any changes and so far we haven't had any problems with it.

Regards,
Carsten Reckord

On 27.07.2011 11:34, Thomas Hallgren wrote:
> On 2011-07-27 11:04, Matthew Webber wrote:
>> Is it possible for Buckminster Git support in Helios to use EGit 1.0.0? I know that it's ok in Indigo, but some of us
>> are still on Helios.
>>
> It's doable of course but I'm afraid that would be a lot more work than just changing the version ranges. EGit/JGit
> changed a lot of API's between 0.11.1 and 1.0.0 and we've also changed some of the common classes that the reader types
> are based on.
>
> I would of course consider a well tested patch ;-)
>
> Regards,
> Thomas Hallgren
Re: Installing Buckminster in Helios requires an old version of EGit/JGit [message #704294 is a reply to message #704091] Thu, 28 July 2011 12:58 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas HallgrenFriend
Messages: 3229
Registered: July 2009
Senior Member
Did you try using branches or tags?

- thomas

On 2011-07-28 11:08, Carsten Reckord wrote:
> Hi Thomas and Matthew,
>
> Actually, since we're still on Helios too, but wanted the latest Git, I've
> built org.eclipse.buckminster.git (version r11751 aka 9ff9606689437) against
> the latest EGit/JGit stable-1.0 branch locally a while ago.
>
> It builds without any changes and so far we haven't had any problems with it.
>
> Regards,
> Carsten Reckord
>
> On 27.07.2011 11:34, Thomas Hallgren wrote:
>> On 2011-07-27 11:04, Matthew Webber wrote:
>>> Is it possible for Buckminster Git support in Helios to use EGit 1.0.0? I know that it's ok in Indigo, but some of us
>>> are still on Helios.
>>>
>> It's doable of course but I'm afraid that would be a lot more work than just changing the version ranges. EGit/JGit
>> changed a lot of API's between 0.11.1 and 1.0.0 and we've also changed some of the common classes that the reader types
>> are based on.
>>
>> I would of course consider a well tested patch ;-)
>>
>> Regards,
>> Thomas Hallgren
>
Re: Installing Buckminster in Helios requires an old version of EGit/JGit [message #704469 is a reply to message #704294] Thu, 28 July 2011 16:32 Go to previous message
Carsten Reckord is currently offline Carsten ReckordFriend
Messages: 139
Registered: July 2009
Senior Member
I didn't try tags, but branches worked well.

On 28.07.2011 14:58, Thomas Hallgren wrote:
> Did you try using branches or tags?
>
> - thomas
>
> On 2011-07-28 11:08, Carsten Reckord wrote:
>> Hi Thomas and Matthew,
>>
>> Actually, since we're still on Helios too, but wanted the latest Git, I've
>> built org.eclipse.buckminster.git (version r11751 aka 9ff9606689437) against
>> the latest EGit/JGit stable-1.0 branch locally a while ago.
>>
>> It builds without any changes and so far we haven't had any problems with it.
>>
>> Regards,
>> Carsten Reckord
>>
>> On 27.07.2011 11:34, Thomas Hallgren wrote:
>>> On 2011-07-27 11:04, Matthew Webber wrote:
>>>> Is it possible for Buckminster Git support in Helios to use EGit 1.0.0? I know that it's ok in Indigo, but some of us
>>>> are still on Helios.
>>>>
>>> It's doable of course but I'm afraid that would be a lot more work than just changing the version ranges. EGit/JGit
>>> changed a lot of API's between 0.11.1 and 1.0.0 and we've also changed some of the common classes that the reader types
>>> are based on.
>>>
>>> I would of course consider a well tested patch ;-)
>>>
>>> Regards,
>>> Thomas Hallgren
>>
>
Previous Topic:Generic RMAP?
Next Topic:Proposal: simple materialization outside the workspace
Goto Forum:
  


Current Time: Sun Nov 23 02:33:21 GMT 2014

Powered by FUDForum. Page generated in 0.05984 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software