Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Eclipse IDE save undo redo menu entries stay greyed out(command Handlers are failing to display the undo redo and save menu entries of an Eclipse IDE correctly.)
Eclipse IDE save undo redo menu entries stay greyed out [message #700017] Fri, 22 July 2011 13:50 Go to next message
Phil M. Fischer is currently offline Phil M. Fischer
Messages: 60
Registered: November 2010
Location: Germany
Member
Hi everyone,

I am currently developing an RCP based on Eclipse 3.6. The application is based on "org.eclipse.ui.ide.workbench". I am currently failing to enable the entries for "Save, Undo and Redo" in the main menus. Whatever I do they stay grey. I wrote three commandHandlers for:

org.eclipse.ui.file.save
org.eclipse.ui.edit.undo
org.eclipse.ui.edit.redo

Using the same commands in a different popup-menu works fine and they are correctly enabled and disabled. Nevertheless for the main menu they always stay grey.

For the commands:

org.eclipse.ui.edit.cut
org.eclipse.ui.edit.copy
org.eclipse.ui.edit.paste

everything works fine and i get the same behaviour (enabling and disabling) for both menus.

Does anyone have similar problems or does anyone know how to handle this?

Cheers

Phil

[Updated on: Fri, 22 July 2011 14:09]

Report message to a moderator

(no subject) [message #703793 is a reply to message #700017] Wed, 27 July 2011 18:50 Go to previous message
Wim Jongman is currently offline Wim Jongman
Messages: 418
Registered: July 2009
Senior Member
Hi Phil,

Try this in your ApplicationActionBarAdvisor.makeActions(IWorkbencWindow):

register(ActionFactory.PASTE.create(window));

etc ..

I'm not sure exactly what it does. I have a vague idea of it connecting the
global action to the command framework.

Regards,

Wim

> Hi everyone,
>
> I am currently developing an RCP. The application is based on
"org.eclipse.ui.ide.workbench". I am currently failing to enable the entries
for "Save, Undo and Redo" in the main menus. Whatever I do they stay grey. I
wrote three commandHandlers for:
>
> org.eclipse.ui.file.save
> org.eclipse.ui.edit.undo
> org.eclipse.ui.edit.redo
>
> Using the same commands in a different popup-menu works fine and they are
correctly enabled and disabled. Nevertheless for the main menu they always
stay grey.
>
> For the commands:
>
> org.eclipse.ui.edit.cut
> org.eclipse.ui.edit.copy
> org.eclipse.ui.edit.paste
>
> everything works fine and i get the same behaviour (enabling and disabling)
for both menus.
>
> Does anyone have similar problems or does anyone know how to handle this?
>
> Cheers
>
> Phil
Previous Topic:SWT components not displaying after migrating to helios or indigo
Next Topic:Error:Transfer RCP project with Multi Page editor
Goto Forum:
  


Current Time: Thu Aug 28 09:19:53 EDT 2014

Powered by FUDForum. Page generated in 0.02079 seconds