Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » Unable to resolve Installable Unit
Unable to resolve Installable Unit [message #699265] Thu, 21 July 2011 08:29 Go to next message
Markus Stutz is currently offline Markus Stutz
Messages: 22
Registered: September 2010
Location: Switzerland
Junior Member
Hi all

In our Project we defined a baseline in a BOM file, which require specific features and bundels from a p2 repository.

Now, if I import these bom file I get following error message:

ERROR   [0002] : Unable to resolve Installable Unit com.csg.fw.runtime.source 0.1.0.201107060933 in repository file:///C:/Apps/p2/com.csg.rsk.carat.productline.p2.update
Errors and Warnings
TAG-ID 0002 = Query for com.csg.components.baseline:buckminster, path: com.csg.components.baseline:buckminster$0.1.0.qualifier


The problem is, these Source bundle is on the right place and has the right configurations. I tryed it with other versions and I get the same error with the new versionnumber.
If I generate an completle new baseline on "qualifier" versions, is everything working. Is there something wrong in my bom or is there an other mistake?


Thank you & Cheers
Markus


Cheers,
Markus
Re: Unable to resolve Installable Unit [message #699342 is a reply to message #699265] Thu, 21 July 2011 11:03 Go to previous message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3229
Registered: July 2009
Senior Member
On 2011-07-21 10:29, Markus Stutz wrote:
> Hi all
>
> In our Project we defined a baseline in a BOM file, which require specific features and bundels from a p2 repository.
>
> Now, if I import these bom file I get following error message:
>
>
> ERROR [0002] : Unable to resolve Installable Unit com.csg.fw.runtime.source 0.1.0.201107060933 in repository
> file:///C:/Apps/p2/com.csg.rsk.carat.productline.p2.update
> Errors and Warnings
> TAG-ID 0002 = Query for com.csg.components.baseline:buckminster, path:
> com.csg.components.baseline:buckminster$0.1.0.qualifier
>
>
> The problem is, these Source bundle is on the right place and has the right configurations. I tryed it with other
> versions and I get the same error with the new versionnumber. If I generate an completle new baseline on "qualifier"
> versions, is everything working. Is there something wrong in my bom or is there an other mistake?
>
>
I think a bit more info is needed in order to answer that. What reader type are you using? What component types are set
on your provider? How did you create your BOM? How did you create your p2 repository? How did you verify that the entry
was present? Are other bundles from the same repository found?

- thomas


> Thank you & Cheers
> Markus
Previous Topic:Path to current target platform
Next Topic:{fs:translations} does not exist
Goto Forum:
  


Current Time: Sun Sep 21 10:19:31 GMT 2014

Powered by FUDForum. Page generated in 0.02048 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software