Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » Package explorer broken with Working Sets as Top Level Elements
Package explorer broken with Working Sets as Top Level Elements [message #690424] Wed, 29 June 2011 09:44 Go to next message
Philippe Couton is currently offline Philippe Couton
Messages: 13
Registered: July 2009
Junior Member
Hi all,

I have updated today my Eclipse from Helios to Indigo.

I usually works with the package explorer focused to the active task,
and using Working Sets as Top Level Elements. This configuration worked
well with Eclipse 3.6.1.

This no longer works in version 3.7: the package explorer shows me
Working Sets unrelated to my active task, and even it shows no files
within these Working Sets. I have to unselect "Focus on Active Task" or
to use Projects as Top Level Elements to be able to see the files
related to my active task.

Is there anyone with the same problem? Do I have missed to configure
some new parameter to solve this issue?

Philippe
Re: Package explorer broken with Working Sets as Top Level Elements [message #691219 is a reply to message #690424] Thu, 30 June 2011 20:43 Go to previous messageGo to next message
Steffen Pingel is currently offline Steffen Pingel
Messages: 706
Registered: July 2009
Senior Member
The problem is tracked on this bug:

247373: [context][java] working sets always shown in focused package
explorer
https://bugs.eclipse.org/bugs/show_bug.cgi?id=247373

Unfortunately we do not have a work-around or solution, yet.

Steffen


Philippe Couton wrote:

> Hi all,
>
> I have updated today my Eclipse from Helios to Indigo.
>
> I usually works with the package explorer focused to the active task,
> and using Working Sets as Top Level Elements. This configuration worked
> well with Eclipse 3.6.1.
>
> This no longer works in version 3.7: the package explorer shows me
> Working Sets unrelated to my active task, and even it shows no files
> within these Working Sets. I have to unselect "Focus on Active Task" or
> to use Projects as Top Level Elements to be able to see the files
> related to my active task.
>
> Is there anyone with the same problem? Do I have missed to configure
> some new parameter to solve this issue?
>
> Philippe

--
Steffen Pingel
Committer, http://eclipse.org/mylyn
Senior Developer, http://tasktop.com
Re: Package explorer broken with Working Sets as Top Level Elements [message #692312 is a reply to message #691219] Mon, 04 July 2011 03:17 Go to previous messageGo to next message
Philippe Couton is currently offline Philippe Couton
Messages: 13
Registered: July 2009
Junior Member
I am not sure this bug matches my problem.

Currently, my package explorer shows nothing in focused mode when it is
configured to work with working sets as top level elements: no working
sets (interesting or not), no files.

It just shows the message "Empty task context, unfocus or Alt+click".
However, my context is not empty, since I can display it in Context tab
of the task.

Philippe


Steffen Pingel wrote:
> The problem is tracked on this bug:
>
> 247373: [context][java] working sets always shown in focused package
> explorer
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=247373
>
> Unfortunately we do not have a work-around or solution, yet.
>
> Steffen
>
>
> Philippe Couton wrote:
>
>> Hi all,
>>
>> I have updated today my Eclipse from Helios to Indigo.
>>
>> I usually works with the package explorer focused to the active task,
>> and using Working Sets as Top Level Elements. This configuration worked
>> well with Eclipse 3.6.1.
>>
>> This no longer works in version 3.7: the package explorer shows me
>> Working Sets unrelated to my active task, and even it shows no files
>> within these Working Sets. I have to unselect "Focus on Active Task" or
>> to use Projects as Top Level Elements to be able to see the files
>> related to my active task.
>>
>> Is there anyone with the same problem? Do I have missed to configure
>> some new parameter to solve this issue?
>>
>> Philippe
Re: Package explorer broken with Working Sets as Top Level Elements [message #713654 is a reply to message #692312] Mon, 08 August 2011 14:27 Go to previous messageGo to next message
Steffen Pingel is currently offline Steffen Pingel
Messages: 706
Registered: July 2009
Senior Member
I haven't seen that problem. Please feel free to open a new bug and include
information about the type of files in the context and screenshots if
possible.

Thanks.

Steffen


Philippe Couton wrote:

> I am not sure this bug matches my problem.
>
> Currently, my package explorer shows nothing in focused mode when it is
> configured to work with working sets as top level elements: no working
> sets (interesting or not), no files.
>
> It just shows the message "Empty task context, unfocus or Alt+click".
> However, my context is not empty, since I can display it in Context tab
> of the task.
>
> Philippe
>
>
> Steffen Pingel wrote:
>> The problem is tracked on this bug:
>>
>> 247373: [context][java] working sets always shown in focused package
>> explorer
>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=247373
>>
>> Unfortunately we do not have a work-around or solution, yet.
>>
>> Steffen
>>
>>
>> Philippe Couton wrote:
>>
>>> Hi all,
>>>
>>> I have updated today my Eclipse from Helios to Indigo.
>>>
>>> I usually works with the package explorer focused to the active task,
>>> and using Working Sets as Top Level Elements. This configuration worked
>>> well with Eclipse 3.6.1.
>>>
>>> This no longer works in version 3.7: the package explorer shows me
>>> Working Sets unrelated to my active task, and even it shows no files
>>> within these Working Sets. I have to unselect "Focus on Active Task" or
>>> to use Projects as Top Level Elements to be able to see the files
>>> related to my active task.
>>>
>>> Is there anyone with the same problem? Do I have missed to configure
>>> some new parameter to solve this issue?
>>>
>>> Philippe

--
Steffen Pingel
Committer, http://eclipse.org/mylyn
Senior Developer, http://tasktop.com
Re: Package explorer broken with Working Sets as Top Level Elements [message #713922 is a reply to message #713654] Tue, 09 August 2011 07:44 Go to previous message
Philippe Couton is currently offline Philippe Couton
Messages: 13
Registered: July 2009
Junior Member
I have created the Bug 353721
(https://bugs.eclipse.org/bugs/show_bug.cgi?id=353721), with snapshots.
About the context, it contains only Java files.

Philippe


Steffen Pingel wrote:
> I haven't seen that problem. Please feel free to open a new bug and include
> information about the type of files in the context and screenshots if
> possible.
>
> Thanks.
>
> Steffen
>
>
> Philippe Couton wrote:
>
>> I am not sure this bug matches my problem.
>>
>> Currently, my package explorer shows nothing in focused mode when it is
>> configured to work with working sets as top level elements: no working
>> sets (interesting or not), no files.
>>
>> It just shows the message "Empty task context, unfocus or Alt+click".
>> However, my context is not empty, since I can display it in Context tab
>> of the task.
>>
>> Philippe
>>
>>
>> Steffen Pingel wrote:
>>> The problem is tracked on this bug:
>>>
>>> 247373: [context][java] working sets always shown in focused package
>>> explorer
>>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=247373
>>>
>>> Unfortunately we do not have a work-around or solution, yet.
>>>
>>> Steffen
>>>
>>>
>>> Philippe Couton wrote:
>>>
>>>> Hi all,
>>>>
>>>> I have updated today my Eclipse from Helios to Indigo.
>>>>
>>>> I usually works with the package explorer focused to the active task,
>>>> and using Working Sets as Top Level Elements. This configuration worked
>>>> well with Eclipse 3.6.1.
>>>>
>>>> This no longer works in version 3.7: the package explorer shows me
>>>> Working Sets unrelated to my active task, and even it shows no files
>>>> within these Working Sets. I have to unselect "Focus on Active Task" or
>>>> to use Projects as Top Level Elements to be able to see the files
>>>> related to my active task.
>>>>
>>>> Is there anyone with the same problem? Do I have missed to configure
>>>> some new parameter to solve this issue?
>>>>
>>>> Philippe
Previous Topic:Mylyn 3.6.1 is now available
Next Topic:(no subject)
Goto Forum:
  


Current Time: Tue Sep 02 00:33:30 EDT 2014

Powered by FUDForum. Page generated in 0.04530 seconds