Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Publish working sporadically
Publish working sporadically [message #688831] Sat, 25 June 2011 22:32 Go to next message
Mike Cooper is currently offline Mike CooperFriend
Messages: 46
Registered: February 2011
Member
I'm having problems with Publish not working consistantly. I have my workspace/project set to automatic publish. Automatic publish seems to work fine for the first dozen or some saves of Java files but then just stops. A Clean... from the server menu does absolutely nothing at least viewed from the eclipse GUI. If I delete the server and re-add it, publish works again but stops after another dozen or so saves.

This problem started a few weeks ago. I can't correlate it with any specific environment changes, though. Previously it worked fine.

I'm using Eclipse helios and have applied all current updates. Platform is Linux x64 on RHEL 5.3. Publishing to Glassfish 3.1 (located on same host as Eclipse).

Any suggestions?

mike
Re: Publish working sporadically [message #688841 is a reply to message #688831] Sat, 25 June 2011 23:28 Go to previous messageGo to next message
Mike Cooper is currently offline Mike CooperFriend
Messages: 46
Registered: February 2011
Member
Forgot to mention this problem usually happens when saving Java source files in a dependend project. That project is listed in the Deployment Description as well as in the Build Path as a dependent Project and listed for Export as well.

mike
Re: Publish working sporadically [message #689369 is a reply to message #688841] Mon, 27 June 2011 14:08 Go to previous messageGo to next message
Larry Isaacs is currently offline Larry IsaacsFriend
Messages: 1313
Registered: July 2009
Senior Member
On 6/25/2011 7:28 PM, Mike Cooper wrote:
> Forgot to mention this problem usually happens when saving Java source
> files in a dependend project. That project is listed in the Deployment
> Description as well as in the Build Path as a dependent Project and
> listed for Export as well.
>
> mike
>

The Glassfish server plug-ins are responsible for publishing to the
server. You may want to ask this on a Glassfish forum or newsgroup for
better visibility. They would have to determine where the problem
originates.

Cheers,
Larry
Re: Publish working sporadically [message #689480 is a reply to message #689369] Mon, 27 June 2011 17:50 Go to previous message
Mike Cooper is currently offline Mike CooperFriend
Messages: 46
Registered: February 2011
Member
Will do. Thanks Larry!

mike
Previous Topic:Deploying remote web resources
Next Topic:Eclipse WTP Web Service, Axis2, and JAR project dependencies
Goto Forum:
  


Current Time: Sun Dec 21 06:53:34 GMT 2014

Powered by FUDForum. Page generated in 0.02119 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software