Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » {fs:translations} does not exist
{fs:translations} does not exist [message #688206] Fri, 24 June 2011 07:14 Go to next message
techteam is currently offline techteamFriend
Messages: 54
Registered: September 2010
Member
Hi,
I try to rebuild a simple exmaple by using Buckminster.
I read Ralf Ebert's tutorial and follow his steps.
In diffrent, I use the new Eclipse 3.7 and have installed Buckminster from here

While try to build the site.p2, I get the following log:
[start org.eclipse.swt:osgi.bundle$3.7.0.v3735b#target.fragments]
[end org.eclipse.swt:osgi.bundle$3.7.0.v3735b#target.fragments]
[start org.eclipse.ui:osgi.bundle$3.7.0.I20110602-0100#target.fragments]
[end org.eclipse.ui:osgi.bundle$3.7.0.I20110602-0100#target.fragments]
[start org.eclipse.equinox.launcher:osgi.bundle$1.2.0.v20110502#target.fragments]
[start ....
...
[start com.example.mail.feature:eclipse.feature$1.0.0.qualifier#manifest]
[end com.example.mail.feature:eclipse.feature$1.0.0.qualifier#manifest]
[start com.example.mail.feature:eclipse.feature$1.0.0.qualifier#feature.jar]
[end com.example.mail.feature:eclipse.feature$1.0.0.qualifier#feature.jar]
[start com.example.mail:osgi.bundle$1.0.0.qualifier#source.manifest]
[end com.example.mail:osgi.bundle$1.0.0.qualifier#source.manifest]
[start com.example.mail:osgi.bundle$1.0.0.qualifier#source.bundle.jar]
[end com.example.mail:osgi.bundle$1.0.0.qualifier#source.bundle.jar]
[start com.example.mail.feature:eclipse.feature$1.0.0.qualifier#source.manifest]
org.eclipse.core.runtime.CoreException: C:\Users\???\eclipse 3.7.0\configuration\org.eclipse.osgi\bundles\750\1\.cp\org\eclipse\buckminster\pde\antscripts\build.xml:224: C:\Users\???\eclipse 3.7.0\{fs:translations} does not exist.
C:\Users\???\eclipse 3.7.0\configuration\org.eclipse.osgi\bundles\750\1\.cp\org\eclipse\buckminster\pde\antscripts\build.xml:224: C:\Users\???\eclipse 3.7.0\{fs:translations} does not exist.: C:\Users\???\eclipse 3.7.0\{fs:translations} does not exist.

What am I doing wrong, or do I use a wrong Buckminster build?
The adress
http://download.eclipse.org/tools/buckminster/updates doesn't work for me.

Greetings
Heiko
Re: {fs:translations} does not exist [message #688221 is a reply to message #688206] Fri, 24 June 2011 07:43 Go to previous messageGo to next message
Matthew Webber is currently offline Matthew WebberFriend
Messages: 198
Registered: December 2010
Senior Member
I am also getting that (or something very similar), running Buckminster headless under linux. It works with 3.6.2.
Matthew
Re: {fs:translations} does not exist [message #688478 is a reply to message #688221] Fri, 24 June 2011 19:08 Go to previous messageGo to next message
Miles Parker is currently offline Miles ParkerFriend
Messages: 1340
Registered: July 2009
Senior Member
I see this two, but in my case I just get /mypath/{fs does not exist. There is something up with how the sp: paramaters are replaced, but I haven't really been able to puzzle it out. What does your prouct.ant and buckminster properties look like?
Re: {fs:translations} does not exist [message #690283 is a reply to message #688206] Wed, 29 June 2011 09:57 Go to previous messageGo to next message
techteam is currently offline techteamFriend
Messages: 54
Registered: September 2010
Member
Today I have updated the buckminster to Buckminster - Core
1.4.0.v20110628-2229.

Now I try it again with the example from Ralf Ebert -> fail :(

Now I try the first example from the BuckyBook -> Chapter 13:
and again it fails with the same error:

org.eclipse.core.runtime.CoreException: C:\Users\???\eclipse
3.7.0\configuration\org.eclipse.osgi\bundles\786\1\.cp\org\eclipse\buckminster\pde\antscripts\build.xml:224:
C:\Users\???\eclipse 3.7.0\{fs:translations} does not exist.
C:\Users\???\eclipse
3.7.0\configuration\org.eclipse.osgi\bundles\786\1\.cp\org\eclipse\buckminster\pde\antscripts\build.xml:224:
C:\Users\???\eclipse 3.7.0\{fs:translations} does not exist.:
C:\Users\???\eclipse 3.7.0\{fs:translations} does not exist.

My Buckminste proterities are:
# Where all the output should go
buckminster.output.root=${user.home}/demosite
# Where the temp files should go
buckminster.temp.root=${user.home}/tmp/demosite.tmp
# How .qualifier in versions should be replaced
qualifier.replacement.*=generator:lastRevision


I have no self defined product.ant at the moment.





Am 24.06.2011 09:14, schrieb forums-noreply@eclipse.org:
> Hi,
> I try to rebuild a simple exmaple by using Buckminster.
> I read
> http://akravets.blogspot.com/2011/04/simplest-possible-buckminster-example.html
> tutorial and follow his steps.
> In diffrent, I use the new Eclipse 3.7 and have installed Buckminster
> from http://download.eclipse.org/tools/buckminster/updates-3.7
>
> While try to build the site.p2, I get the following log:
> [start org.eclipse.swt:osgi.bundle$3.7.0.v3735b#target.fragments]
> [end org.eclipse.swt:osgi.bundle$3.7.0.v3735b#target.fragments]
> [start org.eclipse.ui:osgi.bundle$3.7.0.I20110602-0100#target.fragments]
> [end org.eclipse.ui:osgi.bundle$3.7.0.I20110602-0100#target.fragments]
> [start
> org.eclipse.equinox.launcher:osgi.bundle$1.2.0.v20110502#target.fragments]
> [start ....
> ..
> [start com.example.mail.feature:eclipse.feature$1.0.0.qualifier#manifest]
> [end com.example.mail.feature:eclipse.feature$1.0.0.qualifier#manifest]
> [start
> com.example.mail.feature:eclipse.feature$1.0.0.qualifier#feature.jar]
> [end com.example.mail.feature:eclipse.feature$1.0.0.qualifier#feature.jar]
> [start com.example.mail:osgi.bundle$1.0.0.qualifier#source.manifest]
> [end com.example.mail:osgi.bundle$1.0.0.qualifier#source.manifest]
> [start com.example.mail:osgi.bundle$1.0.0.qualifier#source.bundle.jar]
> [end com.example.mail:osgi.bundle$1.0.0.qualifier#source.bundle.jar]
> [start
> com.example.mail.feature:eclipse.feature$1.0.0.qualifier#source.manifest]
> org.eclipse.core.runtime.CoreException: C:\Users\???\eclipse
> 3.7.0\configuration\org.eclipse.osgi\bundles\750\1\.cp\org\eclipse\buckminster\pde\antscripts\build.xml:224:
> C:\Users\???\eclipse 3.7.0\{fs:translations} does not exist.
> C:\Users\???\eclipse
> 3.7.0\configuration\org.eclipse.osgi\bundles\750\1\.cp\org\eclipse\buckminster\pde\antscripts\build.xml:224:
> C:\Users\???\eclipse 3.7.0\{fs:translations} does not exist.:
> C:\Users\???\eclipse 3.7.0\{fs:translations} does not exist.
>
> What am I doing wrong, or do I use a wrong Buckminster build?
> The adress http://download.eclipse.org/tools/buckminster/updates doesn't
> work for me.
>
> Greetings
> Heiko
Re: {fs:translations} does not exist [message #694211 is a reply to message #690283] Fri, 08 July 2011 06:14 Go to previous messageGo to next message
Adrian Gaberell is currently offline Adrian GaberellFriend
Messages: 9
Registered: July 2011
Junior Member
Hi,

We have detected the same failure with buckminster 3.7.
As we've found out, a change in build.xml in org.eclipse.buckminster.pde has been introduced with Bug 336141 which eventually lead to this failure.
As a workaround you have to make sure the attribute 'bin.includes' is contained in the CSpec of the feature.
(We've achieved this by adding a file contained in a subfolder to the bin.includes property in the build.properties of our feature project)

bin.includes = feature.xml,\
               icons/JSE-Icon.ico   #<-- workaround 


Maybe we should file a bug for that?

greetings adrian
Re: {fs:translations} does not exist [message #694300 is a reply to message #694211] Fri, 08 July 2011 09:39 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas HallgrenFriend
Messages: 3232
Registered: July 2009
Senior Member
On 2011-07-08 08:14, adrian gaberell wrote:
> Hi,
>
> We have detected the same failure with buckminster 3.7.
> As we've found out, a change in build.xml in org.eclipse.buckminster.pde has been introduced with Bug 336141 which
> eventually lead to this failure.
> As a workaround you have to make sure the attribute 'bin.includes' is contained in the CSpec of the feature.
> (We've achieved this by adding a file contained in a subfolder to the bin.includes property in the build.properties of
> our feature project)
>
>
> bin.includes = feature.xml,\
> icons/JSE-Icon.ico #<-- workaround
>
> Maybe we should file a bug for that?
>
Please do. But before you do that, can you please check that you run the latest version? I did a change quite recently
that I thought would have fixed this problem.

Regards,
Thomas Hallgren
Re: {fs:translations} does not exist [message #697097 is a reply to message #694300] Fri, 15 July 2011 14:27 Go to previous messageGo to next message
Matthew Webber is currently offline Matthew WebberFriend
Messages: 198
Registered: December 2010
Senior Member
The problem was solved for me when I updated (tested in Indigo IDE only).
Matthew
Re: {fs:translations} does not exist [message #699740 is a reply to message #694300] Fri, 22 July 2011 08:25 Go to previous message
Adrian Gaberell is currently offline Adrian GaberellFriend
Messages: 9
Registered: July 2011
Junior Member
hi,

we updated our environment from version 1.4.0.r11798 to version 1.4.0.v20110712-1350 and the problem was solved.

thanks, adrian
Previous Topic:Unable to resolve Installable Unit
Next Topic:Dynamic branchToTag in cquery
Goto Forum:
  


Current Time: Fri Dec 19 23:31:30 GMT 2014

Powered by FUDForum. Page generated in 0.02275 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software