Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » New expert help, runtime plug-in error
New expert help, runtime plug-in error [message #68295] Thu, 16 July 2009 23:23
Tee Bee is currently offline Tee Bee
Messages: 18
Registered: July 2009
Junior Member
Hi all,

I'm quite a newbie when it comes to plug-in development. However, I do
believe that I've encountered some issues that are quite mysterious. So if
anyone of you experts have some minutes available, I would be sincerely
happy.

Ok, here goes:
1. I create a template plug-in (popup menu). Everything works fine when
using the plug-in
2. I create a simple type in a new package within the context of my
plug-in project and import it in the action class. Everything works fine.
3. I create a simple class for finding/creating a
org.eclipse.ui.console.MessageConsole, and things start to happen; I get
noClassDefFound exceptions on the imported classes like MessageConsole,
and I get messages saying that "Could not create action delegate for
id..." and "Plug-in ... was unable to instatiate class <action class>. All
imported packages/types are found in Plug-in Dependencies in my project,
and listed under Require-Bundle/Import-Package in manifest.mf. I've also
tried a fresh eclipse bundle. I've searched the Internet, made new
projects, added files to build.properties, manifest.mf, tried adding files
to classpath, added files to the Extra Classpath Entries, etc. In short,
I've spent many hours on this problem with no solution. It somehow seems
like there is an inconsistency in eclipse. But then again, I've downloaded
a couple of fresh versions. Anyone who has any advices? In that case, it
is hugely appreciated!

Have a good day!
Previous Topic:Headless signing just our JARs
Next Topic:New expert help, runtime plug-in error
Goto Forum:
  


Current Time: Tue Jul 29 15:07:45 EDT 2014

Powered by FUDForum. Page generated in 0.01867 seconds