Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Problem with XDebug on Linux
Problem with XDebug on Linux [message #675680] Wed, 01 June 2011 03:50 Go to next message
Missing name Missing name is currently offline Missing name Missing name
Messages: 17
Registered: June 2010
Junior Member
hi, i use Eclipse on Windows and I have no problems.
everything works great.

now i switched on Linux (Ubuntu 11.04) and i'm having some problems with debug.
infact i get everything, but the debugger won't stop on my break points.
the weird thing is that everything starts normally: i get a new page on my browser when the debugger start, eclipse get the xdebug session and when i stop the debugger i get the "debug session ended" tab on my browser, but Eclipse won't stop on my break points!

even if i check "break on the first line"!

any help?
any of you uses eclipse on linux?

thanks in advance
Re: Problem with XDebug on Linux [message #675930 is a reply to message #675680] Wed, 01 June 2011 21:10 Go to previous messageGo to next message
Toshihiro Izumi is currently offline Toshihiro Izumi
Messages: 338
Registered: July 2009
Location: Japan
Senior Member
Did you set xdebug directives in your php.ini(or xdebug.ini) ?
xdebug.remote_enable=On
Re: Problem with XDebug on Linux [message #675974 is a reply to message #675680] Thu, 02 June 2011 04:51 Go to previous messageGo to next message
Missing name Missing name is currently offline Missing name Missing name
Messages: 17
Registered: June 2010
Junior Member
yes, i did.
this is my php.ini file:

extension=xdebug.so

zend_extension=/usr/lib/php5/20090626+lfs/xdebug.so
xdebug.profiler_enable = On
xdebug.remote_enable=On
xdebug.remote_host="localhost"
xdebug.remote_port=9000
xdebug.remote_handler="dbgp"
xdebug.remote_autostart=1

btw i ran some test and i saw that if i put a xdebug_break() into my code the debugger stops...

any help?
Re: Problem with XDebug on Linux [message #676135 is a reply to message #675974] Thu, 02 June 2011 19:39 Go to previous messageGo to next message
Toshihiro Izumi is currently offline Toshihiro Izumi
Messages: 338
Registered: July 2009
Location: Japan
Senior Member
>extension=xdebug.so
Delete this line.
Re: Problem with XDebug on Linux [message #676172 is a reply to message #676135] Fri, 03 June 2011 01:52 Go to previous messageGo to next message
Missing name Missing name is currently offline Missing name Missing name
Messages: 17
Registered: June 2010
Junior Member
it works!

i owe you a beer Very Happy
Re: Problem with XDebug on Linux [message #683295 is a reply to message #676135] Mon, 13 June 2011 08:44 Go to previous messageGo to next message
Lorenzo Bettini is currently offline Lorenzo Bettini
Messages: 1260
Registered: July 2009
Senior Member
On 06/03/2011 01:39 AM, Toshihiro Izumi wrote:
>> extension=xdebug.so
> Delete this line.

why should it be deleted? Isn't that the library for php debugging?

--
Lorenzo Bettini, PhD in Computer Science, DI, Univ. Torino
ICQ# lbetto, 16080134 (GNU/Linux User # 158233)
HOME: http://www.lorenzobettini.it MUSIC: http://www.purplesucker.com
http://www.myspace.com/supertrouperabba
BLOGS: http://tronprog.blogspot.com http://longlivemusic.blogspot.com
http://www.gnu.org/software/src-highlite
http://www.gnu.org/software/gengetopt
http://www.gnu.org/software/gengen http://doublecpp.sourceforge.net
Re: Problem with XDebug on Linux [message #683572 is a reply to message #683295] Mon, 13 June 2011 22:47 Go to previous message
Toshihiro Izumi is currently offline Toshihiro Izumi
Messages: 338
Registered: July 2009
Location: Japan
Senior Member
You missed
>zend_extension=/usr/lib/php5/20090626+lfs/xdebug.so
in the message #675974.

see also http://www.xdebug.org/docs/faq
Previous Topic:missing org.eclipse.php_feature.feature.group
Next Topic:Error comparing files
Goto Forum:
  


Current Time: Mon Apr 21 08:53:02 EDT 2014

Powered by FUDForum. Page generated in 0.04133 seconds